Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » m2eclipse with svn:// ?
m2eclipse with svn:// ? [message #643273] Mon, 06 December 2010 11:03 Go to next message
OG  is currently offline OG
Messages: 1
Registered: December 2010
Junior Member
Hello,

I have a SVN repo that is behind a svn://.... URL.
I have Eclipse 3.5.2 and m2eclipse 0.12.0.20101115

But it looks like I am unable to connect to this repo. When I go to Windows > Maven and look at Maven Repositories, I see m2eclipse recognized the existence of my repo that's behind svn://....

But if I then select Update Index I get a message like this in Eclipse console:

Unable to update index for foo-repo|svn:svn://....

I've also installed Subversion in hopes of that coming with something that makes it possible for m2eclipse to talk to my SVN repo, but no luck - I get the same error.

Is there any way to get to the repo behind svn:// with m2eclipse?

Thanks,
Otis
Re: m2eclipse with svn:// ? [message #646010 is a reply to message #643273] Tue, 21 December 2010 14:57 Go to previous message
andy  is currently offline andy
Messages: 5
Registered: June 2010
Junior Member
Hello,

a SVN Repository never exists in View Maven Repositories. In this View are only Maven Repositories and not SVN Repositories.

In the View "Maven Repositories" you only can update indexes of Maven Repositories and not from SVN Repositories.

If you want to check out projects from a SVN Repository you have to open the View SVN Repositories. There you can add a Repository Locations like "svn://..." or "http://...." or "file://....".

If you have no View SVN Repositories you have to install the svn-Plugin "Subversive".



Previous Topic:Publish to server or WAR export includes "provided"-scope dependencies
Next Topic:Installing m2eclipse for Eclipse Java EE
Goto Forum:
  


Current Time: Thu Oct 02 12:28:54 GMT 2014

Powered by FUDForum. Page generated in 0.18990 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software