Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Problem opening JSP with web page editor(java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters in escape (%) pattern)
Problem opening JSP with web page editor [message #642695] Thu, 02 December 2010 12:10 Go to next message
rssole is currently offline rssole
Messages: 3
Registered: November 2010
Junior Member
Hi, I am facing strange issue and any help/hint from someone who possibly faced with same problem is appreciated.

I've posted this previously on other forum and got suggestion to re-post it here.

I am using Eclipse 3.6 SR1 (build: 20100917-0705)

When I try to open some JSPs with Wep Page Editor (WTP) I am getting the following exception:

java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "=r" 	at java.net.URLDecoder.decode(Unknown Source) 	at  org.eclipse.jst.pagedesigner.utils.ProjectResolver.getLocati onByURI(ProjectResolver.java:372) 	at  org.eclipse.jst.pagedesigner.utils.ProjectResolver.getLocati onByURI(ProjectResolver.java:500) 	at  org.eclipse.jst.pagedesigner.utils.ProjectResolver.getLocati onByURI(ProjectResolver.java:489) 	at  org.eclipse.wst.html.core.internal.htmlcss.URLModelProvider. resolveURI(URLModelProvider.java:401) 	at  org.eclipse.wst.html.core.internal.htmlcss.URLModelProvider. getCommonModelFor(URLModelProvider.java:86)


Some JSPs opens no problem.

I can email problematic page to anyone interested.

What I can add also is that in 3.5 (Galileo) all pages open no problem.

Thanks.
Re: Problem opening JSP with web page editor [message #648168 is a reply to message #642695] Tue, 11 January 2011 15:12 Go to previous messageGo to next message
Bonus  is currently offline Bonus
Messages: 1
Registered: January 2011
Junior Member
I am having the same Exact problem, and has become really annoying. If you find a solution please share the information. Regards Ed.
Re: Problem opening JSP with web page editor [message #648173 is a reply to message #642695] Tue, 11 January 2011 15:51 Go to previous message
Russell Bateman is currently offline Russell Bateman
Messages: 3196
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2010.12.02 5:10, rssole wrote:
> Hi, I am facing strange issue and any help/hint from someone who
> possibly faced with same problem is appreciated.
>
> I've posted this previously on other forum and got suggestion to re-post
> it here.
>
> I am using Eclipse 3.6 SR1 (build: 20100917-0705)
>
> When I try to open some JSPs with Wep Page Editor (WTP) I am getting the
> following exception:
>
> java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters
> in escape (%) pattern - For input string: "=r" at
> [snip]
>
> I can email problematic page to anyone interested.
>
> What I can add also is that in 3.5 (Galileo) all pages open no problem.

If I were diagnosing this problem, regardless of whether it worked in
another version or not, I would want to know the command string (URL)
because as soon as I see "illegal hex characters" I begin to think that
something is malformed in the URL. Post that string here to help someone
answer your question.
Previous Topic:Web Page editor only shows me some part of a file
Next Topic:A workshop on how to integrate eSignature into your Java app
Goto Forum:
  


Current Time: Tue Sep 23 18:40:29 GMT 2014

Powered by FUDForum. Page generated in 0.06649 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software