Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Helios - Metro JAX-WS web service runtime
Helios - Metro JAX-WS web service runtime [message #641776] Sat, 27 November 2010 16:44 Go to next message
mark streit is currently offline mark streit
Messages: 11
Registered: July 2009
Junior Member
Hello, Just installed the latest Helios SR1 release and I have a question. I have configured Server runtimes for the various servers such as Tomcat 6, 7, Geronimo 2.1, and Glassfish v3. When creating a web service project, I am presented with all of these server runtimes, no problem. However, as for Web Service runtimes I am presented only w/ Axis 1, Axis2, and Apache CXF which I really don't want to use at all for anything. I would like to have the option for the Metro JAX-WS runtime option. I have tried installing plugins for both the Oracle tools and Glassfish tools but without any success in seeing a Metro JAX-WS web service runtime option. Any suggestions would be apprectiated.

Thanks in advance.
Re: Helios - Metro JAX-WS web service runtime [message #643086 is a reply to message #641776] Fri, 03 December 2010 23:36 Go to previous messageGo to next message
mark streit is currently offline mark streit
Messages: 11
Registered: July 2009
Junior Member
I found this article from well over a year ago - http://blogs.sun.com/arungupta/entry/totd_98_create_a_metro - it's from Arun Gupta's blog. It shows after installation, the Metro JAX-WS runtime as a web service runtime option. I can't seem to get this to work on Helios, however.

Has anyone else tried w/ the Helios release?
Re: Helios - Metro JAX-WS web service runtime [message #646855 is a reply to message #643086] Sat, 01 January 2011 10:24 Go to previous message
DM  is currently offline DM
Messages: 1
Registered: January 2011
Junior Member
I've done. but did not found standalone plugin.
I did:
1 download bundle on which the article is linked.
2 install it - it install another eclipse instance with installed METRO plugins.
3 go to <bundle folder>/dropins/ find metro folder
4 copy it to <your eclipse instance>/dropins/
it has some limitations in project facets, i found Dynamic Web module max version 2.5 instead of 3.0

[Updated on: Sat, 01 January 2011 10:24]

Report message to a moderator

Previous Topic:XML editor - Show In Package Explorer - Cannot reveal the selected element
Next Topic:InputStream in the WebPageEditor
Goto Forum:
  


Current Time: Tue Jul 22 13:29:42 EDT 2014

Powered by FUDForum. Page generated in 0.01478 seconds