Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Error within Web Page Editor (Web Tools Platform)(Could not open the editor: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "=r")
Error within Web Page Editor (Web Tools Platform) [message #641499] Thu, 25 November 2010 17:06 Go to next message
rssole is currently offline rssoleFriend
Messages: 3
Registered: November 2010
Junior Member
Hi, I am facing strange issue and any help/hint from someone who possibly faced with same problem is appreciated.

I am using Eclipse 3.6 SR1 (build: 20100917-0705)

When I try to open some JSPs with Wep Page Editor (WTP) I am getting the following exception:

java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "=r" 	at java.net.URLDecoder.decode(Unknown Source) 	at  org.eclipse.jst.pagedesigner.utils.ProjectResolver.getLocati onByURI(ProjectResolver.java:372) 	at  org.eclipse.jst.pagedesigner.utils.ProjectResolver.getLocati onByURI(ProjectResolver.java:500) 	at  org.eclipse.jst.pagedesigner.utils.ProjectResolver.getLocati onByURI(ProjectResolver.java:489) 	at  org.eclipse.wst.html.core.internal.htmlcss.URLModelProvider. resolveURI(URLModelProvider.java:401) 	at  org.eclipse.wst.html.core.internal.htmlcss.URLModelProvider. getCommonModelFor(URLModelProvider.java:86)


Some JSPs opens no problem.

I can email problematic page to anyone interested.

Thanks.

[Updated on: Thu, 25 November 2010 17:07]

Report message to a moderator

Re: Error within Web Page Editor (Web Tools Platform) [message #641589 is a reply to message #641499] Fri, 26 November 2010 08:54 Go to previous messageGo to next message
rssole is currently offline rssoleFriend
Messages: 3
Registered: November 2010
Junior Member
I forgot to mention that "problematic" page in Eclipse Galileo opens no problem from Web Page Editor
Re: Error within Web Page Editor (Web Tools Platform) [message #642006 is a reply to message #641499] Mon, 29 November 2010 13:48 Go to previous message
Mauro Molinari is currently offline Mauro MolinariFriend
Messages: 281
Registered: July 2009
Senior Member
Il 25/11/2010 18:06, Rastko Soskic ha scritto:
> When I try to open some JSPs I am getting the following exception

You should post your question to eclipse.webtools newsgroup.

Mauro.
Previous Topic:Open Type - filter results based on Working Set
Next Topic:Stop at next line with debugger
Goto Forum:
  


Current Time: Mon Dec 22 07:07:36 GMT 2014

Powered by FUDForum. Page generated in 0.01721 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software