Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [QVTo] Errors importing a blackbox library
[QVTo] Errors importing a blackbox library [message #640985] Tue, 23 November 2010 18:14 Go to next message
Toñi Reina is currently offline Toñi ReinaFriend
Messages: 209
Registered: July 2009
Senior Member
Hi all,

I' m trying to write a blackbox library in Java to add some
functionality to some extra methods.

I have found the following resource:
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.m2m/org .eclipse.qvtoml/doc/org.eclipse.m2m.qvt.oml.doc/references/b lackboxing.html?root=Modeling_Project&view=co

I have installed the example at 'Examples/Operational QVT
Transformation/Black-box Library Definition'wizard and downloaded the
project org.eclipse.emf.compare from eclipse svn because it also has an
example of blackboxing at org.eclipse.emf.compare.mpatch.emfdiff2mpatch.

The problem is that the import sentence in the qvto files has an error
whose text is "Cannot find imported compilation unit
'org.mwacsl.SWC2jsp.lib'.

I have been looking for similar problem described in the messages
posted in the eclipse m2m forum, but although I have found some, I
haven't found any answer.

How can I configure in a QVT project where the blackbox libraries
can be found? Is there something similar to Java Build Path to specify
this configuration?

I have created a project that holds the Java code, based on the
example at the wizard. Then I have created a plugin and installed it in
my Eclipse. But I does not work.

Can anyone give me a hint?

Regards,
Toñi Reina
Re: [QVTo] Errors importing a blackbox library [message #641808 is a reply to message #640985] Sun, 28 November 2010 10:47 Go to previous message
Toñi Reina is currently offline Toñi ReinaFriend
Messages: 209
Registered: July 2009
Senior Member
Hi,

finally I found what the problem was. I'm going to report it in case
someone could find it useful.

The problem was that I wrote the class name in the import sentence
org.mwacsl.SWC2jsp.lib.MWACSLUtilitiesLibrary. However, the right
sentence should include the namespace and the unit name.

import m2m.qvt.oml.MWACSLUtilitiesLibrary;

This information can be found in the plugin.xml file attached to the
library project.

<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.7"?>
<plugin>
<extension point="org.eclipse.m2m.qvt.oml.javaBlackboxUnits">
<unit name="MWACSLUtilitiesLibrary" namespace="m2m.qvt.oml">
<library name="MWACSLUtilitiesLibrary"
class="org.mwacsl.SWC2jsp.lib.MWACSLUtilitiesLibrary">
<metamodel nsURI="http://www.eclipse.org/emf/2002/Ecore"/>
</library>
</unit>
</extension>
</plugin>

Furthermore, I have to create the plugin from the MWACSLUtilitiesLibrary
project and installed it.

Regards,
Toñi

El 23/11/2010 19:14, Toñi Reina Quintero escribió:
> Hi all,
>
> I' m trying to write a blackbox library in Java to add some
> functionality to some extra methods.
>
> I have found the following resource:
> http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.m2m/org .eclipse.qvtoml/doc/org.eclipse.m2m.qvt.oml.doc/references/b lackboxing.html?root=Modeling_Project&view=co
>
>
> I have installed the example at 'Examples/Operational QVT
> Transformation/Black-box Library Definition'wizard and downloaded the
> project org.eclipse.emf.compare from eclipse svn because it also has an
> example of blackboxing at org.eclipse.emf.compare.mpatch.emfdiff2mpatch.
>
> The problem is that the import sentence in the qvto files has an error
> whose text is "Cannot find imported compilation unit
> 'org.mwacsl.SWC2jsp.lib'.
>
> I have been looking for similar problem described in the messages posted
> in the eclipse m2m forum, but although I have found some, I haven't
> found any answer.
>
> How can I configure in a QVT project where the blackbox libraries can be
> found? Is there something similar to Java Build Path to specify this
> configuration?
>
> I have created a project that holds the Java code, based on the example
> at the wizard. Then I have created a plugin and installed it in my
> Eclipse. But I does not work.
>
> Can anyone give me a hint?
>
> Regards,
> Toñi Reina
>
>
>
>
>
>
>
Previous Topic:[ATL] How to launch Query by program in ATL3 API?
Next Topic:[QVTo] Running a QVT transformation from a program
Goto Forum:
  


Current Time: Sun Dec 21 06:17:37 GMT 2014

Powered by FUDForum. Page generated in 0.01653 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software