Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » Deploying to tomcat
Deploying to tomcat [message #640632] Mon, 22 November 2010 16:28 Go to next message
acangi is currently offline acangi
Messages: 2
Registered: November 2010
Junior Member
Hello,

I'm new to maven, and also I always felt like there's something I didn't get in eclipse, always a lot of problems to do something new, so don't be affraid of very basic answers.

I checked out my projects from subversion, and I'm able to build and package using :
pom.xml right-click > Run as > Maven package, this gives me a build successful

After installing a server in File > New > Server and giving the path to my Tomcat 6 on localhost,

I make a new Run configuration in pom.xml right-click > run as > Run configurations ... > select the server > Run

I get an error "java.lang.noclassdeffounderror: org/apache/catalina/startup/bootstrap"


I also try to run my app on tomcat without maven, but I first need to add facet "Dynamic web module" in the project properties. I do it like explained here : http://greatwebguy.com/programming/eclipse/make-eclipse-and- tomcat-play-nice-together/#comment-125
This screws my project structure : I get a WebContent folder, JAX-WS Web Services and plenty of exceptions in my code (probably validation stuff that didn't happen before)

Then I try to add my project to the server, but I get an exception that Tomcat6 only supports J2EE 1.2, 1.3, 1.4 and Jave EE 5 Web modules...

If I do mvn tomcat:run in a command prompt, it works fine (but installs a new tomcat).

I'm using Eclipse Helios.

How can I get maven to run my webapp in Tomcat ?

Alain
Re: Deploying to tomcat [message #641349 is a reply to message #640632] Thu, 25 November 2010 07:16 Go to previous messageGo to next message
acangi is currently offline acangi
Messages: 2
Registered: November 2010
Junior Member
Should I have posted this on another forum ?

Alain
Re: Deploying to tomcat [message #673368 is a reply to message #640632] Mon, 23 May 2011 12:00 Go to previous messageGo to next message
qadeeralvi  is currently offline qadeeralvi
Messages: 2
Registered: July 2009
Junior Member
Hi Alain,

I have also the same problem. Have u found the solution? If u have please share it. thanks.

//Alvi
Re: Deploying to tomcat [message #685790 is a reply to message #640632] Mon, 20 June 2011 05:25 Go to previous message
Vijay Karmani is currently offline Vijay Karmani
Messages: 1
Registered: June 2011
Junior Member
Hi Alen,Alvi

'Tomcat6 only supports J2EE 1.2, 1.3, 1.4 and Jave EE 5 Web modules' error has something to do with mismatch between the versions of Tomcat and Eclipse WTP. Please refer the link at www.javashiksha.com/development-environment/web-application-using-eclipse-maven-tomcat.html link. This link provides step by step guide to set up web application using Eclipse WTP, Maven and Tomcat. And step#13 within this link talks about the error that you've referred.

Please let me know if that does not help you.

Regards
Vijay

[Updated on: Mon, 20 June 2011 05:59]

Report message to a moderator

Previous Topic:Unable to update index for remote repository
Next Topic:Tomcat error deploy in eclipse galileo maven web project
Goto Forum:
  


Current Time: Fri Oct 31 04:11:57 GMT 2014

Powered by FUDForum. Page generated in 0.02757 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software