Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » B3 » Cannot install b3 Aggregator into 3.7 M3.
Cannot install b3 Aggregator into 3.7 M3. [message #640453] Mon, 22 November 2010 07:40 Go to next message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Hi,

I'm having a bit of trouble installing b3 Aggregator into my 3.7 SDK.

I'm following the directions posted here:
http://wiki.eclipse.org/Eclipse_b3/aggregator/manual#Eclipse _SDK_installation

Using this update site:
http://download.eclipse.org/modeling/emft/b3/updates-3.7mile stones

That's what I get:

Cannot complete the install because of a conflicting dependency.
Software being installed: b3 Aggregator Editor (Incubation)
0.1.0.r01404 (org.eclipse.b3.aggregator.editor.feature.feature.group
0.1.0.r01404)
Software currently installed: Eclipse SDK 3.7.0.I20101028-1441
(org.eclipse.sdk.ide 3.7.0.I20101028-1441)
Only one of the following can be installed at once:
ECF Core API 3.1.0.v20100529-0735 (org.eclipse.ecf 3.1.0.v20100529-0735)
ECF Core API 3.1.0.v20100906-1425 (org.eclipse.ecf 3.1.0.v20100906-1425)
Cannot satisfy dependency:
From: b3 Aggregator Editor (Incubation) 0.1.0.r01404
(org.eclipse.b3.aggregator.editor.feature.feature.group 0.1.0.r01404)
To: org.eclipse.b3.aggregator.engine.feature.feature.group
[0.1.0.r01404]
Cannot satisfy dependency:
From: b3 Aggregator Engine (Incubation) 0.1.0.r01404
(org.eclipse.b3.aggregator.engine.feature.feature.group 0.1.0.r01404)
To: org.eclipse.ecf [3.1.0.v20100529-0735]
Cannot satisfy dependency:
From: Equinox p2 Provisioning
2.0.0.v20100503-897OFx-FdHjO2NkE10Uc8KQ
(org.eclipse.equinox.p2.user.ui.feature.group
2.0.0.v20100503-897OFx-FdHjO2NkE10Uc8KQ)
To: org.eclipse.ecf [3.1.0.v20100906-1425]
Cannot satisfy dependency:
From: Eclipse SDK 3.7.0.I20101028-1441 (org.eclipse.sdk.ide
3.7.0.I20101028-1441)
To: org.eclipse.equinox.p2.user.ui.feature.group
[2.0.0.v20100503-897OFx-FdHjO2NkE10Uc8KQ]


Any ideas?

Thanks,
Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Re: Cannot install b3 Aggregator into 3.7 M3. [message #640539 is a reply to message #640453] Mon, 22 November 2010 12:33 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip Hrbek
Messages: 233
Registered: July 2009
Senior Member
We are preparing a new build for 3.7milestones. When we are done, we'll try to install it into a fresh 3.7. I'll keep you informed about the result here later today.

Regards
Filip

Dne 22.11.2010 08:40, Gunnar Wagenknecht napsal(a):
> Hi,
>
> I'm having a bit of trouble installing b3 Aggregator into my 3.7 SDK.
>
> I'm following the directions posted here:
> http://wiki.eclipse.org/Eclipse_b3/aggregator/manual#Eclipse _SDK_installation
>
> Using this update site:
> http://download.eclipse.org/modeling/emft/b3/updates-3.7mile stones
>
> That's what I get:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: b3 Aggregator Editor (Incubation)
> 0.1.0.r01404 (org.eclipse.b3.aggregator.editor.feature.feature.group
> 0.1.0.r01404)
> Software currently installed: Eclipse SDK 3.7.0.I20101028-1441
> (org.eclipse.sdk.ide 3.7.0.I20101028-1441)
> Only one of the following can be installed at once:
> ECF Core API 3.1.0.v20100529-0735 (org.eclipse.ecf 3.1.0.v20100529-0735)
> ECF Core API 3.1.0.v20100906-1425 (org.eclipse.ecf 3.1.0.v20100906-1425)
> Cannot satisfy dependency:
> From: b3 Aggregator Editor (Incubation) 0.1.0.r01404
> (org.eclipse.b3.aggregator.editor.feature.feature.group 0.1.0.r01404)
> To: org.eclipse.b3.aggregator.engine.feature.feature.group
> [0.1.0.r01404]
> Cannot satisfy dependency:
> From: b3 Aggregator Engine (Incubation) 0.1.0.r01404
> (org.eclipse.b3.aggregator.engine.feature.feature.group 0.1.0.r01404)
> To: org.eclipse.ecf [3.1.0.v20100529-0735]
> Cannot satisfy dependency:
> From: Equinox p2 Provisioning
> 2.0.0.v20100503-897OFx-FdHjO2NkE10Uc8KQ
> (org.eclipse.equinox.p2.user.ui.feature.group
> 2.0.0.v20100503-897OFx-FdHjO2NkE10Uc8KQ)
> To: org.eclipse.ecf [3.1.0.v20100906-1425]
> Cannot satisfy dependency:
> From: Eclipse SDK 3.7.0.I20101028-1441 (org.eclipse.sdk.ide
> 3.7.0.I20101028-1441)
> To: org.eclipse.equinox.p2.user.ui.feature.group
> [2.0.0.v20100503-897OFx-FdHjO2NkE10Uc8KQ]
>
>
> Any ideas?
>
> Thanks,
> Gunnar
>
Re: Cannot install b3 Aggregator into 3.7 M3. [message #641072 is a reply to message #640539] Wed, 24 November 2010 08:16 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Am 22.11.2010 13:33, schrieb Filip Hrbek:
> We are preparing a new build for 3.7milestones. When we are done, we'll try to install it into a fresh 3.7. I'll keep you informed about the result here later today.

Still no luck today. I wonder if the version ranges are too strict.

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Re: Cannot install b3 Aggregator into 3.7 M3. [message #641082 is a reply to message #641072] Wed, 24 November 2010 08:31 Go to previous message
Filip Hrbek is currently offline Filip Hrbek
Messages: 233
Registered: July 2009
Senior Member
Unfortunately there are API changes that need to be reflected in the aggregator code. We created a new build for 3.6 (which has been published) but the build for 3.7 will require more effort (no problem in the actual build but in adopting to the new API).

Stay tuned.

Filip

Dne 24.11.2010 09:16, Gunnar Wagenknecht napsal(a):
> Am 22.11.2010 13:33, schrieb Filip Hrbek:
>> We are preparing a new build for 3.7milestones. When we are done, we'll try to install it into a fresh 3.7. I'll keep you informed about the result here later today.
>
> Still no luck today. I wonder if the version ranges are too strict.
>
> -Gunnar
>
Previous Topic:Status of b3 building tool
Next Topic:UnsupportedOperationException with 3 repositories
Goto Forum:
  


Current Time: Sat Sep 20 04:16:20 GMT 2014

Powered by FUDForum. Page generated in 0.02876 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software