Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Problems with page break
Problems with page break [message #640449] Mon, 22 November 2010 07:48 Go to next message
Mark Howard is currently offline Mark Howard
Messages: 7
Registered: April 2010
Junior Member
Hello

i have the problem that i cann't control the page break.

There is the following situation:

----grid (includes one "header" line)
----table (includes complex data with multiple tables)

If there are more rows in the table and i export to PDF, BIRT puts the grid on page 1 and the table data starts at page 2. This means that there is just one row (=the row of the grid) at page one, the rest of page one is empty. At the end of the table BIRT always makes a page break (which is ok for me) but i don't want that there is a page break after the "headline" grid (which is only on page one) and the table.

If the table has less rows so that the table fits on one page everything works fine.

I tried to set the page break rules but BIRT seems to ignorie these rules.

I hope i explained the problem properly.

Thanks for your help!
Re: Problems with page break [message #640477 is a reply to message #640449] Mon, 22 November 2010 09:26 Go to previous messageGo to next message
Mark Howard is currently offline Mark Howard
Messages: 7
Registered: April 2010
Junior Member
I am using BIRT 2.6
Re: Problems with page break [message #640598 is a reply to message #640449] Mon, 22 November 2010 15:20 Go to previous messageGo to next message
Richard A. Polunsky is currently offline Richard A. Polunsky
Messages: 199
Registered: July 2009
Location: Houston TX
Senior Member

Is there any way you can replicate this using the Derby sample database?
Re: Problems with page break [message #640791 is a reply to message #640449] Tue, 23 November 2010 08:09 Go to previous message
Mark Howard is currently offline Mark Howard
Messages: 7
Registered: April 2010
Junior Member
thx for your help richard!

This error was cause by my stupid table grouping. i just had to add the "headline" grid as first group to the table (and display it in the header of this group) and everything worked.
Previous Topic:Birt in Oracle APEX
Next Topic:XML ERROR in Workbook Setting when opening exported excel
Goto Forum:
  


Current Time: Sat Oct 25 22:16:58 GMT 2014

Powered by FUDForum. Page generated in 0.01849 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software