Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » How to install it?(i'm unable by all means to install UML2 tools)
icon8.gif  How to install it? [message #640309] Sat, 20 November 2010 10:06 Go to next message
Petak  is currently offline Petak Friend
Messages: 2
Registered: November 2010
Junior Member
Hi everyone.

I have big problems with installing UML2 tools to eclipse. My system is arch linux 64 bit, and I'm using eclipse helios from repo, exact version is 3.6.1Build id: M20100909-0800.

I'm trying to install uml2 tools from update site, and all I got is missing dependency. Up to now I tried to add all update sites where the dependencies should be, but even after three days trying and googling I was unable to install the UML2 tools. Always new and new dependencies, now I have approx 15 update sites, and I hate Eclipse more than Monday.

Is there any procedure how to install uml2 tools to Eclipse and not going mad about it? Or should I simply forget Eclipse because it is impossible? Because this is how I feel now. Crap, crap, and once more crap.

Uff. If anyone can point me to some other discussion or anything, I'm completely lost.

Thanks
Re: How to install it? [message #642021 is a reply to message #640309] Mon, 29 November 2010 15:16 Go to previous messageGo to next message
Thomas Neustupny is currently offline Thomas NeustupnyFriend
Messages: 75
Registered: October 2009
Member
Hehe, I tried it too and gave up. Have you seen the previous thread: http://www.eclipse.org/forums/index.php?t=msg&th=170577& amp;start=0
(I gave papyrus a try and it worked. Both pap and u2t are based on eclipse UML2, so that's fine.)
Re: How to install it? [message #642052 is a reply to message #640309] Mon, 29 November 2010 17:09 Go to previous messageGo to next message
Petak  is currently offline Petak Friend
Messages: 2
Registered: November 2010
Junior Member
At the end I gave up too, and moved to netbeans..
Re: How to install it? [message #642192 is a reply to message #642052] Tue, 30 November 2010 10:41 Go to previous messageGo to next message
Vlad Varnica is currently offline Vlad VarnicaFriend
Messages: 546
Registered: July 2009
Location: Milton Keynes - UK
Senior Member
I don't think that moving to Netbeans is a solution because you don't have an UML editor in Netbeans 6.9.

You have many open source plugins related to Eclipse such as Papyrus, Topcased, Umllet etc...
For advanced modeling needs you can select Omondo if Java, or Visual paradigm or Rational for traditional modeling. Rational is better for my point of view for MDD and Omondo better for agile.

You need to select your project depending on your need. If you are a student then please use open source and contribute. If you are a company then you must decide if you have time or not to invest into modeling plugins. If you have time then select open source if you don't have time then buy a software tool. I think that it is the same price at the end between time needed to understand and then model your project using open source than to pay for a modeling tool out of the box.
Don't forget that for example if you want to repair your car it is sometimes better to buy a new component and pay for it than trying to repair it by yourself . I know what I talking about because I lost day and days in mechanics for a very mediocre result Embarrassed

[Updated on: Tue, 30 November 2010 10:44]

Report message to a moderator

icon14.gif  Re: How to install it? [message #647553 is a reply to message #642192] Fri, 07 January 2011 03:39 Go to previous messageGo to next message
Minnow  is currently offline Minnow Friend
Messages: 1
Registered: January 2011
Junior Member
Hi Buddies,

Actually most errors are not missing dependencies, but conflicting, as my log shown below.
And then I removed previously installed version of EMF, GMF, UML2 SDK and OCL. Finally, I only choose to install UML2Tool and it works

============log===================
Cannot complete the install because of a conflicting dependency.
Software being installed: OCL 2.0 Binding for UML 2.0.0.v200901271800-3--7w311A16382511 (org.eclipse.ocl.uml.feature.group 2.0.0.v200901271800-3--7w311A16382511)
Software currently installed: UML2 Extender SDK 3.1.1.v201008191505 (org.eclipse.uml2.sdk.feature.group 3.1.1.v201008191505)
Only one of the following can be installed at once:
UML2 UML Model 3.1.1.v201008191505 (org.eclipse.uml2.uml 3.1.1.v201008191505)
UML2 UML Model 3.0.1.v200908281330 (org.eclipse.uml2.uml 3.0.1.v200908281330)
UML2 UML Model 3.1.0.v201006071150 (org.eclipse.uml2.uml 3.1.0.v201006071150)
UML2 UML Model 3.0.0.v200905151700 (org.eclipse.uml2.uml 3.0.0.v200905151700)
Cannot satisfy dependency:
From: OCL 2.0 Binding for UML 2.0.0.v200905271400 (org.eclipse.ocl.uml 2.0.0.v200905271400)
To: bundle org.eclipse.uml2.uml [3.0.0,3.1.0)
Cannot satisfy dependency:
From: OCL 2.0 Binding for UML 2.0.0.v200901271800-3--7w311A16382511 (org.eclipse.ocl.uml.feature.group 2.0.0.v200901271800-3--7w311A16382511)
To: org.eclipse.ocl.uml [2.0.0.v200905271400]
Cannot satisfy dependency:
From: UML2 End-User Features 3.1.1.v201008191505 (org.eclipse.uml2.feature.group 3.1.1.v201008191505)
To: org.eclipse.uml2.uml [3.1.1.v201008191505]
Cannot satisfy dependency:
From: UML2 Extender SDK 3.1.1.v201008191505 (org.eclipse.uml2.sdk.feature.group 3.1.1.v201008191505)
To: org.eclipse.uml2.feature.group [3.1.1.v201008191505]
Re: How to install it? [message #649913 is a reply to message #647553] Thu, 20 January 2011 23:10 Go to previous messageGo to next message
Mario L is currently offline Mario LFriend
Messages: 7
Registered: July 2009
Junior Member
Yeah, no success here either.
I hoped I'd see it in the Eclipse Modeler edition, but probably the guys packaging it weren't able to get it installed either Smile

What is truly disappointing is that this "official" forum is getting zero attention from the developers... atta community Sad

PS: and Papyrus doesn't install either, straight from Eclipse Modeler "install modeling components". I'd say the whole Modeler is a piece of broken s* as actually NONE of these components can be installed on the freshly downloaded Eclipse. But this is another rant. Might be NetBeans doesn't have everything, but maybe you are able install the things it's offering.

[Updated on: Thu, 20 January 2011 23:14]

Report message to a moderator

Re: How to install it? [message #649922 is a reply to message #649913] Fri, 21 January 2011 01:13 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26215
Registered: July 2009
Senior Member
Mario,

There's really no one left developing this stuff. Papyrus is much more
lively so a much better bet...


Mario L wrote:
> Yeah, no success here either. I hoped I'd see it in the Eclipse
> Modeler edition, but probably the guys packaging it weren't able to
> get it installed either :)
>
> What is truly disappointing is that this "official" forum is getting
> zero attention from the developers... atta community :(
Re: How to install it? [message #650001 is a reply to message #649922] Fri, 21 January 2011 12:05 Go to previous messageGo to next message
Mario L is currently offline Mario LFriend
Messages: 7
Registered: July 2009
Junior Member
Ed Merks wrote on Thu, 20 January 2011 20:13
There's really no one left developing this stuff. Papyrus is much more
lively so a much better bet...

Thanks for sharing this Smile maybe somebody shouild put this also on the project page, so ppl know it's dead (so make it kinda "official") - or maybe there's no one left to be able to write there either Smile

Anyway, Papyrus doesn't install/update on Helios either. I downloaded from their site a preinstalled Galileo-based edition - which worked and I'm using right now. I'll just model in one Eclipse and use the generated code in another - annoying but bearable.
Re: How to install it? [message #650047 is a reply to message #649913] Fri, 21 January 2011 14:02 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: r.zozmann.exxcellent.de

Hi Mario,

sorry for your impression. You are right, there was not so much active
working in the project in the past. But it's not dead :-)
For long term decicions i would also tend to papyrus, but currently
papyrus has also some missed functionality.
We are using UML2Tools for modelling in our company and we have strong
interest to hold UML2Tools living, at least for maintenance. With the
new year we now have a employee with commit rights for the UML2Tools
project and we are working on a regular build process to get a new
release for the UML2Tools and Helios (as a p2 update site). I hope for
the next weeks...

Regards
Ralf

On 01/21/2011 12:11 AM, Mario L wrote:
> Yeah, no success here either. I hoped I'd see it in the Eclipse Modeler
> edition, but probably the guys packaging it weren't able to get it
> installed either :)
>
> What is truly disappointing is that this "official" forum is getting
> zero attention from the developers... atta community :(
Re: How to install it? [message #650132 is a reply to message #650047] Fri, 21 January 2011 21:16 Go to previous message
Mario L is currently offline Mario LFriend
Messages: 7
Registered: July 2009
Junior Member
Now THIS is great news Smile thank you Ralf! (and the other guys)
Previous Topic:apply stereotpe programmaticaly
Next Topic: Helios is out.. where are the UML2 Tools?
Goto Forum:
  


Current Time: Sun Nov 23 07:43:16 GMT 2014

Powered by FUDForum. Page generated in 0.02122 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software