Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Unable to find extensions points declared in source workspace
Unable to find extensions points declared in source workspace [message #639896] Thu, 18 November 2010 10:13
No real name is currently offline No real nameFriend
Messages: 1
Registered: July 2009
Junior Member
Hi
I have a problem in using extensions points declared in workspace plug-ins when I select Run as > Eclipse Application.

My scenario is the following:
1) I run Eclipse
2) In the workspace I have few source projects with PDE nature.
3) Some of them *uses* predefined extensions (such as editor, actions, etc...).
4) One of them declare a new extension point, incorporating a exsd file
5) From here I run another Eclipse instance using Run As > Eclipse Application

In the target workspace I can see the effect of he point #3 above, but I cannot see the effect of point #4 above. More specifically, if in this target workspace I create a new plug-in project there is absolutely now way for me to see, in the Dependencies page of the Manifest Editor, the plug-in I described in point #4 above. And in the Extension page of the Manifest Editor there is no way for me to see the Extension Point i described in point #4 above.

I expected to see, in the target workspace, all the contributions from the original Eclipse plug-ins plus the contributions from the plug-in projects in the source workspace, but the latter are hidden. Is there a preference to enable this ?

Thanks in advance
Aldo

Previous Topic:Included Plugins
Next Topic:Building war files
Goto Forum:
  


Current Time: Wed Nov 26 09:09:24 GMT 2014

Powered by FUDForum. Page generated in 0.02144 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software