Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT Error(Error when report was put in server)
BIRT Error [message #639631] Wed, 17 November 2010 09:51 Go to next message
Neo is currently offline NeoFriend
Messages: 12
Registered: November 2010
Junior Member
Hi,
I created a BIRT report which is working fine in local server.
But when I had uploaded it into the internet server. The report gave me the following. Would you please tell me what more should I do?
Following is the error

------------------------------------------------------------ -------------------------
<html>
<head>
<title>Error</title>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">
</head>
<body>
<div id="birt_errorPage" style="color:red">
<span id="error_icon" style="cursor:pointer" onclick="if (document.getElementById('error_detail').style.display == 'none') { document.getElementById('error_icon').innerHTML = '- '; document.getElementById('error_detail').style.display = 'block'; }else { document.getElementById('error_icon').innerHTML = '+ '; document.getElementById('error_detail').style.display = 'none'; }" > + </span>
The report file : does not exist or contains errors.<br>
<pre id="error_detail" style="display:none;" >
org.eclipse.birt.report.exception.ViewerException: The report file : does not exist or contains errors.<br> at org.eclipse.birt.report.context.ViewerAttributeBean.getDesig nHandle(ViewerAttributeBean.java:647) <br> at org.eclipse.birt.report.context.ViewerAttributeBean.__init(V iewerAttributeBean.java:224) <br> at org.eclipse.birt.report.context.BaseAttributeBean.init(BaseA ttributeBean.java:233) <br> at org.eclipse.birt.report.context.ViewerAttributeBean.<init>(ViewerAttributeBean.java:118) <br> at org.eclipse.birt.report.context.BirtContext.__init(BirtConte xt.java:44) <br> at org.eclipse.birt.report.context.BaseContext.<init>(BaseContext.java:69) <br> at org.eclipse.birt.report.context.BirtContext.<init>(BirtContext.java:30) <br> at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(V iewerServlet.java:150) <br> at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherSer vlet.doPost(BirtSoapMessageDispatcherServlet.java:243) <br> at javax.servlet.http.HttpServlet.service(HttpServlet.java:710) <br> at org.apache.axis.transport.http.AxisServletBase.service(AxisS ervletBase.java:327) <br> at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
<br> at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherSer vlet.service(BirtSoapMessageDispatcherServlet.java:122) <br> at org.apache.catalina.core.ApplicationFilterChain.internalDoFi lter(ApplicationFilterChain.java:290) <br> at org.apache.catalina.core.ApplicationFilterChain.doFilter(App licationFilterChain.java:206) <br> at org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerF ilter.java:68) <br> at org.apache.catalina.core.ApplicationFilterChain.internalDoFi lter(ApplicationFilterChain.java:235) <br> at org.apache.catalina.core.ApplicationFilterChain.doFilter(App licationFilterChain.java:206) <br> at org.apache.catalina.core.StandardWrapperValve.invoke(Standar dWrapperValve.java:233) <br> at org.apache.catalina.core.StandardContextValve.invoke(Standar dContextValve.java:175) <br> at org.apache.catalina.core.StandardHostValve.invoke(StandardHo stValve.java:128) <br> at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorRepo rtValve.java:102) <br> at org.apache.catalina.core.StandardEngineValve.invoke(Standard EngineValve.java:109) <br> at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAd apter.java:263) <br> at org.apache.coyote.http11.Http11Processor.process(Http11Proce ssor.java:844) <br> at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHand ler.process(Http11Protocol.java:584) <br> at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoin t.java:447) <br> at java.lang.Thread.run(Thread.java:619)<br></pre>


--------------------------
Neo
Re: BIRT Error [message #639702 is a reply to message #639631] Wed, 17 November 2010 14:05 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Neo,

can you post the design? Are the runtime versions of your development
and deployment environments the same?

Jason

On 11/17/2010 4:51 AM, Neo wrote:
> Hi,
> I created a BIRT report which is working fine in local server.
> But when I had uploaded it into the internet server. The report gave me
> the following. Would you please tell me what more should I do?
> Following is the error
>
> ------------------------------------------------------------
> -------------------------
> <html>
> <head>
> <title>Error</title>
> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">
> </head>
> <body>
> <div id="birt_errorPage" style="color:red">
> <span id="error_icon" style="cursor:pointer" onclick="if
> (document.getElementById('error_detail').style.display == 'none') {
> document.getElementById('error_icon').innerHTML = '- ';
> document.getElementById('error_detail').style.display = 'block'; }else {
> document.getElementById('error_icon').innerHTML = '+ ';
> document.getElementById('error_detail').style.display = 'none'; }" > +
> </span>
> The report file : does not exist or contains errors.<br>
> <pre id="error_detail" style="display:none;" >
> org.eclipse.birt.report.exception.ViewerException: The report file :
> does not exist or contains errors.<br> at
> org.eclipse.birt.report.context.ViewerAttributeBean.getDesig
> nHandle(ViewerAttributeBean.java:647) <br> at
> org.eclipse.birt.report.context.ViewerAttributeBean.__init(V
> iewerAttributeBean.java:224) <br> at
> org.eclipse.birt.report.context.BaseAttributeBean.init(BaseA
> ttributeBean.java:233) <br> at
> org.eclipse.birt.report.context.ViewerAttributeBean.<init>(ViewerAttributeBean.java:118)
> <br> at org.eclipse.birt.report.context.BirtContext.__init(BirtConte
> xt.java:44) <br> at
> org.eclipse.birt.report.context.BaseContext.<init>(BaseContext.java:69)
> <br> at
> org.eclipse.birt.report.context.BirtContext.<init>(BirtContext.java:30)
> <br> at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(V
> iewerServlet.java:150) <br> at
> org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherSer
> vlet.doPost(BirtSoapMessageDispatcherServlet.java:243) <br> at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:710) <br> at
> org.apache.axis.transport.http.AxisServletBase.service(AxisS
> ervletBase.java:327) <br> at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
> <br> at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherSer
> vlet.service(BirtSoapMessageDispatcherServlet.java:122) <br> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFi
> lter(ApplicationFilterChain.java:290) <br> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(App
> licationFilterChain.java:206) <br> at
> org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerF
> ilter.java:68) <br> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFi
> lter(ApplicationFilterChain.java:235) <br> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(App
> licationFilterChain.java:206) <br> at
> org.apache.catalina.core.StandardWrapperValve.invoke(Standar
> dWrapperValve.java:233) <br> at
> org.apache.catalina.core.StandardContextValve.invoke(Standar
> dContextValve.java:175) <br> at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHo
> stValve.java:128) <br> at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorRepo
> rtValve.java:102) <br> at
> org.apache.catalina.core.StandardEngineValve.invoke(Standard
> EngineValve.java:109) <br> at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAd
> apter.java:263) <br> at
> org.apache.coyote.http11.Http11Processor.process(Http11Proce
> ssor.java:844) <br> at
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHand
> ler.process(Http11Protocol.java:584) <br> at
> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoin t.java:447)
> <br> at java.lang.Thread.run(Thread.java:619)<br></pre>
Re: BIRT Error [message #639712 is a reply to message #639702] Wed, 17 November 2010 14:59 Go to previous messageGo to next message
Neo is currently offline NeoFriend
Messages: 12
Registered: November 2010
Junior Member
Hi jason,
it was a relative path problem. I solved it on my own.
One more I found out is usage of "\" and "/".
It was a UNIX server where we have to use "/".
I had used "\\".
These two I found out, I thought I will share so that it may be useful for others when you are solving all the issues on BIRT.

Kind Regards,


--------------------------
Neo
Re: BIRT Error [message #639753 is a reply to message #639712] Wed, 17 November 2010 16:42 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Thanks for updating.

On 11/17/2010 9:59 AM, Neo wrote:
> Hi jason,
> it was a relative path problem. I solved it on my own.
> One more I found out is usage of "\" and "/".
> It was a UNIX server where we have to use "/".
> I had used "\\".
> These two I found out, I thought I will share so that it may be useful
> for others when you are solving all the issues on BIRT.
>
> Kind Regards,
Re: BIRT Error [message #647146 is a reply to message #639712] Tue, 04 January 2011 18:23 Go to previous message
James Mising name is currently offline James Mising nameFriend
Messages: 26
Registered: November 2010
Junior Member
Hello, having the same issue and may be from the same cause. where did you have an issue with your slashes? Was it in web.xml or some kind of xml configuration and what did you do to fix?

I think it has to do with a BIRT_VIEWER_WORKING_FOLDER setting which I am not real sure how to set the path to root for both unix and windows.

Thanks,


James

[Updated on: Tue, 04 January 2011 18:25]

Report message to a moderator

Previous Topic:Dynamic data sources for report generation
Next Topic:gradients in pie charts
Goto Forum:
  


Current Time: Sun Dec 21 20:53:15 GMT 2014

Powered by FUDForum. Page generated in 0.06555 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software