Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » [AGR] Inconclusive results when playing back hierarchic test suites
[AGR] Inconclusive results when playing back hierarchic test suites [message #64340] Wed, 05 April 2006 13:34 Go to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
Hello.

I have a master test suite which does not directly define any test cases
but simply invokes other test suites. I find that, if the invoked test
suites reside in different folders from the master test suite, the
master test suite cannot be played back successfully: the Eclipse
workbench is briefly instantiated, but the bodies of the invoked test
suites are never executed and then the process ends with inconclusive
results. If instead the suites are organized in a flat structure (as
opposed to a hierarchical one), all works well.

Please note that a hierarchical organization is not a problem when a
suite invokes test cases from other suites directly, they can be located
anywhere and all functions properly.

Has anybody encountered this problem? Is it a bug or a limitation?

TIA
Barbara

PS: Thank you very much, Ali, for a fantastic tool! I have been doing
GUI testing with Rational XDETester, and I must say that AGR is such a
breath of fresh air!... :-)
I finally feel in control of things and capable of defining verification
points at whatever granularity I feel necessary.
Re: [AGR] Inconclusive results when playing back hierarchic test suites [message #64412 is a reply to message #64340] Wed, 05 April 2006 15:47 Go to previous messageGo to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------060708090101010605070802
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

On further examination in my real testing environment, it turns out that
I get the same inconclusive results also when my master test suite is
located in the same folder as the suites that I am invoking from the
master suite.

Just in case it is of any help, I am attaching the .execution file that
shows the problem.

Thanks to anyone that might shed some light on the issue.
B.

Barbara Rosi-Schwartz wrote:
> Hello.
>
> I have a master test suite which does not directly define any test cases
> but simply invokes other test suites. I find that, if the invoked test
> suites reside in different folders from the master test suite, the
> master test suite cannot be played back successfully: the Eclipse
> workbench is briefly instantiated, but the bodies of the invoked test
> suites are never executed and then the process ends with inconclusive
> results. If instead the suites are organized in a flat structure (as
> opposed to a hierarchical one), all works well.
>
> Please note that a hierarchical organization is not a problem when a
> suite invokes test cases from other suites directly, they can be located
> anywhere and all functions properly.
>
> Has anybody encountered this problem? Is it a bug or a limitation?
>
> TIA
> Barbara
>
> PS: Thank you very much, Ali, for a fantastic tool! I have been doing
> GUI testing with Rational XDETester, and I must say that AGR is such a
> breath of fresh air!... :-)
> I finally feel in control of things and capable of defining verification
> points at whatever granularity I feel necessary.


--------------060708090101010605070802
Content-Type: application/x-zip-compressed;
name="ProvaMaster.zip"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="ProvaMaster.zip"

UEsDBBQAAAAIAH2NhTR6TGJtawMAAIIDAAAjAAAAUHJvdmFNYXN0ZXJfMTE0 NDI1MTAwNjA2
OC5leGVjdXRpb24L8GZmEWHgAMIjza0mDEhAAIiDUovzS4uSU53z80pS80qK 70bE5t8yEKmd
v+W/QKr+bedCoUkOAjlcPwMmhm3V2nIreqqU+B5B602yGf//zmGI5BAJ2tK1 rf/G9e/zqs/Z
uvl9P55sE/yso9DH0/+q9KxVCkwvJSZ7+u+VbE3P/Xr8+/n5u+R6k73euXV0 t1xkt3GeezFU
wkZpBlflF6mPJWpTjkuUd6W4TfNZpr5H+Xr1q5COJcwHkjZmXKi4tCCHqS6W p0tgn+SmjGeC
bcteGr15LuAXKDM38ZCri0LU/KiDrxZnmhyfcpe3w0GnSVJl30S+g5J+FqeK /eYvMnyksCzZ
5DHDM80Df7VYDywV4eXcE7TqyIHTXB317NMzP+5Y/qtNsG3b011tyTumXear 1c7Y2fZsZm70
9drwUA+R007hPecWd3d4Z6xSmie0U4Vb1HU6q3Rkp9sUrlszllj8N/XZ6LBK JCBwV4buNctn
TZuW12zdI3dGUDBmolfJNNWybrtJ1Y9twpwObrzT88jlXF/erLal2bNyI7Zx 9Z21UyjmWvzo
QLEJa1/mjEnL6qwXv1z9zzf0RZOC2QrBvezblMJdtdzblwsonZO/NHPXK5dv QVK9E1wnRzy6
/S79uU7Zr+3XWyP1FH0knX9K+EtWnVjlOdNigskft4A57ik2k9lYVK8Wm37e oM9+mzn1SPEv
91WhHzNl/frnbg59mr5s7a7qI2f+8s91lNS60bx1dmm5RJyjI69ju8eSk3K2 t8uC+U3VsxeH
XhV+I1aSaxbw8Guo74uIebJZu17OXDd/9oUb6YeyvrAbPwyrPj6zgN37/ZkW /Qs/XdT2+Ajs
jFo3lTX3l+/6pbt1/bN/R93/lrv3JbvuWvkb0U37NMV/xSXM2Be2Y8PO661T X/Q/O5RV7b6r
YPbS788O/bKaf6L18Jd5zm3vL3bImSWviI6L5zYyrsq/3bPvWURj6IyLd/KP nX3Bn37Mq/r4
rMLupeXpx25ZNW9nTXfdqqJledW20PnHr2Uckr3890XXCUc1ll+yfxd95JhE 1+H3U88er/vX
ZWsgdd7gP9f5KVLvz53a3sWTKH7lV5CK8n+mAG92jpqT28M/MDEwVAsxMAR4 MzKJMCDyC7Kc
AAM6QM89Ad6sbCBxRiC0A9J6zCAtAFBLAQIUABQAAAAIAH2NhTR6TGJtawMA AIIDAAAjAAAA
AAAAAAAAAAC2gQAAAABQcm92YU1hc3Rlcl8xMTQ0MjUxMDA2MDY4LmV4ZWN1 dGlvblBLBQYA
AAAAAQABAFEAAACsAwAAAAA=
--------------060708090101010605070802--
Re: [AGR] Inconclusive results when playing back hierarchic test suites [message #65840 is a reply to message #64412] Tue, 11 April 2006 20:02 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
Hi Barbara,

You're right, I've opened the following defect to handle this issue
https://bugs.eclipse.org/bugs/show_bug.cgi?id=136186

Thanks.

"Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
news:e10ose$1ol$1@utils.eclipse.org...
> On further examination in my real testing environment, it turns out that
> I get the same inconclusive results also when my master test suite is
> located in the same folder as the suites that I am invoking from the
> master suite.
>
> Just in case it is of any help, I am attaching the .execution file that
> shows the problem.
>
> Thanks to anyone that might shed some light on the issue.
> B.
>
> Barbara Rosi-Schwartz wrote:
> > Hello.
> >
> > I have a master test suite which does not directly define any test cases
> > but simply invokes other test suites. I find that, if the invoked test
> > suites reside in different folders from the master test suite, the
> > master test suite cannot be played back successfully: the Eclipse
> > workbench is briefly instantiated, but the bodies of the invoked test
> > suites are never executed and then the process ends with inconclusive
> > results. If instead the suites are organized in a flat structure (as
> > opposed to a hierarchical one), all works well.
> >
> > Please note that a hierarchical organization is not a problem when a
> > suite invokes test cases from other suites directly, they can be located
> > anywhere and all functions properly.
> >
> > Has anybody encountered this problem? Is it a bug or a limitation?
> >
> > TIA
> > Barbara
> >
> > PS: Thank you very much, Ali, for a fantastic tool! I have been doing
> > GUI testing with Rational XDETester, and I must say that AGR is such a
> > breath of fresh air!... :-)
> > I finally feel in control of things and capable of defining verification
> > points at whatever granularity I feel necessary.
>
>
Re: [AGR] Inconclusive results when playing back hierarchic test suites [message #65990 is a reply to message #65840] Tue, 11 April 2006 20:34 Go to previous message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-Schwartz
Messages: 448
Registered: July 2009
Senior Member
Ali Mehregani wrote:
> Hi Barbara,
>
> You're right, I've opened the following defect to handle this issue
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=136186
>
> Thanks.
>

Ali,

Thanks for your reply and for opening the bug.

Cheerio,
B.
Previous Topic:AGR: Minimal feature set?
Next Topic:Getting the new technology agent controller working
Goto Forum:
  


Current Time: Fri Oct 31 22:24:38 GMT 2014

Powered by FUDForum. Page generated in 0.02099 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software