Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » problems with running a simple tptp (it keeps running and running (like energizer bunny))
icon5.gif  problems with running a simple tptp [message #638179] Wed, 10 November 2010 11:03
elhanan Maayan is currently offline elhanan Maayan
Messages: 131
Registered: November 2009
Senior Member
hi..using eclipse galieo 3.5.2

when i try to do a simple test, at first i get this:
rg.eclipse.core.runtime.CoreException: Agent Controller is unavailable under port 10002. Make sure that the service is started and the port number is correct under preferences.
at org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:124)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :438)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:345)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1164)
at org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:195)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException:
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerFactory.createConnection(AgentControllerFactory.java:55 )
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool.createConnection(AgentControllerPool.java:190)
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool.getConnection(AgentControllerPool.java:152)
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool.getConnection(AgentControllerPool.java:83)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:47)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:52)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :431)
... 5 more
!SUBENTRY 1 org.eclipse.hyades.trace.ui 4 0 2010-11-10 12:48:38.990
!MESSAGE Agent Controller is unavailable under port 10002. Make sure that the service is started and the port number is correct under preferences.
!STACK 0
org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException:
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerFactory.createConnection(AgentControllerFactory.java:55 )
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool.createConnection(AgentControllerPool.java:190)
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool.getConnection(AgentControllerPool.java:152)
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerPool.getConnection(AgentControllerPool.java:83)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:47)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.uti l.AgentControllerDelegate.getConnection(AgentControllerDeleg ate.java:52)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.connectToAgentController(TIDelegateHelper.java :431)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:345)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1164)
at org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:195)
at java.lang.Thread.run(Thread.java:619)


running it for the 2nd time gives me a gpf on java,
when on the debug window i keep seeing running over and over. it never ends.

[Updated on: Wed, 10 November 2010 11:05]

Report message to a moderator

Previous Topic:New to TPTP & Eclipse - Problem
Next Topic:Getting started
Goto Forum:
  


Current Time: Wed Oct 22 09:58:10 GMT 2014

Powered by FUDForum. Page generated in 0.01681 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software