Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Hot deployment functionality for maven EARs not working in latest versions.(Hot deployment functionality for maven EARs not working in latest versions along with other issues with latest versions.)
Hot deployment functionality for maven EARs not working in latest versions. [message #638111] Tue, 09 November 2010 23:28
No real name is currently offline No real name
Messages: 1
Registered: November 2010
Junior Member
Hi All,

I would like to use the hot deployment functionality in IAM. But the latest development version available seems to have some issues and is not able to deploy the maven ear directly from RAD.

1.) When I do right click and Run on Server, which is Websphere 6.1.0.25 in my case, it gives the error - 'Cannot add an EAR project to the server unless it contains a Web, EJB, or Connector module."

2) With the new versions of IAM, I am not sure but there seems to be some issue, as I am unable to build any of my projects, it always have some or the other issue. Whenever I import my maven project, either sometimes it fails to get the maven classpath and or always gives a pom.xml error. After looking into the pom error, I was able to see that it fails to download some or the other file from the repo. The important thing is that the files are present and I am able to build the project easily without even single fail through command prompt. Also, it gives error of different jars everytime. So it is not a case that jars are not present. It gives error for one jar and when I reimport the project, it is able to download that jar and gives error for another one.

3.) I was till now using IAM build 0.9.0.200905051543, and it works just perfect. Even when I downgrade from 0.12.x version back to 0.9.0.x version, it just runs fine without any issues.

Can anybody please tell me from where I can find a very stable version which has hot deployment functionality. I have a user base of around 300 users approx. for which I am responsible for these plugins. Carlos had a version published around 17 Aug, I think it worked.

Thanks and Regards
Abhinav Tyagi
Previous Topic:War Overlays
Next Topic:Install Error on Helios
Goto Forum:
  


Current Time: Fri Oct 24 10:29:57 GMT 2014

Powered by FUDForum. Page generated in 0.02686 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software