Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » MoDisco » [JSP Component] Help with generation plugin
[JSP Component] Help with generation plugin [message #638017] Tue, 09 November 2010 16:01 Go to next message
Toñi Reina is currently offline Toñi Reina
Messages: 206
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------090005000601000705010900
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

Hi all,

I'm testing the JSP Component. The Discoverer, works fine, but I have
problems with the generator.

The test I'm doing is to generate a .jspxmi file from a web site.
Then, I launch a Run Configuration for Acceleo, but, unfortunately, the
only generated stuff is an empty directory with no jsp files.

I have attached a screenshot of the launch configuration to see if I'm
doing something wrong. I have tested both runners, the Acceleo Plug-in
application and the Java Application, but the result is the same, no jsp
files are generated.

Best regards,

To
Re: [JSP Component] Help with generation plugin [message #638139 is a reply to message #638017] Wed, 10 November 2010 07:38 Go to previous messageGo to next message
Fabien Giquel is currently offline Fabien Giquel
Messages: 138
Registered: July 2009
Senior Member
Hi,

your launch configuration seems to be all right (it should work whatever
the Runner chosen).

I will need some informations to help you:

- first of all, does the JSP discoverer really worked fine ? --> right
click on the .jspxmi file, and "open with ... MoDisco Model browser",
please check there are some "Page" instances in the model.
- when you launch the generation, have a look into the "error log" view
to find any error message.

Fabien.


----------------------------------------------------
Fabien GIQUEL
R&D Engineer
Mia-Software
4, rue du Château de l'Eraudiere
44324 NANTES CEDEX 03
----------------------------------------------------
Re: [JSP Component] Help with generation plugin [message #638182 is a reply to message #638139] Wed, 10 November 2010 09:56 Go to previous messageGo to next message
Toñi Reina is currently offline Toñi Reina
Messages: 206
Registered: July 2009
Senior Member
Hi,

thanks for your interest.

I have woven my answers between your questions
El 10/11/2010 8:38, Fabien escribió:
> Hi,
>
> your launch configuration seems to be all right (it should work whatever
> the Runner chosen).
>
> I will need some informations to help you:
>
> - first of all, does the JSP discoverer really worked fine ? --> right
> click on the .jspxmi file, and "open with ... MoDisco Model browser",
> please check there are some "Page" instances in the model.

Yes, the discoverer worked fine. I can open the .jspxmi file, and it has
pages, jsp directives, ... Furthermore, in order to check if the problem
was due to the concrete file, I also tested the .mtl file with the
org.eclipse.modisco.jee.jsp.discoverer.tests.jspxmi included in the
org.eclipse.modisco.jee.jsp.generation.tests project. So I think the
problem is not due to the concrete file.

All of them cause the same result: no file is generated.

> - when you launch the generation, have a look into the "error log" view
> to find any error message.

Before launching the generation, I delete the log and clear the log
viewer, to be sure the error messages belong to the generation. However,
after the generation (I can see the message Launching Generate Jsp at
the bottom of Eclispe), there are any error messages.

>
> Fabien.


Regards,
Toñi
Re: [JSP Component] Help with generation plugin [message #638687 is a reply to message #638182] Fri, 12 November 2010 08:17 Go to previous messageGo to next message
Fabien Giquel is currently offline Fabien Giquel
Messages: 138
Registered: July 2009
Senior Member
ok, to go ahead i will need to debug.

is it possible for you to create a bug under MoDisco project ?
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=MDT.MoDi sco
-> Technologies component.
Then you may attach your .jspxmi file. I will debug the generation.


----------------------------------------------------
Fabien GIQUEL
R&D Engineer
Mia-Software
4, rue du Château de l'Eraudiere
44324 NANTES CEDEX 03
----------------------------------------------------
Re: [JSP Component] Help with generation plugin [message #638925 is a reply to message #638687] Sat, 13 November 2010 10:28 Go to previous message
Toñi Reina is currently offline Toñi Reina
Messages: 206
Registered: July 2009
Senior Member
Thanks Fabien,

I have opened the Bug 330166
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=330166) and there you
have the .jspxmi file.

Regards,
Toñi

El 12/11/2010 9:17, Fabien escribió:
> ok, to go ahead i will need to debug.
>
> is it possible for you to create a bug under MoDisco project ?
> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=MDT.MoDi sco
> -> Technologies component.
> Then you may attach your .jspxmi file. I will debug the generation.
Previous Topic:Discovering Java Model from Java Source Code
Next Topic:Setting element 'ID's in KDM and traversing references
Goto Forum:
  


Current Time: Wed Oct 22 03:14:49 GMT 2014

Powered by FUDForum. Page generated in 0.02351 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software