Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » All text files modified?
All text files modified? [message #637931] Tue, 09 November 2010 11:49 Go to next message
Jochen Wiedmann is currently offline Jochen WiedmannFriend
Messages: 24
Registered: July 2009
Junior Member
Just enabled eGit for one of my repositories. The repository is unmodified:

bash-3.2$ git status .
# On branch master
nothing to commit (working directory clean)


Nevertheless, eGit (version 0.9.3) shows all text files as modified.

I tried to set core.eol to various values, nothing changed. Any ideas?

Thanks,

Jochen
Re: All text files modified? [message #645258 is a reply to message #637931] Thu, 16 December 2010 10:02 Go to previous messageGo to next message
Jochen Wiedmann is currently offline Jochen WiedmannFriend
Messages: 24
Registered: July 2009
Junior Member
Ping?
Re: All text files modified? [message #646091 is a reply to message #645258] Wed, 22 December 2010 01:43 Go to previous messageGo to next message
Jochen Wiedmann is currently offline Jochen WiedmannFriend
Messages: 24
Registered: July 2009
Junior Member
Pong?
Re: All text files modified? [message #652270 is a reply to message #637931] Thu, 03 February 2011 12:13 Go to previous messageGo to next message
ant is currently offline antFriend
Messages: 1
Registered: February 2011
Junior Member
same issue here using 0.11.0.201102020324 nightly
Re: All text files modified? [message #652494 is a reply to message #637931] Fri, 04 February 2011 09:50 Go to previous message
Manuel Doninger is currently offline Manuel DoningerFriend
Messages: 119
Registered: October 2010
Senior Member
This can happen, if you use the option core.autocrlf not the right way (or if that option is not set). See the wikipage at http://www.kernel.org/pub/software/scm/git/docs/gitattribute s.html, especially the paragraph "End-of-line conversion". There are also many discussions, e.g. at stackoverflow, about the right use of that option.

I have configured it to autocrlf=true on my windows computer, and autocrlf=input on my linux machine.
Previous Topic:Install prob - is there manually downloadable zip?
Next Topic:Egit : new branch
Goto Forum:
  


Current Time: Sun Nov 23 06:03:37 GMT 2014

Powered by FUDForum. Page generated in 0.03704 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software