Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE Headless build(compilation fails when performing a headless build)
PDE Headless build [message #637863] Tue, 09 November 2010 03:27 Go to next message
Florin Missing name is currently offline Florin Missing name
Messages: 6
Registered: November 2010
Junior Member
Hello,

I'm trying to perform a pde headless build.
The build fails as the plugins (all belonging to a single feature) are not compiled in the correct order.
The generated build.xml from the feature file has a target "all.plugins", with calls of type:

<ant antfile="build.xml" dir="../../plugins/com.my.first.plugin" target="${target}">
</ant>

But this target does not contains all the plugins listed in the feature and they are not in the correct order.
Hence compilation fails. In the same directory, there is another file, "compile.my.feature.xml".
It has a target called main with calls like this:
<ant antfile="build.xml" dir="../com.my.first.plugin" target="build.jars"/>
but this file, calls the build for all the plugins in my feature and also in the correct order (it seams though that the target from this file is not called).

What would cause the build.xml file to not call the build for all the plugins?

Is there a way to to specify compilation order?
Re: PDE Headless build [message #638161 is a reply to message #637863] Wed, 10 November 2010 04:14 Go to previous message
Florin Missing name is currently offline Florin Missing name
Messages: 6
Registered: November 2010
Junior Member
I' ve resolved the compilation problem.
It seams that appeared due to fact that reexported plugin dependencies were not taken in account (if C depended on B and B depended on A, I've added A to C plugin dependency list). I have also build against another Eclipse instance (not the development one, that had the plugins installed)
Previous Topic:Install of feature patch doesn't deploy plugin
Next Topic:Adding DropAdapter causes Widge is Disposed error
Goto Forum:
  


Current Time: Thu Aug 21 08:13:31 EDT 2014

Powered by FUDForum. Page generated in 0.01609 seconds