Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Install Error on Helios(Getting some dependency errors when trying to install on Helios)
Install Error on Helios [message #637622] Sun, 07 November 2010 20:49 Go to next message
Andrew Myers is currently offline Andrew Myers
Messages: 8
Registered: October 2010
Junior Member
I've just tried to install IAM on a clean install of Eclipse Helios for JEE (the download file was eclipse-jee-helios-SR1-win32.zip), however it's refusing to install and giving the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse IAM 0.11.0.201001181900 (org.eclipse.iam.feature.feature.group 0.11.0.201001181900)
Missing requirement: Eclipse IAM 0.11.0.201001181900 (org.eclipse.iam.feature.feature.group 0.11.0.201001181900) requires 'org.eclipse.emf.compare [1.0.0,2.0.0)' but it could not be found


The update site I'm using is http://q4e.googlecode.com/svn/trunk/updatesite-iam/

Has anyone else had this problem? I'm evening wondering if there may be some network problems at the moment causing it to be unable to download dependencies, however I am not certain how to confirm if that would be the case.

I have successfully installed q4e on Helios before so I'm really not sure what's happening.

Any suggestions most welcome.
Re: Install Error on Helios [message #637628 is a reply to message #637622] Sun, 07 November 2010 23:30 Go to previous messageGo to next message
Andrew Myers is currently offline Andrew Myers
Messages: 8
Registered: October 2010
Junior Member
Pretty sure this was some kind of network issue. I switched to the Yoxos marketplace and it installed from there without any problems
Re: Install Error on Helios [message #637849 is a reply to message #637622] Tue, 09 November 2010 02:54 Go to previous messageGo to next message
Andrew Myers is currently offline Andrew Myers
Messages: 8
Registered: October 2010
Junior Member
Not sure if anyone is interested or not, but I tried again from the google code update site today on a clean install of helios jee and still am getting errors:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Eclipse IAM Editors 0.11.0.201001181900 (org.eclipse.iam.feature.editor.feature.group 0.11.0.201001181900)
  Missing requirement: Eclipse IAM 0.11.0.201001181900 (org.eclipse.iam.feature.feature.group 0.11.0.201001181900) requires 'org.eclipse.emf.compare [1.0.0,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Eclipse IAM Editors 0.11.0.201001181900 (org.eclipse.iam.feature.editor.feature.group 0.11.0.201001181900)
    To: org.eclipse.iam.feature.feature.group [0.11.0,1.0.0)


I also tried on galileo and got this one:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Eclipse IAM Team Support 0.11.0.201001181900 (org.eclipse.iam.feature.teamsupport.feature.group 0.11.0.201001181900)
  Missing requirement: Eclipse IAM Maven Builder (Incubation) 0.11.0.201001181900 (org.eclipse.iam.builder 0.11.0.201001181900) requires 'bundle org.eclipse.emf.compare.match [1.0.0,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Eclipse IAM Team Support 0.11.0.201001181900 (org.eclipse.iam.feature.teamsupport.feature.group 0.11.0.201001181900)
    To: org.eclipse.iam.wizard [0.11.0,1.0.0)
  Cannot satisfy dependency:
    From: Eclipse IAM Maven JDT Integration Core (Incubation) 0.11.0.201001181900 (org.eclipse.iam.jdt.core 0.11.0.201001181900)
    To: bundle org.eclipse.iam.builder [0.11.0,1.0.0)
  Cannot satisfy dependency:
    From: Eclipse IAM Maven JDT Integration UI (Incubation) 0.11.0.201001181900 (org.eclipse.iam.jdt.ui 0.11.0.201001181900)
    To: bundle org.eclipse.iam.jdt.core [0.11.0,1.0.0)
  Cannot satisfy dependency:
    From: Eclipse IAM Wizard (Incubation) 0.11.0.201001181900 (org.eclipse.iam.wizard 0.11.0.201001181900)
    To: bundle org.eclipse.iam.jdt.ui [0.11.0,1.0.0)


Does anyone know what is missing here? I swear these worked on identical installs less than a week ago.
icon14.gif  Re: Install Error on Helios [message #638114 is a reply to message #637622] Tue, 09 November 2010 19:16 Go to previous message
Andrew Myers is currently offline Andrew Myers
Messages: 8
Registered: October 2010
Junior Member
I've chased this down to a broken mirror. It appears it was unable to find necessary dependencies.

C:\Users\andrew>wget http://download.eclipse.org/releases/helios/compositeConten
t.jar
SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
syswgetrc = C:\Program Files\gnuwin32/etc/wgetrc
--2010-11-10 10:25:54--  http://download.eclipse.org/releases/helios/compositeCo
ntent.jar
Resolving download.eclipse.org... 206.191.52.47
Connecting to download.eclipse.org|206.191.52.47|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://www.gtlib.gatech.edu/pub/eclipse/releases/helios/compositeConte
nt.jar [following]
--2010-11-10 10:25:55--  http://www.gtlib.gatech.edu/pub/eclipse/releases/helios
/compositeContent.jar
Resolving www.gtlib.gatech.edu... 128.61.111.10, 128.61.111.11, 128.61.111.9
Connecting to www.gtlib.gatech.edu|128.61.111.10|:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
2010-11-10 10:25:56 ERROR 403: Forbidden.


I changed it to use a different mirror for anything that started with http://download.eclipse.org/ and the issue went away.

For the record I think the handling of mirrors in the eclipse updater is pretty nasty. Who do we complain to Laughing
Previous Topic:Hot deployment functionality for maven EARs not working in latest versions.
Next Topic:Parent: null:maven-eclipse-plugin:maven-plugin:2.8 of project
Goto Forum:
  


Current Time: Tue Jul 29 23:01:29 EDT 2014

Powered by FUDForum. Page generated in 0.01885 seconds