Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Misplaced view toolbar(Misplaced view toolbar)
Misplaced view toolbar [message #636632] Tue, 02 November 2010 09:53 Go to next message
Heiko is currently offline HeikoFriend
Messages: 43
Registered: July 2009
Member
Hi,

in our RCP application we initialize all views of a perspective to display the correct view titles when changing the locale. We do this on part activation where we call "page.findView" or "page.getViews". With this the "createPartControl" method of each view will be called and each view will be initialized (also with its toolbar, etc.).

We had no problem with Eclipse 3.3, but now when upgrading to Eclipse 3.6.1 we got a problem with the proceeding mentioned above. With Eclipse 3.6.1 the toolbar of each view toolbar will be displayed above the view title bar of the view located in the upper left corner.

Thx for any help.

Regards,

Heiko
Re: Misplaced view toolbar [message #637379 is a reply to message #636632] Fri, 05 November 2010 10:08 Go to previous messageGo to next message
Heiko is currently offline HeikoFriend
Messages: 43
Registered: July 2009
Member
Is there anybody who has an advice?
Re: Misplaced view toolbar [message #637674 is a reply to message #637379] Mon, 08 November 2010 10:14 Go to previous messageGo to next message
Heiko is currently offline HeikoFriend
Messages: 43
Registered: July 2009
Member
Hi,

I've reproduced this behaviour with an example project (a modified RCP mail template project). Is it possible to attach it?

Regards,

Heiko
Re: Misplaced view toolbar [message #720617 is a reply to message #637674] Tue, 30 August 2011 23:46 Go to previous message
Marco Lopes is currently offline Marco LopesFriend
Messages: 56
Registered: September 2010
Member
This is a BUG that is addressed in one of the Indigo RC. If you switch to 3.7 you will no longer experience that problem.
Previous Topic:PreferenceDialog stange "cache" behavior
Next Topic:How to remove * in tab but still prompt when user clicks on close button?
Goto Forum:
  


Current Time: Sun Dec 21 13:00:36 GMT 2014

Powered by FUDForum. Page generated in 0.10445 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software