Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Changing fonts without effect
Changing fonts without effect [message #636489] Mon, 01 November 2010 14:54 Go to next message
Christian is currently offline Christian
Messages: 72
Registered: July 2009
Member
Hello Group,

I have got a problem.
A RCP application of mine has a functionality that lets users change
fonts for all Text/StyledText tables ... etc via settings. (all active
controls that need font cahnged react over a listener to changes in
properties)
This works fine on Windows and on Linux. But fails silently on
MacOsX(cocoa).

Any Idea how I could debug this?
I just don't know how to go on.. FontData created from String is fine.
Font created from FontData doesn't carry helpful information visible
from debugger..
Font is set to the controls.

I am just clueless what I could try to find the culprit for this problem.

Christian
Re: Changing fonts without effect [message #636597 is a reply to message #636489] Tue, 02 November 2010 06:48 Go to previous messageGo to next message
Prakash G.R. is currently offline Prakash G.R.
Messages: 621
Registered: July 2009
Senior Member
On 01/11/10 8:24 PM, Christian wrote:
> Hello Group,
>
> I have got a problem.
> A RCP application of mine has a functionality that lets users change
> fonts for all Text/StyledText tables ... etc via settings. (all active
> controls that need font cahnged react over a listener to changes in
> properties)
> This works fine on Windows and on Linux. But fails silently on
> MacOsX(cocoa).
>
> Any Idea how I could debug this?
> I just don't know how to go on.. FontData created from String is fine.
> Font created from FontData doesn't carry helpful information visible
> from debugger..
> Font is set to the controls.
>
> I am just clueless what I could try to find the culprit for this problem.
>
> Christian
>

Sounds like an SWT issue. CC-ing SWT forum.

A snippet would be easier for investigation.

--
- Prakash
Platform UI Team, IBM

www.eclipse-tips.com
Re: Changing fonts without effect [message #636701 is a reply to message #636597] Tue, 02 November 2010 13:47 Go to previous message
Christian is currently offline Christian
Messages: 72
Registered: July 2009
Member
Am 02.11.2010 07:48, schrieb Prakash G.R.:
> On 01/11/10 8:24 PM, Christian wrote:
>> Hello Group,
>>
>> I have got a problem.
>> A RCP application of mine has a functionality that lets users change
>> fonts for all Text/StyledText tables ... etc via settings. (all active
>> controls that need font cahnged react over a listener to changes in
>> properties)
>> This works fine on Windows and on Linux. But fails silently on
>> MacOsX(cocoa).
>>
>> Any Idea how I could debug this?
>> I just don't know how to go on.. FontData created from String is fine.
>> Font created from FontData doesn't carry helpful information visible
>> from debugger..
>> Font is set to the controls.
>>
>> I am just clueless what I could try to find the culprit for this problem.
>>
>> Christian
>>
>
> Sounds like an SWT issue. CC-ing SWT forum.
>
> A snippet would be easier for investigation.
>

Thanks
I will try to put a sscce together when I come home from work.
Currently I can only offer the whole application ( http://jucy.eu )
which is oss but a bit huge.
Previous Topic:FormEditor and canLeaveThePage
Next Topic:generate the sub tree from tree
Goto Forum:
  


Current Time: Thu Oct 30 15:59:07 GMT 2014

Powered by FUDForum. Page generated in 0.03320 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software