Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE Headless build migration to Helios problems.
PDE Headless build migration to Helios problems. [message #634242] Wed, 20 October 2010 18:27 Go to next message
Laurent Marchal is currently offline Laurent Marchal
Messages: 91
Registered: July 2009
Member
Hi all,

I have successfully been using every version of the PDE headless build
since eclipse 3.4. Today I migrated to helios from 3.5.2 to 3.6.1 and I
can not build my feature based RCP product anymore.

I extracted the delta pack into the eclipse folder itself as usual, but
I have this error (I am building from a Linux box)

BUILD FAILED
[java]
/eclipse_target/plugins/org.eclipse.pde.build_3.6.1.R36x_v20 100823/scripts/productBuild/productBuild.xml:39:
The following error occurred while executing this line:
[java]
/eclipse_target/plugins/org.eclipse.pde.build_3.6.1.R36x_v20 100823/scripts/productBuild/productBuild.xml:69:
Unable to find plug-in:
org.eclipse.equinox.launcher.win32.win32.x86_0.0.0. Please check the
error log for more details.

If I change the config parameter to build only for my platform "configs
= linux, gtk, x86" Then I have this error :

[java] BUILD FAILED
[java] ........
[java] java.io.FileNotFoundException:
/build/compile.org.eclipse.pde.build.container.feature.xml (No such file
or directory)

I have some files in the build folder :
compile.org.eclipse.pde.build.container.feature.all.xml and
compile.org.eclipse.pde.build.container.feature.linux.gtk.x8 6.xml

I didn't change anything to my build.properties file and it was building
before.. I spent few hours trying new things and looking if something
had changed in Helios without any success.

Any Ideas ?

Thanks.
Laurent Marchal.
Re: PDE Headless build migration to Helios problems. [message #634461 is a reply to message #634242] Thu, 21 October 2010 15:26 Go to previous messageGo to next message
Laurent Marchal is currently offline Laurent Marchal
Messages: 91
Registered: July 2009
Member
I found one solution for the java.io.FileNotFoundException
I had "topLevelElementId" defined in my build.properties file.
and the documentation says

"The id of the feature being built.
This property is new in 3.4 and depends on the use of the 3.4
allElements.xml file. Build configurations using older style
customTargets.xml and/or allElements.xml files should not use this
property."

But I still have problems with the delta pack.. Specified with
"pluginPath" or extracted over the eclipse folder I still have

Unable to find plug-in:
org.eclipse.equinox.launcher.win32.win32.x86_0.0.0. Please check the
error log for more details.


Le 10/20/2010 05:27 PM, Laurent Marchal a écrit :
> Hi all,
>
> I have successfully been using every version of the PDE headless build
> since eclipse 3.4. Today I migrated to helios from 3.5.2 to 3.6.1 and I
> can not build my feature based RCP product anymore.
>
> I extracted the delta pack into the eclipse folder itself as usual, but
> I have this error (I am building from a Linux box)
>
> BUILD FAILED
> [java]
> /eclipse_target/plugins/org.eclipse.pde.build_3.6.1.R36x_v20 100823/scripts/productBuild/productBuild.xml:39:
> The following error occurred while executing this line:
> [java]
> /eclipse_target/plugins/org.eclipse.pde.build_3.6.1.R36x_v20 100823/scripts/productBuild/productBuild.xml:69:
> Unable to find plug-in:
> org.eclipse.equinox.launcher.win32.win32.x86_0.0.0. Please check the
> error log for more details.
>
> If I change the config parameter to build only for my platform "configs
> = linux, gtk, x86" Then I have this error :
>
> [java] BUILD FAILED
> [java] ........
> [java] java.io.FileNotFoundException:
> /build/compile.org.eclipse.pde.build.container.feature.xml (No such file
> or directory)
>
> I have some files in the build folder :
> compile.org.eclipse.pde.build.container.feature.all.xml and
> compile.org.eclipse.pde.build.container.feature.linux.gtk.x8 6.xml
>
> I didn't change anything to my build.properties file and it was building
> before.. I spent few hours trying new things and looking if something
> had changed in Helios without any success.
>
> Any Ideas ?
>
> Thanks.
> Laurent Marchal.
Re: PDE Headless build migration to Helios problems. [message #634717 is a reply to message #634461] Fri, 22 October 2010 16:07 Go to previous message
Laurent Marchal is currently offline Laurent Marchal
Messages: 91
Registered: July 2009
Member
Found the second problem : my delta pack zip was corrupted...

Le 10/21/2010 02:26 PM, Laurent Marchal a écrit :
> I found one solution for the java.io.FileNotFoundException
> I had "topLevelElementId" defined in my build.properties file.
> and the documentation says
>
> "The id of the feature being built.
> This property is new in 3.4 and depends on the use of the 3.4
> allElements.xml file. Build configurations using older style
> customTargets.xml and/or allElements.xml files should not use this
> property."
>
> But I still have problems with the delta pack.. Specified with
> "pluginPath" or extracted over the eclipse folder I still have
>
> Unable to find plug-in:
> org.eclipse.equinox.launcher.win32.win32.x86_0.0.0. Please check the
> error log for more details.
>
>
> Le 10/20/2010 05:27 PM, Laurent Marchal a écrit :
>> Hi all,
>>
>> I have successfully been using every version of the PDE headless build
>> since eclipse 3.4. Today I migrated to helios from 3.5.2 to 3.6.1 and I
>> can not build my feature based RCP product anymore.
>>
>> I extracted the delta pack into the eclipse folder itself as usual, but
>> I have this error (I am building from a Linux box)
>>
>> BUILD FAILED
>> [java]
>> /eclipse_target/plugins/org.eclipse.pde.build_3.6.1.R36x_v20 100823/scripts/productBuild/productBuild.xml:39:
>>
>> The following error occurred while executing this line:
>> [java]
>> /eclipse_target/plugins/org.eclipse.pde.build_3.6.1.R36x_v20 100823/scripts/productBuild/productBuild.xml:69:
>>
>> Unable to find plug-in:
>> org.eclipse.equinox.launcher.win32.win32.x86_0.0.0. Please check the
>> error log for more details.
>>
>> If I change the config parameter to build only for my platform "configs
>> = linux, gtk, x86" Then I have this error :
>>
>> [java] BUILD FAILED
>> [java] ........
>> [java] java.io.FileNotFoundException:
>> /build/compile.org.eclipse.pde.build.container.feature.xml (No such file
>> or directory)
>>
>> I have some files in the build folder :
>> compile.org.eclipse.pde.build.container.feature.all.xml and
>> compile.org.eclipse.pde.build.container.feature.linux.gtk.x8 6.xml
>>
>> I didn't change anything to my build.properties file and it was building
>> before.. I spent few hours trying new things and looking if something
>> had changed in Helios without any success.
>>
>> Any Ideas ?
>>
>> Thanks.
>> Laurent Marchal.
Previous Topic:how to debug unresolved dependencies in PDE build
Next Topic:Feature install modifying config.ini?
Goto Forum:
  


Current Time: Fri Apr 18 01:34:39 EDT 2014

Powered by FUDForum. Page generated in 0.45023 seconds