Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Irritating behaviour of Bundle-Classpath - period (home dir) required, but i dont see why
Irritating behaviour of Bundle-Classpath - period (home dir) required, but i dont see why [message #634218] Wed, 20 October 2010 19:37
Simon L. is currently offline Simon L.Friend
Messages: 22
Registered: January 2010
Junior Member
Hello,
this morning, i spent many hours to figure out why classes inside jarred libraries couldn't been loaded from a plugin to my RCP. The libraries were inside a folder named "lib" in the plugin project. I did specify the .jars in the Manifest as follows:

Bundle-ClassPath: lib/jcommon-1.0.16.jar, lib/jfreechart-1.0.13.jar

But it didnt work. Figured out, that it works, when i append ",." to that classpath specification:

Bundle-ClassPath: lib/jcommon-1.0.16.jar, lib/jfreechart-1.0.13.jar,.

Why?! Please tell ;P

Edit: Some more details can be seen on this screenshot:
http://screencast.com/t/bPqlMCl46q

Edit2: Further information: with the bundle-classpath being just this dot, it doesnt work ("Bundle-ClassPath: .")

[Updated on: Wed, 20 October 2010 20:37]

Report message to a moderator

Previous Topic:Bundle-Classpath jars not put into dev.properties on launch
Next Topic:java.lang.NoClassDefFoundError: org/eclipse/core/runtime/IPath
Goto Forum:
  


Current Time: Wed Nov 26 11:18:10 GMT 2014

Powered by FUDForum. Page generated in 0.01767 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software