Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » My workflow - what am I doing wrong?
My workflow - what am I doing wrong? [message #633581] Mon, 18 October 2010 09:01 Go to next message
Brian is currently offline Brian
Messages: 1
Registered: October 2010
Junior Member
Requirments: 2 x devs working on repository on two different workstations

Workflow

1) Created two users on server and adding them to 'gitusers' group
2) Created /var/git folder and chgrp to 'gitusers'
3) Created directory in /var/git called 'test' and made it a bare shared repository (git init --bare --shared)
4) Go to Eclipse with egit on workstation 1, create new general project called 'test', add file test.txt.
5) go to team -> share project
6) Select git then create repository in the test folder -> workspace/test
7) Right click on project -> Team -> Push
Cool enter remote details e.g. ssh://bob@serverip:2020/var/git/test
9) 'Add all branches spec' and 'save specification in origin configuration.
10) Go to workstation 2 and go to File -> Import -> Projects from git
11) Clone - and then add the remote details above
12) Import existing projects and try to shared automatically
13) Project appears. Make a change to test.txt then Team -> Commit
14) Team -> Push and enter details.
15) Go to workstation 1, and team -> Fetch
16) Specify all branches (?) It seems that the option for destination is refs/remote/orgin? Is this right?
17) Changes are not reflected in to files in the project.

What am I doing wrong? Can you suggest an improved workflow?
Re: My workflow - what am I doing wrong? [message #635533 is a reply to message #633581] Wed, 27 October 2010 05:23 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel Doninger
Messages: 119
Registered: October 2010
Senior Member
Add the following step after step 16:
17) Merge the adequate remote branch into local branch

Now changes should appear in your branches.

Fetch only downloads and updates the remote-tracked branches, which you will find per default unter refs/remotes/remotename/. You have to merge incoming changes into your local branches.

EGit doesn't support the Pull-command yet, with pull command the steps 15 - 17 would be replaced by one step.
Re: My workflow - what am I doing wrong? [message #637516 is a reply to message #635533] Fri, 05 November 2010 20:15 Go to previous message
Matthias Sohn is currently offline Matthias Sohn
Messages: 543
Registered: July 2009
Senior Member
EGit 0.10 from nightly build supports pull, see the User Guide.
Previous Topic:is commit normally slow
Next Topic:Performing rollback
Goto Forum:
  


Current Time: Sat Jul 26 05:26:23 EDT 2014

Powered by FUDForum. Page generated in 0.01516 seconds