Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Tycho » Has anyone successfully built a RAP app using Maven Tycho?(Has anyone successfully built a RAP app using Maven Tycho?)
Has anyone successfully built a RAP app using Maven Tycho? [message #633447] Mon, 18 October 2010 04:02 Go to next message
Owen  is currently offline Owen
Messages: 17
Registered: May 2010
Junior Member
Hi,

I am trying to build my RAP app (http://codefaces.org) using Maven Tycho (http://www.eclipse.org/tycho/documentation.php). But unfortunately the Maven p2 resolver doesn't download fragments (org.eclipse.rap.rwt.q07.xxx.jar) and the build fails.

I am wondering anyone has successfully built a RAP app using it.

Many thanks,
Owen

[Updated on: Mon, 18 October 2010 04:24]

Report message to a moderator

Re: Has anything successfully built a RAP app using Maven Tycho? [message #633751 is a reply to message #633447] Tue, 19 October 2010 09:00 Go to previous messageGo to next message
Jan Sievers is currently offline Jan Sievers
Messages: 23
Registered: July 2009
Junior Member
if you don't have explicit dependencies to RAP fragments, I guess you have
to add them in your .target definition file.

See related post
http://software.2206966.n2.nabble.com/fragment-compilation-f ailure-td5238992.html#a5301998


HTH
Jan
"Owen" <jingweno@gmail.com> wrote in message
news:i9ggm2$20u$1@news.eclipse.org...
> Hi,
>
> I am trying to build my RAP app (http://codefaces.org) using Maven Tycho
> (http://www.eclipse.org/tycho/documentation.php). But unfortunately the
> Maven p2 resolver doesn't download fragments
> (org.eclipse.rap.rwt.q07.xxx.jar) and the build fails.
>
> I am wondering anyone has successfully built a RAP app using it.
> Many thanks,
> Owen
Re: Has anything successfully built a RAP app using Maven Tycho? [message #633889 is a reply to message #633751] Tue, 19 October 2010 17:35 Go to previous messageGo to next message
Owen  is currently offline Owen
Messages: 17
Registered: May 2010
Junior Member
Thanks Jan.

Now I met another problem after using the .target files for the target platform. Unfortunately the p2 resolver will resolve all dependencies of the target platform before continuing building my RAP app. Do I have a way to stop the p2 resolver from the resolution? The reason is that RAP's target platform is not meant to be resolved: http://dev.eclipse.org/newslists/news.eclipse.technology.rap /msg06930.html

The way that Tycho resolves the .target files differs from Eclipse's. Inside Eclipse, if I uncheck "Include required software" in the target platform editor, it won't try to resolve everything. But Tycho doesn't provide such option and always resolve all dependencies.

Thanks,
Owen


Jan Sievers wrote on Tue, 19 October 2010 05:00
if you don't have explicit dependencies to RAP fragments, I guess you have
to add them in your .target definition file.

See related post
http://software.2206966.n2.nabble.com/fragment-compilation-f ailure-td5238992.html#a5301998


HTH
Jan
"Owen" <jingweno@gmail.com> wrote in message
news:i9ggm2$20u$1@news.eclipse.org...
> Hi,
>
> I am trying to build my RAP app (http://codefaces.org) using Maven Tycho
> (http://www.eclipse.org/tycho/documentation.php). But unfortunately the
> Maven p2 resolver doesn't download fragments
> (org.eclipse.rap.rwt.q07.xxx.jar) and the build fails.
>
> I am wondering anyone has successfully built a RAP app using it.
> Many thanks,
> Owen

Re: Has anything successfully built a RAP app using Maven Tycho? [message #634059 is a reply to message #633889] Wed, 20 October 2010 11:49 Go to previous messageGo to next message
Jan Sievers is currently offline Jan Sievers
Messages: 23
Registered: July 2009
Junior Member
I am not aware the flag "include required software" is supported right now
in tycho
If this is the only way to build RAP applications, I guess we would need to
support such a flag in tycho for target platform resolution.

Can you open a bug with sample .product file attached and error stacktrace?

this may be related to the p2 resolution modes used (planner mode vs slicer
mode) but I am not sure.

https://issues.sonatype.org/browse/TYCHO

Regards
Jan


"Owen" <jingweno@gmail.com> wrote in message
news:i9kkmj$2t0$1@news.eclipse.org...
> Thanks Jan.
> Now I met another problem after using the .target files for the target
> platform. Unfortunately the p2 resolver will resolve all dependencies of
> the target platform before continuing building my RAP app. Do I have a way
> to stop the p2 resolver from the resolution? The reason is that RAP's
> target platform is not meant to be resolved:
> http://dev.eclipse.org/newslists/news.eclipse.technology.rap /msg06930.html
>
> The way that Tycho resolves the .target files differs from Eclipse's.
> Inside Eclipse, if I uncheck "Include required software" in the target
> platform editor, it won't try to resolve everything. But Tycho doesn't
> provide such option and always resolve all dependencies.
>
> Thanks,
> Owen
>
>
> Jan Sievers wrote on Tue, 19 October 2010 05:00
>> if you don't have explicit dependencies to RAP fragments, I guess you
>> have to add them in your .target definition file.
>>
>> See related post
>> http://software.2206966.n2.nabble.com/fragment-compilation-f
>> ailure-td5238992.html#a5301998
>>
>>
>> HTH
>> Jan
>> "Owen" <jingweno@gmail.com> wrote in message
>> news:i9ggm2$20u$1@news.eclipse.org...
>> > Hi,
>> >
>> > I am trying to build my RAP app (http://codefaces.org) using Maven
>> > Tycho (http://www.eclipse.org/tycho/documentation.php). But
>> > unfortunately the Maven p2 resolver doesn't download fragments
>> > (org.eclipse.rap.rwt.q07.xxx.jar) and the build fails.
>> >
>> > I am wondering anyone has successfully built a RAP app using it.
>> > Many thanks,
>> > Owen
>
>
Re: Has anyone successfully built a RAP app using Maven Tycho? [message #634194 is a reply to message #633447] Wed, 20 October 2010 18:31 Go to previous messageGo to next message
Jan Sievers is currently offline Jan Sievers
Messages: 23
Registered: July 2009
Junior Member
searching through the mailing list archive again, I think this may already be reported. Please attach your findings to
https://issues.sonatype.org/browse/TYCHO-477


Re: Has anyone successfully built a RAP app using Maven Tycho? [message #635184 is a reply to message #634194] Mon, 25 October 2010 21:47 Go to previous message
Owen  is currently offline Owen
Messages: 17
Registered: May 2010
Junior Member
Thanks Jan. I think you have summarized everything pretty well in the jira. That's exactly the problem I met. Hopefully it will get fixed in the next release.

Thanks,
Owen

Jan Sievers wrote on Wed, 20 October 2010 14:31
searching through the mailing list archive again, I think this may already be reported. Please attach your findings to
https://issues.sonatype.org/browse/TYCHO-477




Previous Topic:IllegalAccessErrors Running JUnit Tests During Build
Next Topic:Building a Product with additional files
Goto Forum:
  


Current Time: Sun Oct 26 07:49:48 GMT 2014

Powered by FUDForum. Page generated in 0.01634 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software