Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Buckminster builds don't include linked resources
Buckminster builds don't include linked resources [message #632132] Mon, 11 October 2010 12:56 Go to next message
Peter Woods is currently offline Peter Woods
Messages: 5
Registered: July 2009
Junior Member
I'm working on a large scale RCP project at the minute for one of my customers. They want me to improve the build process from using lots of custom Ant and Ivy scripts to something more intelligible. I've decided that Buckminster is the right tool for this job, and have created an appropriate R-Map to map out the project's resources, some C-Queries, etc. These all seem to work pretty well.

The customer uses the ClearCase version control system, however. It's extremely slow to build from because the "bin/" folder in your project lives on a network drive with your other project resources. To work around this, they have set up an Eclipse linked resource that maps "eclipse_build_loc" to, say "D:\Temp\build" for build output. Then inside each plug-in you include the following in the ".project" file.

	<linkedResources>
		<link>
			<name>bin</name>
			<type>2</type>
			<locationURI>eclipse_build_loc/myprojectname</locationURI>
		</link>
	</linkedResources>

This maps the output "bin/" directory to live on your local disk instead of on the network.

Unfortunately when you do a Buckminster build of these plug-ins they don't include the compiled classes. I thought I was so close after mapping out all the dozens of search locations out! Crying or Very Sad

Any suggestions on how to work around this? I've tried debugging the Buckminster process, but the codebase is too large for me to quickly find out what's going wrong. I'm not above patching my version of Buckminster, if necessary, until you guys can come up with a fix for this.

Sadly we can't just take out the linked resources stuff. Are things like a CSPEX to manually force the inclusion of the output directory sane?

A test plug-in that demonstrates this failure is downloadable from here.
Re: Buckminster builds don't include linked resources [message #632146 is a reply to message #632132] Mon, 11 October 2010 14:19 Go to previous messageGo to next message
Alan Underwood is currently offline Alan Underwood
Messages: 37
Registered: October 2010
Member
I've added a bug for this but that may be premature. I'm having the same problem.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=327441
Sad
Re: Buckminster builds don't include linked resources [message #632286 is a reply to message #632132] Tue, 12 October 2010 08:56 Go to previous messageGo to next message
Peter Woods is currently offline Peter Woods
Messages: 5
Registered: July 2009
Junior Member
I've posted a patch that goes some way to solving this problem on the bug report.
Re: Buckminster builds don't include linked resources [message #632759 is a reply to message #632132] Thu, 14 October 2010 04:03 Go to previous messageGo to next message
David  is currently offline David
Messages: 88
Registered: July 2009
Member
if you use clearcase, and build over an dynamic view (over the network) i suggest you instead create an snapshot view (local to the machine) and build from that instead.
Re: Buckminster builds don't include linked resources [message #632782 is a reply to message #632132] Thu, 14 October 2010 05:13 Go to previous messageGo to next message
Peter Woods is currently offline Peter Woods
Messages: 5
Registered: July 2009
Junior Member
If only the ClearCase support team "supported" snapshot views. Crying or Very Sad Thanks for the idea, though!
Re: Buckminster builds don't include linked resources [message #632799 is a reply to message #632782] Thu, 14 October 2010 06:27 Go to previous messageGo to next message
David  is currently offline David
Messages: 88
Registered: July 2009
Member
bah..who needs support Smile

*cough*"cleartool mkview -snapshot -tag $snapshot \\$localmachine\views\$snapshotviewname.vws"*cough on windows*

If they don't support snapshot views, they just made clearcase into an scm system you can't build large products with as you experienced.

cleartool mkview
cleartool: Error: View directory pathname must be specified.
cleartool: Error: View tag must be specified.
Usage: mkview -tag dynamic-view-tag [-tcomment tag-comment] [-tmode text-mode]
              [-region network-region | -stream stream-selector]
              [-shareable_dos | -nshareable_dos] [-cachesize size]
              { -stgloc {view-stgloc-name | -auto}
              | [-host hostname -hpath host-stg-pname -gpath global-stg-pname]
                dynamic-view-storage-pname
              }
       mkview -snapshot [-tag snapshot-view-tag]
              [-tcomment tag-comment] [-tmode text-mode]
              [-cachesize size] [-ptime] [-stream stream-selector]
              [ -stgloc view-stgloc-name
              | -colocated_server [-host hostname -hpath host-snapshot-view-pname -gpath global-snapshot-view-pname]
              | -vws view-storage-pname [-host hostname -hpath host-stg-pname -gpath global-stg-pname]
              ] snapshot-view-pname


Re: Buckminster builds don't include linked resources [message #632802 is a reply to message #632132] Thu, 14 October 2010 06:33 Go to previous messageGo to next message
Peter Woods is currently offline Peter Woods
Messages: 5
Registered: July 2009
Junior Member
I don't have permission to create views myself. The ClearCase team keep complete control over everything. If they didn't do that people could get their job done without ringing them all the time. Then maybe they'd be redundant - and they'd never want that!
Re: Buckminster builds don't include linked resources [message #633434 is a reply to message #632132] Sun, 17 October 2010 16:46 Go to previous messageGo to next message
Alan Underwood is currently offline Alan Underwood
Messages: 37
Registered: October 2010
Member
And even if clearcase could be worked around, you would still have to change all the .project files to remove the linked resource output. It doesn't fix the problem that Buckminster is not resolving linked resources properly.

Rolling Eyes
Re: Buckminster builds don't include linked resources [message #633601 is a reply to message #632132] Mon, 18 October 2010 10:19 Go to previous message
Peter Woods is currently offline Peter Woods
Messages: 5
Registered: July 2009
Junior Member
I can trivially remove all the entries from all the .project files with a script. But yes, as Alan says, this is something broken that is very simple to patch in basic support for.
Previous Topic:Upgrade of Buckminster tooling results in "org.eclipse.rcp:eclipse.feature was found "
Next Topic:Use ant properties in a customized category.xml
Goto Forum:
  


Current Time: Fri Apr 18 04:08:18 EDT 2014

Powered by FUDForum. Page generated in 0.02026 seconds