Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » can't import groovy-all bundle
can't import groovy-all bundle [message #631830] Fri, 08 October 2010 23:43 Go to next message
Kostas Kougios is currently offline Kostas KougiosFriend
Messages: 42
Registered: August 2010
Member
I am trying to import groovy-all bundle. Here is my manifest:
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Groovy Language Services
Bundle-SymbolicName: com.rits.groovy
Bundle-Version: 1.0.0
Bundle-Vendor: RITS
Import-Bundle: groovy-all;version="[1.7.5,2.0.0)",
 com.springsource.org.apache.log4j;version="[1.2.15,1.3.0)"
Export-Package: com.rits.groovy.manager

I do have groovy-all-1.7.5.jar in my maven2 repository under /home/ariskk/.m2/repository/org/codehaus/groovy/groovy-all/1 .7.5 and ofcourse I've configured virgo to scan the repository for bundles (this works because it finds other bundles)

Any ideas what might be wrong?

manifest.mf of groovy-all-1.7.5.jar:
...
Bundle-SymbolicName: groovy-all

Extension-Name: groovy

Implementation-Version: 1.7.5

...



The error msg:

Caused by: org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundl eDependenciesException: Unable to satisfy dependencies of bundle 'com.rits.groovy' at ver
sion '1.0.0': Import-Bundle with symbolic name 'groovy-all' in version range '[1.7.5, 2.0.0)' could not be satisfied
at org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.getBundlePackageImports(ImportExpans ionHandler.java:271)
at org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.getAdditionalPackageImports(ImportEx pansionHandler.java:236)






maven:
....
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>1.7.5</version>
</dependency>





org.eclipse.virgo.repository.properties:

ext.type=external
ext.searchPattern=repository/ext/{artifact}

usr.type=watched
usr.watchDirectory=repository/usr

mavenrepo.type=external
mavenrepo.searchPattern=${user.home}/.m2/repository/**/{bund le}.jar

mavenrepolibd.type=external
mavenrepolibd.searchPattern=${user.home}/.m2/repository/**/{ bundle}.libd

chain=mavenrepo,mavenrepolibd,ext,usr
Re: can't import groovy-all bundle [message #631881 is a reply to message #631830] Sat, 09 October 2010 23:12 Go to previous messageGo to next message
Kostas Kougios is currently offline Kostas KougiosFriend
Messages: 42
Registered: August 2010
Member
Strange, when I did

Require-Bundle: groovy-all;version="[1.7.5,2.0.0)"


it worked!

What's the difference??? (I know Import-Bundle is a virgo thing with different schematics than require-bundle)
Re: can't import groovy-all bundle [message #632016 is a reply to message #631881] Mon, 11 October 2010 08:39 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
require-bundle has several semantic "rough edges" compared to import-bundle (which is really syntactic sugar for a bundle of package imports). So it *might* be something do so with that difference.

But this seems very odd and may be a bug.

Please could you raise a bugzilla against Virgo and ideally attach a simple testcase which reproduces the problem. groovy-all is probably too large to attach, so a URL will do fine. If you can eliminate all extraneous dependencies and make this fail with groovy-all in repository/usr, that will simplify analysis of the bug considerably.

Often we find that in doing that kind of simplification, users find the source of the problem themselves, often in application code, so I would be grateful if you could have a go.
Re: can't import groovy-all bundle [message #632669 is a reply to message #632016] Wed, 13 October 2010 20:13 Go to previous messageGo to next message
Kostas Kougios is currently offline Kostas KougiosFriend
Messages: 42
Registered: August 2010
Member
Thanks Glyn. I was using M4 and I just upgraded to M6. Import-Bundle now works fine for the groovy-all bundle!

Maybe it was related to "Bug 325334: Import-Bundle of fragment that does not specify bundle version range"

Re: can't import groovy-all bundle [message #632762 is a reply to message #632669] Thu, 14 October 2010 08:27 Go to previous message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Excellent! Thanks for feeding back.
Previous Topic:Thread Context Class Loading in Web-Bundles
Next Topic:When does Virgo register the ApplicationContext service?
Goto Forum:
  


Current Time: Thu Nov 27 04:49:03 GMT 2014

Powered by FUDForum. Page generated in 0.04807 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software