Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Need help: Exported product dumps
Need help: Exported product dumps [message #631805] Fri, 08 October 2010 16:18
Karl Weber is currently offline Karl Weber
Messages: 63
Registered: September 2010
Member
Hi,

I don't get it. I have a product for an RCP application, that is running smoothly in the workbench. However, after export, the product does not run.

My environment is linux x86_64 gtk, Helios 3.6.1.

Target Platform defined, consisting of Eclipse RCP SDK, Eclipse Help System and Equinox P2 SDK, nebula CDateTime, the delta.pack and -- Eclipse SDK. I only need four plug-ins from the Eclipse SDK, but I have selected all plug-ins so far (due to another error, see separate post).

After exporting and starting the app, it dumps. Here an extract from the log

!SESSION 2010-10-08 21:51:21.724 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_18
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=${target.os}, ARCH=${target.arch}, WS=${target.ws}, NL=${target.nl}
Framework arguments: -log
Command-line arguments: -os ${target.os} -ws ${target.ws} -arch ${target.arch} -console -log -clean

!ENTRY org.eclipse.osgi 4 0 2010-10-08 21:51:22.891
!MESSAGE An error occurred while automatically activating bundle org.eclipse.ui.workbench (50).
!STACK 0

[...]
!ENTRY org.eclipse.osgi 2 0 2010-10-08 21:51:22.901
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-10-08 21:51:22.901
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20 100810 [32] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86_64 2 0 2010-10-08 21:51:22.901
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-10-08 21:51:22.901
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_64_3.6.1.v3655c [44] was not resolved.
!SUBENTRY 2 org.eclipse.swt.gtk.linux.x86_64 2 0 2010-10-08 21:51:22.901
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))

!ENTRY org.eclipse.osgi 4 0 2010-10-08 21:51:22.901
!MESSAGE Application error
!STACK 1

I don't understand this error message, as the mentioned bundles are exported by the wizard:

ls plugins/
com.ibm.icu_4.2.1.v20100412.jar org.eclipse.equinox.http.jetty_2.0.0.v20100503.jar
com.ibm.icu.source_4.2.1.v20100412.jar org.eclipse.equinox.http.registry_1.1.0.v20100503.jar
de.gps.app_1.0.0.jar org.eclipse.equinox.http.servlet_1.1.0.v20100503.jar
de.gps.db_1.0.0.jar org.eclipse.equinox.launcher_1.1.0.v20100507.jar
de.gps.db.ui_1.0.0.jar org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20 100810
de.gps.log_1.0.0 org.eclipse.equinox.preferences_3.3.0.v20100503.jar
de.gps.log.db_1.0.0.jar org.eclipse.equinox.registry_3.5.0.v20100503.jar
de.gps.log.ui_1.0.0.jar org.eclipse.equinox.util_1.0.200.v20100503.jar
de.gps.web_1.0.0.jar
org.eclipse.help_3.5.0.v20100524.jar
derby_10.6.1000000.938214 org.eclipse.jface_3.6.1.M20100825-0800.jar
derbytools_10.6.1000000.938214 org.eclipse.jface.databinding_1.4.0.I20100601-0800.jar
javax.servlet_2.5.0.v200910301333.jar org.eclipse.jface.text_3.6.1.r361_v20100825-0800.jar
org.apache.commons.logging_1.0.4.v201005080501.jar org.eclipse.nebula.cwt_0.9.0.HEAD.jar
org.eclipse.compare.core_3.5.100.I20100526-0800.jar org.eclipse.nebula.widgets.cdatetime_0.14.0.HEAD.jar
org.eclipse.core.commands_3.6.0.I20100512-1500.jar org.eclipse.osgi_3.6.1.R36x_v20100806.jar
org.eclipse.core.contenttype_3.4.100.v20100505-1235.jar org.eclipse.osgi.services_3.2.100.v20100503.jar
org.eclipse.core.databinding_1.3.100.I20100601-0800.jar org.eclipse.swt_3.6.1.v3655c.jar
org.eclipse.core.databinding.observable_1.3.0.I20100601-0800 .jar org.eclipse.swt.gtk.linux.x86_64_3.6.1.v3655c.jar
org.eclipse.core.databinding.property_1.3.0.I20100601-0800.j ar org.eclipse.text_3.5.0.v20100601-1300.jar
org.eclipse.core.expressions_3.4.200.v20100505.jar org.eclipse.ui_3.6.1.M20100826-1330.jar
org.eclipse.core.filesystem_1.3.1.R36x_v20100727-0745.jar org.eclipse.ui.console_3.5.0.v20100526.jar
org.eclipse.core.jobs_3.5.1.R36x_v20100824.jar org.eclipse.ui.forms_3.5.2.r36_v20100702.jar
org.eclipse.core.resources_3.6.0.R36x_v20100825-0600.jar org.eclipse.ui.views.log_1.0.100.v20100423.jar
org.eclipse.core.runtime_3.6.0.v20100505.jar org.eclipse.ui.workbench_3.6.1.M20100826-1330.jar
org.eclipse.core.variables_3.2.400.v20100505.jar org.eclipse.ui.workbench.texteditor_3.6.1.r361_v20100714-080 0.jar
org.eclipse.equinox.app_1.3.1.R36x_v20100803.jar org.mortbay.jetty.server_6.1.23.v201004211559.jar
org.eclipse.equinox.common_3.6.0.v20100503.jar org.mortbay.jetty.util_6.1.23.v201004211559.jar
org.eclipse.equinox.ds_1.2.1.R36x_v20100803.jar
org.rxtx_2.2.0.pre2


So, what is wrong here?
Previous Topic:Dynamic Jface tree Implementation
Next Topic:Need help: Target definition for RCP app not working
Goto Forum:
  


Current Time: Wed Aug 27 15:12:39 EDT 2014

Powered by FUDForum. Page generated in 0.01809 seconds