Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » eclipse unable to load native library: can't find dependent libraries
eclipse unable to load native library: can't find dependent libraries [message #631766] Fri, 08 October 2010 16:35 Go to next message
Mike Sacauskis is currently offline Mike Sacauskis
Messages: 2
Registered: October 2010
Junior Member
Not sure where to post this, so I thought I 'd try here. My helios install stopped working on me. I try to start it up and it just goes away. I ran it to try and get some debug (./eclipse -debug -console -consolelog> error.out) and get the following output:
Error occurred during initialization of VM
Unable to load native library: Can't find dependent libraries
Start VM: -Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-Djava.class.path=C:\Software\eclipse\plugins/org.eclipse.eq uinox.launcher_1.1.0.v20100507.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Software\eclipse\\plugins\org.eclipse.platform_3.6.1.v201 009090800\splash.bmp
-launcher C:\Software\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Software\eclipse\plugins/org.eclipse.equinox.launcher.win 32.win32.x86_64_1.1.1.R36x_v20100810\eclipse_1309.dll
-startup C:\Software\eclipse\plugins/org.eclipse.equinox.launcher_1.1 .0.v20100507.jar
-product org.eclipse.epp.package.jee.product
-debug
-console
-consolelog
-vm C:\Software\Java\jdk1.6.0_21\bin\server\jvm.dll
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-Djava.class.path=C:\Software\eclipse\plugins/org.eclipse.eq uinox.launcher_1.1.0.v20100507.jar

I just updated my java sdk to javac 1.6.0_21.

Any help would be greatly appreciated.
Re: eclipse unable to load native library: can't find dependent libraries [message #632680 is a reply to message #631766] Wed, 13 October 2010 21:12 Go to previous message
Mike Sacauskis is currently offline Mike Sacauskis
Messages: 2
Registered: October 2010
Junior Member
I resolved this by upgrading to jdk1.6.0_22.
Previous Topic:Eclipse 3.6, exporting a product: Where is the "Export to multiple platforms" option?
Next Topic:Running code from plug-in project in headless env
Goto Forum:
  


Current Time: Tue Oct 21 16:42:03 GMT 2014

Powered by FUDForum. Page generated in 0.02522 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software