Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Bundle-Classpath jars not put into dev.properties on launch
Bundle-Classpath jars not put into dev.properties on launch [message #631177] Wed, 06 October 2010 13:22 Go to next message
Chris Dail is currently offline Chris DailFriend
Messages: 2
Registered: October 2010
Junior Member
I have an eclipse plugin project that requires a lot of external jar file dependencies. The plugin places these on the Bundle-Classpath and includes them in the plugin when built through build.properties. If you export the plugin and run it through eclipse, everything works fine. When running through the launch configuration (ie: debugging), none of the extra jars are added to the classpath. Only class files from the source of the plugin are put on the classpath.

To show this easier, I put together a small dummy application.

Contents of Manifest.MF:

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Test-pde-project
Bundle-SymbolicName: test-pde-project
Bundle-Version: 1.0.0.qualifier
Require-Bundle: org.eclipse.ui,
 org.eclipse.core.runtime
Bundle-ClassPath: plugin-out.jar,
 lib/dummy.jar


Contents of build.properties:

source.plugin-out.jar = src/
output.. = bin/
bin.includes = META-INF/,\
               plugin-out.jar,\
               lib/dummy.jar


As you can see, plugin-out.jar contains the class files from my compiled plugin. The dummy.jar is a sample jar file that should be included with this plugin when running it. I would expect to see both of these in dev.properties when the PDE launches eclipse with this plugin. What actually happens though is this dev.properties is the one that is generated:

#
#Wed Oct 06 10:11:09 ADT 2010
test-pde-project=bin
@ignoredot@=true


Why is lib/dummy.jar not getting added to dev.properties? I did some reading around and my understanding is that it should be there? Can anyone tell me how I can get dummy.jar to be added to the runtime when running through the launch configuration?

Thanks
Re: Bundle-Classpath jars not put into dev.properties on launch [message #632327 is a reply to message #631177] Tue, 12 October 2010 14:49 Go to previous messageGo to next message
Chris Dail is currently offline Chris DailFriend
Messages: 2
Registered: October 2010
Junior Member
After some further digging on this issue I determined that there was not way to get the PDE to use the BundleClasspath including a library the way it was implemented. I have created a bug for this issue and included a patch the fixes the problem.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=327371
Re: Bundle-Classpath jars not put into dev.properties on launch [message #634051 is a reply to message #631177] Wed, 20 October 2010 11:54 Go to previous message
Simon L. is currently offline Simon L.Friend
Messages: 22
Registered: January 2010
Junior Member
Hello,
Today I think I had the same problem as you. Try this manifest entry instead:

"Bundle-ClassPath: plugin-out.jar, lib/dummy.jar,."

(and remeber ending the manifest file with a linebreak)

and dont ask me why this works >_> I puzzled 2 hours, and really dont care anymore Razz
Previous Topic:Problems with Run Configuration with Selected Features
Next Topic:Irritating behaviour of Bundle-Classpath - period (home dir) required, but i dont see why
Goto Forum:
  


Current Time: Sun Dec 21 02:46:43 GMT 2014

Powered by FUDForum. Page generated in 0.01842 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software