Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Ecore Tools » How to deploy a generated editor plug-in
icon5.gif  How to deploy a generated editor plug-in [message #630278] Fri, 01 October 2010 11:57 Go to next message
Kai Maschke is currently offline Kai Maschke
Messages: 16
Registered: October 2010
Junior Member
Hi,

I am trying to deploy an editor that was generated via a ecore-model, like described here http://www.vogella.de/articles/EclipseEMF/article.html#emfed itor

So, I am able to launch it in a new eclipse instance. But I like to use the editor as a real plug-in.

While searching I found this: http://agile.csc.ncsu.edu/SEMaterials/tutorials/plugin_dev/# section5_0

I followed the instructions and copied the jar to the eclipse plug-in folder.
After starting eclipse I get the error message:
Unable to access file "plugins/de.saintmetais.dqamm.editor_plugin.jar!META-INF/MANIFEST.MF".

This is the editor I created. But I see no reason why eclipse is unable to access the manifest. It is definetly in the jar at the exact location.

Does anyone know what the error might be?
icon14.gif  Re: How to deploy a generated editor plug-in [message #630288 is a reply to message #630278] Fri, 01 October 2010 12:39 Go to previous message
Kai Maschke is currently offline Kai Maschke
Messages: 16
Registered: October 2010
Junior Member
The issue is over! Solved it myself
Previous Topic:[Teneo] No primary key in table for multi-valued string attribute
Next Topic:ecorediag and ecore mismatch
Goto Forum:
  


Current Time: Wed Oct 22 23:18:01 GMT 2014

Powered by FUDForum. Page generated in 0.08792 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software