Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT Viewer 2.5.1 ISSUE(BIRT Viewer is running without producing results)
BIRT Viewer 2.5.1 ISSUE [message #629924] Thu, 30 September 2010 00:53 Go to next message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
I'm new in BIRT. I created a couple of reports running fine from ECLIPSE (Helios)

When I try to run the same projects using BIRT VIEWER 2.5.1 on Apache/Tomcat 5.5.30 doesn`t work. I tested the BIRT VIEWER installation with the sample and runs fine. However, my own reports just display the popup window with the message "Processsing, please wait..." and never ends.

I don't know what kind of logs to check or how to troubleshoot the issue. One of the reports is a simple list with 5 columns an less than 200 records.

Thanks.
Re: BIRT Viewer 2.5.1 ISSUE [message #630094 is a reply to message #629924] Thu, 30 September 2010 15:41 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Helios contains BIRT 2.6. Can you download the 2.6 runtime and deploy
the viewer it contains to tomcat and give it a try?

Jason

On 9/29/2010 8:53 PM, JuanD wrote:
> I'm new in BIRT. I created a couple of reports running fine from ECLIPSE
> (Helios)
>
> When I try to run the same projects using BIRT VIEWER 2.5.1 on
> Apache/Tomcat 5.5.30 doesn`t work. I tested the BIRT VIEWER installation
> with the sample and runs fine. However, my own reports just display the
> popup window with the message "Processsing, please wait..." and never ends.
>
> I don't know what kind of logs to check or how to troubleshoot the
> issue. One of the reports is a simple list with 5 columns an less than
> 200 records.
>
> Thanks.
Re: BIRT Viewer 2.5.1 ISSUE [message #630109 is a reply to message #630094] Thu, 30 September 2010 16:25 Go to previous messageGo to next message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
Hi Jason,

Thank you very much for your answer.

I tried with the version 2.6 of the runtime and I have the same symptom. Actually, it happens even with the test example.

I don't know if my issue is related to my OS. I am using Windows 7- 64 bits. Should I try a different Apache/Tomcat version?

Thanks again.

Juan Diego
Re: BIRT Viewer 2.5.1 ISSUE [message #630122 is a reply to message #630109] Thu, 30 September 2010 16:43 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Did you use the 2.6. or 2.6.1 runtime. I just tried the 2.6.1 runtime
with tomcat 5.5.20 with no issue. I have the same OS as you.

Jason

On 9/30/2010 12:25 PM, JuanD wrote:
> Hi Jason,
>
> Thank you very much for your answer.
>
> I tried with the version 2.6 of the runtime and I have the same symptom.
> Actually, it happens even with the test example.
>
> I don't know if my issue is related to my OS. I am using Windows 7- 64
> bits. Should I try a different Apache/Tomcat version?
>
> Thanks again.
>
> Juan Diego
Re: BIRT Viewer 2.5.1 ISSUE [message #630123 is a reply to message #630122] Thu, 30 September 2010 17:04 Go to previous messageGo to next message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
I tried 2.6.1. Should I try Apache 5.5.20?

Thanks a lot, again!
Re: BIRT Viewer 2.5.1 ISSUE [message #630128 is a reply to message #630123] Thu, 30 September 2010 17:11 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Are you getting anything in the \webapps\WebViewer\logs
directory?

I just tried tomcat 6.0.20 and had no issues.

Jason

On 9/30/2010 1:04 PM, JuanD wrote:
> I tried 2.6.1. Should I try Apache 5.5.20?
>
> Thanks a lot, again!
Re: BIRT Viewer 2.5.1 ISSUE [message #630130 is a reply to message #630128] Thu, 30 September 2010 17:30 Go to previous messageGo to next message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
The file ReportEngine_2010_09_30_13_27_30.log shows:

2010-09-30 13:29:23 org.eclipse.birt.report.engine.api.impl.RenderTask render
GRAVE: There is insufficient memory to execute this report.

It seems that this is the problem. How do I increase the available memory for BIRT?

Thanks.

Re: BIRT Viewer 2.5.1 ISSUE [message #630144 is a reply to message #630130] Thu, 30 September 2010 18:40 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Look in the catalina.bat file and edit the JAV_OPTS like below.

if not exist "%CATALINA_HOME%\bin\tomcat-juli.jar" goto noJuli
set JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=256m
:noJuli


Jason


On 9/30/2010 1:30 PM, JuanD wrote:
> The file ReportEngine_2010_09_30_13_27_30.log shows:
>
> 2010-09-30 13:29:23 org.eclipse.birt.report.engine.api.impl.RenderTask
> render
> GRAVE: There is insufficient memory to execute this report.
>
> It seems that this is the problem. How do I increase the available
> memory for BIRT?
>
> Thanks.
>
>
Re: BIRT Viewer 2.5.1 ISSUE [message #630281 is a reply to message #630144] Fri, 01 October 2010 12:15 Go to previous messageGo to next message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
Hi Jason,

I just looked at your last suggestion now. Unfortunately, I couldn't find the file catalilna.bat. Is it because my Apache is running as a service?

Thanks.

Juan Diego
Re: BIRT Viewer 2.5.1 ISSUE [message #630318 is a reply to message #630281] Fri, 01 October 2010 14:59 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

There should be a tomcat5w.exe in the tomcat bin.
Run it and select the java tab and enter
-XX:MaxPermSize=256m
in the Java Options box.

Jason


On 10/1/2010 8:15 AM, JuanD wrote:
> Hi Jason,
>
> I just looked at your last suggestion now. Unfortunately, I couldn't
> find the file catalilna.bat. Is it because my Apache is running as a
> service?
>
> Thanks.
>
> Juan Diego
Re: BIRT Viewer 2.5.1 ISSUE [message #630326 is a reply to message #630318] Fri, 01 October 2010 15:26 Go to previous messageGo to next message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
Hi Jason,

Thanks. I found the .exe file but when I try to execute it I get "access denied" (or something like that, it is in French), "unable to open the service 'tomcat5'".

I tried stopping the service or having it up and didn't work. I am suppose to be the Administrator for the machine.

Sorry for bothering so much. I am a newby on Apache/Tomcat too.

Thanks again.

Juan Diego
Re: BIRT Viewer 2.5.1 ISSUE [message #630362 is a reply to message #630326] Fri, 01 October 2010 18:18 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Juan,

It sounds like you do not have admin rights on the machine. You could
always download tomcat zip file instead of service and run the bat file
to start it up.

Jason

On 10/1/2010 11:26 AM, JuanD wrote:
> Hi Jason,
>
> Thanks. I found the .exe file but when I try to execute it I get "access
> denied" (or something like that, it is in French), "unable to open the
> service 'tomcat5'".
>
> I tried stopping the service or having it up and didn't work. I am
> suppose to be the Administrator for the machine.
>
> Sorry for bothering so much. I am a newby on Apache/Tomcat too.
>
> Thanks again.
>
> Juan Diego
Re: BIRT Viewer 2.5.1 ISSUE [message #630414 is a reply to message #630144] Fri, 01 October 2010 23:49 Go to previous message
JuanD  is currently offline JuanD
Messages: 7
Registered: September 2010
Junior Member
Hi Jason,

Solved. Tomcat 5.5.31 installed just as a folder and starting thourg startup.bat. Modified catalina.bat according to your instructions.

I really appreciate your help. Thanks.

Juan Diego
Previous Topic:Error on setMax using DateTimeDataSet series
Next Topic:Custom number format - is there a description ?
Goto Forum:
  


Current Time: Fri Sep 19 06:10:02 GMT 2014

Powered by FUDForum. Page generated in 0.02824 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software