Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » product export wizard fails(export of product fails with error message: Missing Constraint: Bundle-RequiredExecutionEnvironment: OSGi/Minimum-1.2)
product export wizard fails [message #629326] Mon, 27 September 2010 19:23 Go to next message
Tom is currently offline TomFriend
Messages: 2
Registered: September 2010
Location: Germany
Junior Member
Hi,

my product configuration seems to work as I can launch it from within the product overview page.
When I try to export it from that same page, an error message appears:

Processing inclusion from feature org.eclipse.pde.container.feature: Bundle org.eclipse.equinox.launcher_1.1.0.v20100507 failed to resolve.:
    Missing Constraint: Bundle-RequiredExecutionEnvironment: OSGi/Minimum-1.2


I don´t fully understand that message, at least not what I am supposed to do. Do I have to configure the ExecutionEnvironment in my eclipse preferences? I found explanations on how to install JRE´s into eclipse, but nothing about setting OSGi/Minimum-1.2.
How is it done?

Any help would be appreciated.
Re: product export wizard fails [message #631080 is a reply to message #629326] Wed, 06 October 2010 06:58 Go to previous messageGo to next message
Tom is currently offline TomFriend
Messages: 2
Registered: September 2010
Location: Germany
Junior Member
I setup a new workspace and product export works fine again Rolling Eyes . I still wonder what plugin was causing the error and why there was no exception stacktrace? Confused
Re: product export wizard fails [message #697553 is a reply to message #631080] Sun, 17 July 2011 06:50 Go to previous message
David Erickson is currently offline David EricksonFriend
Messages: 21
Registered: April 2010
Junior Member
I ran into this problem today, for anyone else that runs into it, the solution is to delete <workspace directory>/.metadata/.plugins/org.eclipse.core.resources

You'll need to re-import your projects after doing it.
Previous Topic:Setting HTTP Listener Port
Next Topic:update process error
Goto Forum:
  


Current Time: Thu Nov 27 13:14:40 GMT 2014

Powered by FUDForum. Page generated in 0.02231 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software