Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Problem while trying to export graphic from diagram
Problem while trying to export graphic from diagram [message #627838] Tue, 04 August 2009 12:35
Edaurd Bauer is currently offline Edaurd Bauer
Messages: 9
Registered: July 2010
Junior Member
Hey out there,

I have just started to use the tools fro the uml2. But as soon as I try
to export an arbitrary (right mouse click->File->Save As Image->PDF (or
anything else), I get the following warning in the error view

java.lang.NoClassDefFoundError:
org/eclipse/gmf/runtime/draw2d/ui/render/awt/internal/svg/ex port/GraphicsSVG
at
org.eclipse.gmf.runtime.diagram.ui.render.util.CopyToImageUt il.getDiagramGenerator(CopyToImageUtil.java:344)
at
org.eclipse.gmf.runtime.diagram.ui.render.util.CopyToImageUt il.copyToImage(CopyToImageUtil.java:303)
at
org.eclipse.gmf.runtime.diagram.ui.render.actions.CopyToImag eAction$1.run(CopyToImageAction.java:257)
at
org.eclipse.jface.operation.ModalContext.runInCurrentThread( ModalContext.java:464)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:372)
at
org.eclipse.jface.dialogs.ProgressMonitorDialog.run(Progress MonitorDialog.java:507)
at
org.eclipse.gmf.runtime.diagram.ui.render.actions.CopyToImag eAction.runCopyToImageUI(CopyToImageAction.java:167)
at
org.eclipse.gmf.runtime.diagram.ui.render.actions.CopyToImag eAction.run(CopyToImageAction.java:136)
at
org.eclipse.gmf.runtime.diagram.ui.render.actions.CopyToImag eAction$2.run(CopyToImageAction.java:389)
at
org.eclipse.emf.transaction.impl.TransactionalEditingDomainI mpl.runExclusive(TransactionalEditingDomainImpl.java:313)
at
org.eclipse.gmf.runtime.diagram.ui.render.actions.CopyToImag eAction.doRun(CopyToImageAction.java:385)
at
org.eclipse.gmf.runtime.common.ui.action.AbstractActionHandl er.run(AbstractActionHandler.java:359)
at
org.eclipse.gmf.runtime.common.ui.action.ActionManager$1.run (ActionManager.java:225)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at
org.eclipse.gmf.runtime.common.ui.action.ActionManager.run(A ctionManager.java:223)
at
org.eclipse.gmf.runtime.common.ui.action.AbstractActionHandl er.runWithEvent(AbstractActionHandler.java:377)
at
org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:584)
at
org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:501)
at
org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1176)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1200)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1185)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1 025)
at
org.eclipse.jface.action.ActionContributionItem$9.handleEven t(ActionContributionItem.java:1284)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1176)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3493)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3112)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2405)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 21)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:493)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:194)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
Caused by:
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter $TerminatingClassNotFoundException:
An error occurred while automatically activating bundle
org.eclipse.gmf.runtime.draw2d.ui.render.awt (386).
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:125)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:449)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:211)
at
org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass (BundleLoader.java:376)
at
org.eclipse.osgi.internal.loader.SingleSourcePackage.loadCla ss(SingleSourcePackage.java:33)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClassInter nal(BundleLoader.java:449)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:405)
at
org.eclipse.osgi.internal.loader.BundleLoader.findClass(Bund leLoader.java:393)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320 )
... 49 more
Caused by: org.osgi.framework.BundleException: The activator
org.eclipse.gmf.runtime.draw2d.ui.render.awt.internal.Draw2d RenderPlugin
for bundle org.eclipse.gmf.runtime.draw2d.ui.render.awt is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:157)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:750)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:352)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:280)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:408)
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:111)
... 59 more
Caused by: java.lang.InternalError: libXt loaded before libXm
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1778)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1695)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1028)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction. java:50)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1592)
at java.awt.Toolkit.<clinit>(Toolkit.java:1614)
at java.awt.Color.<clinit>(Color.java:263)
at
org.eclipse.gmf.runtime.draw2d.ui.render.awt.internal.Draw2d RenderPlugin.initAWT(Draw2dRenderPlugin.java:56)
at
org.eclipse.gmf.runtime.draw2d.ui.render.awt.internal.Draw2d RenderPlugin. <init>(Draw2dRenderPlugin.java:52)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e Method)
at
sun.reflect.NativeConstructorAccessorImpl.newInstance(Native ConstructorAccessorImpl.java:39)
at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(De legatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:5 13)
at java.lang.Class.newInstance0(Class.java:355)
at java.lang.Class.newInstance(Class.java:308)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:152)
... 64 more


I am using Eclipse Galileo, and have installed the UML2 tools today via
the updater. Have I missed to install a particular package, or is this a
known problem?

Thanks for any help
Kind regards
Ede
Previous Topic:Reload UML2 for genmodel programmatically
Next Topic:Operations Package Export in GenModel
Goto Forum:
  


Current Time: Thu Oct 02 04:33:00 GMT 2014

Powered by FUDForum. Page generated in 0.04461 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software