Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Applying stereotypes
Applying stereotypes [message #627835] Sun, 02 August 2009 06:39
Eban Escott is currently offline Eban EscottFriend
Messages: 61
Registered: July 2009
Member
Hello, I am doing my first UML2 profile and have been following the
article below.

http://www.eclipse.org/modeling/mdt/uml2/docs/articles/Intro duction_to_UML2_Profiles/article.html

It all seems to go well up until the 'Applying Stereotypes' section step 3:

1) Select an element (i.e. <Property> pendingOrders : PurchaseOrder [0..*]
in <Class> Supplier) in the UML editor.
2) Select the UML Editor > Element > Apply Stereotype¬Ö menu item.
3) Choose a stereotype (i.e. ecore::EReference), press the Add button,
then press the OK button.

When the dialogue appears with the available choices it is empty!? Hmm, I
have tried it several times and playd around with it and searched the
newsgroup but I can't work it out. I am sure it will be simple as all the
doco states that doing a lightweight extension is easy :)

For what reason could the choices dialogue be empty? I have applied the
profile as per the previous steps in the article.

Thanks in advance
Eban
Previous Topic:DerivedSubsetEList won't be generated
Next Topic:Reload UML2 for genmodel programmatically
Goto Forum:
  


Current Time: Mon Dec 22 14:22:01 GMT 2014

Powered by FUDForum. Page generated in 0.02533 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software