Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » UML2 Tools and Helios
UML2 Tools and Helios [message #625637] Sat, 05 June 2010 11:08
Eclipse User
Originally posted by: formatzeh.gmx.de

The UML2 Tools aren't included in the Helios RC3. As I wanted to install
them by update url
http://download.eclipse.org/modeling/mdt/updates/releases/ I checked the
latest incubation version 0.9.0 from there. But the installation
couldn't be completed because of the inconsistencies I attached at the
end of this message. Is there a possibility to get the nice UML2
diagrams working in the Helios RC3? Or do I have to check out it from
the CVS?

best regards,
Gilbert


Cannot complete the install because of a conflicting dependency.
Software being installed: UML2 Diagramming (Incubation)
0.9.0.v200906190654 (org.eclipse.uml2.diagram.feature.group
0.9.0.v200906190654)
Software currently installed: Eclipse Modeling Tools
1.3.0.20100529-0859 (epp.package.modeling 1.3.0.20100529-0859)
Only one of the following can be installed at once:
EMF Ecore 2.5.0.v200906151043 (org.eclipse.emf.ecore
2.5.0.v200906151043)
EMF Ecore 2.1.1 (org.eclipse.emf.ecore 2.1.1)
EMF Ecore 2.2.4.v200808252119 (org.eclipse.emf.ecore
2.2.4.v200808252119)
EMF Ecore 2.4.1.v200808251517 (org.eclipse.emf.ecore
2.4.1.v200808251517)
EMF Ecore 2.3.2.v200802051830 (org.eclipse.emf.ecore
2.3.2.v200802051830)
EMF Ecore 2.0.4 (org.eclipse.emf.ecore 2.0.4)
EMF Ecore 2.6.0.v20100527-1913 (org.eclipse.emf.ecore
2.6.0.v20100527-1913)
EMF Ecore 2.4.2.v200902171115 (org.eclipse.emf.ecore
2.4.2.v200902171115)
Cannot satisfy dependency:
From: Eclipse Modeling Tools 1.3.0.20100529-0859
(epp.package.modeling 1.3.0.20100529-0859)
To: org.eclipse.epp.package.modeling.feature.feature.group
[1.3.0.20100529-0859]
Cannot satisfy dependency:
From: Ecore Tools (Incubation) 0.10.0.v20100521-2009
(org.eclipse.emf.ecoretools 0.10.0.v20100521-2009)
To: bundle org.eclipse.emf.ecore [2.6.0,3.0.0)
Cannot satisfy dependency:
From: Ecore Tools (Incubation) 0.10.0.v20100601-1628
(org.eclipse.emf.ecoretools.feature.group 0.10.0.v20100601-1628)
To: org.eclipse.emf.ecoretools [0.10.0.v20100521-2009]
Cannot satisfy dependency:
From: Ecore Tools SDK (Incubation) 0.10.0.v20100601-1628
(org.eclipse.emf.ecoretools.sdk.feature.group 0.10.0.v20100601-1628)
To: org.eclipse.emf.ecoretools.feature.group [0.10.0.v20100601-1628]
Cannot satisfy dependency:
From: Object Constraint Language (OCL) 2.0 Compatibility API
1.1.101.v200808291106 (org.eclipse.emf.ocl 1.1.101.v200808291106)
To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Object Constraint Language (OCL) 2.0 Compatibility API
1.1.101.v200901271800 (org.eclipse.emf.ocl 1.1.101.v200901271800)
To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Object Constraint Language (OCL) 2.0 Compatibility API
1.1.101.v200908161630 (org.eclipse.emf.ocl 1.1.101.v200908161630)
To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
Cannot satisfy dependency:
From: EPP Modeling Feature 1.3.0.20100529-0859
(org.eclipse.epp.package.modeling.feature.feature.group 1.3.0.20100529-0859)
To: org.eclipse.emf.ecoretools.sdk.feature.group 0.0.0
Cannot satisfy dependency:
From: OCL 2.0 Binding for Ecore 1.2.1.v200807301850
(org.eclipse.ocl.ecore 1.2.1.v200807301850)
To: bundle org.eclipse.emf.ecore [2.4.0,2.5.0)
Cannot satisfy dependency:
From: OCL 2.0 Binding for Ecore 1.3.0.v200905271400
(org.eclipse.ocl.ecore 1.3.0.v200905271400)
To: bundle org.eclipse.emf.ecore [2.5.0,2.6.0)
Cannot satisfy dependency:
From: UML2 Activity Diagram Plugin (Incubation) 0.9.0.v200906190654
(org.eclipse.uml2.diagram.activity 0.9.0.v200906190654)
To: bundle org.eclipse.emf.ocl 0.0.0
Cannot satisfy dependency:
From: UML2 Diagramming (Incubation) 0.9.0.v200906190654
(org.eclipse.uml2.diagram.feature.group 0.9.0.v200906190654)
To: org.eclipse.uml2.diagram.activity [0.9.0.v200906190654]
Previous Topic:Problem when programatically deleting diagram file
Next Topic:How can I add a dependency on org.eclipse.uml2tools plugin
Goto Forum:
  


Current Time: Sun Aug 31 00:38:16 EDT 2014

Powered by FUDForum. Page generated in 0.01425 seconds