Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » uml2tools newbie - Trouble with basic functionality
uml2tools newbie - Trouble with basic functionality [message #624831] Wed, 02 September 2009 03:09
Eclipse User
Originally posted by: mail.scottgurney.com

I am a long-time user of Eclipse however I'm a new user of UML2tools. I
would appreciate some help getting me over the following hurdles.

Background
I'm trying to draw a simple class diagram and having considerable
difficulty. (I'm following the basic tutorial documented here:
http://www.vogella.de/articles/UML/article.html)

Hurdle 1
I can create the classes and their attributes/operations. However, when I
try to follow the step "If you select your UML diagram and click on the
outgoing arrow you can create associations", I am not able to associate a
class to another class. When I click the outgoing arrow and hover over
another class, the cursor becomes a "prohibited" symbol (circle with line
through it). Creating connections, i.e. associations, using the arrows
does not work for me.

Hurdle 2
As a workaround, I can use the Palette to create an Navigable Association
between classes. However, I am not able to create a simple one-way,
directed association as described in messages #476574 and #476575.
( http://www.eclipse.org/forums/index.php?t=msg&S=de1bf5eb c736c32670cb63280e089c76&th=151479&goto=476574#msg_4 76574)
The association does not have preferences for "-Show all arrows and x’s.
-Suppress all arrows and x’s.
-Show one-way navigibility only"

Please help.

Scott
Previous Topic:Getting started with Topcased
Next Topic:uml2tools newbie - Trouble with basic functionality
Goto Forum:
  


Current Time: Mon Oct 20 22:54:55 GMT 2014

Powered by FUDForum. Page generated in 0.02349 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software