Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » CDateTime issues since 26 January?
CDateTime issues since 26 January? [message #62844] Wed, 18 February 2009 04:10 Go to next message
Liviu-Marian Negrila is currently offline Liviu-Marian Negrila
Messages: 53
Registered: July 2009
Member
Hello,

I've checked out the CDateTime project from the eclipse CVS and got it
working in my application on the 26 January.

I did that becouse the old CDateTime I've used would't work correctly a
Vista system (the menu bar would dissapear under a white bar after the
drop down composite would show).

The 26 January version I got from the eclipse CVS corrected this problem
but I had other issues:

- If I would open and close the drop down 4 times in a row by clicking
on the botton (aka arrow button in a normal combo) then the CDateTime
would start to preselect days (Ex it would auto-select the day 21 and if
I pressed on 15 without going with the mouse over 21 a priori then it
would still select the 21rst day of that date - it could trick the user
that he selected the 15 but actually the CDateTime selected 21 or so;
note that after the 4th drop of the combo the date that it
'auto-selected' kept changing circulary following a diagonal pattern
parallel with the secondary diagonal of the square)

- moreover if I tried to use the arrows on the keyboard to change the
selection then the whole app would freeze

I did a compare with the date 26 january to check weather there have
been changes that could correct this but I would like to check with you
if these issues are already corrected or can otherwise be workedaround.

For now I rolled back to the old CDateTime and miss the chance to run my
app on a Vista box.

Please advice.

Thanks,
Liviu
Re: CDateTime issues since 26 January? [message #62870 is a reply to message #62844] Thu, 19 February 2009 08:23 Go to previous messageGo to next message
Jeremy Dowdall is currently offline Jeremy Dowdall
Messages: 181
Registered: July 2009
Senior Member
Hi Liviu,

Thanks for the excellent and thorough description of this problem. The
first actually sounds like an internal focus problem - do these issues
happen on XP or is it specific to Vista?
Please file a bug for each of these and I'll try to get to them shortly
- I just haven't had time to run Vista lately.

Liviu wrote:
> Hello,
>
> I've checked out the CDateTime project from the eclipse CVS and got it
> working in my application on the 26 January.
>
> I did that becouse the old CDateTime I've used would't work correctly a
> Vista system (the menu bar would dissapear under a white bar after the
> drop down composite would show).
>
> The 26 January version I got from the eclipse CVS corrected this problem
> but I had other issues:
>
> - If I would open and close the drop down 4 times in a row by clicking
> on the botton (aka arrow button in a normal combo) then the CDateTime
> would start to preselect days (Ex it would auto-select the day 21 and if
> I pressed on 15 without going with the mouse over 21 a priori then it
> would still select the 21rst day of that date - it could trick the user
> that he selected the 15 but actually the CDateTime selected 21 or so;
> note that after the 4th drop of the combo the date that it
> 'auto-selected' kept changing circulary following a diagonal pattern
> parallel with the secondary diagonal of the square)
>
> - moreover if I tried to use the arrows on the keyboard to change the
> selection then the whole app would freeze
>
> I did a compare with the date 26 january to check weather there have
> been changes that could correct this but I would like to check with you
> if these issues are already corrected or can otherwise be workedaround.
>
> For now I rolled back to the old CDateTime and miss the chance to run my
> app on a Vista box.
>
> Please advice.
>
> Thanks,
> Liviu
Re: CDateTime issues since 26 January? [message #62876 is a reply to message #62870] Thu, 19 February 2009 13:17 Go to previous messageGo to next message
Liviu-Marian Negrila is currently offline Liviu-Marian Negrila
Messages: 53
Registered: July 2009
Member
Hi Jeremy,

They happen on XP.

I only tested on Vista that it would not kill the menu bar and it didn't
but on XP I had that focus problem you identified.

I did not test on vista for those bugs. I may do so next week
(Monday-Tuesday?).

I will file the bugs in about 20 hours.

Thanks
Liviu

Jeremy Dowdall wrote:
> Hi Liviu,
>
> Thanks for the excellent and thorough description of this problem. The
> first actually sounds like an internal focus problem - do these issues
> happen on XP or is it specific to Vista?
> Please file a bug for each of these and I'll try to get to them shortly
> - I just haven't had time to run Vista lately.
>
> Liviu wrote:
>> Hello,
>>
>> I've checked out the CDateTime project from the eclipse CVS and got it
>> working in my application on the 26 January.
>>
>> I did that becouse the old CDateTime I've used would't work correctly a
>> Vista system (the menu bar would dissapear under a white bar after the
>> drop down composite would show).
>>
>> The 26 January version I got from the eclipse CVS corrected this problem
>> but I had other issues:
>>
>> - If I would open and close the drop down 4 times in a row by clicking
>> on the botton (aka arrow button in a normal combo) then the CDateTime
>> would start to preselect days (Ex it would auto-select the day 21 and if
>> I pressed on 15 without going with the mouse over 21 a priori then it
>> would still select the 21rst day of that date - it could trick the user
>> that he selected the 15 but actually the CDateTime selected 21 or so;
>> note that after the 4th drop of the combo the date that it
>> 'auto-selected' kept changing circulary following a diagonal pattern
>> parallel with the secondary diagonal of the square)
>>
>> - moreover if I tried to use the arrows on the keyboard to change the
>> selection then the whole app would freeze
>>
>> I did a compare with the date 26 january to check weather there have
>> been changes that could correct this but I would like to check with you
>> if these issues are already corrected or can otherwise be workedaround.
>>
>> For now I rolled back to the old CDateTime and miss the chance to run my
>> app on a Vista box.
>>
>> Please advice.
>>
>> Thanks,
>> Liviu
Re: CDateTime issues since 26 January? [message #62897 is a reply to message #62876] Mon, 02 March 2009 10:54 Go to previous messageGo to next message
Liviu-Marian Negrila is currently offline Liviu-Marian Negrila
Messages: 53
Registered: July 2009
Member
Hi Jeremy,

I forgot to tell you my hours tend to be quite long sometimes.

Here are the bugs:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=266694
https://bugs.eclipse.org/bugs/show_bug.cgi?id=266698

I'd offer my time to correct this but I don't really know where to
start; on the other hand my client has already moved some systems on
Vista and, you guessed it, I'm rather desperate.
Please advice.

Thanks
Liviu

Liviu wrote:
> Hi Jeremy,
>
> They happen on XP.
>
> I only tested on Vista that it would not kill the menu bar and it didn't
> but on XP I had that focus problem you identified.
>
> I did not test on vista for those bugs. I may do so next week
> (Monday-Tuesday?).
>
> I will file the bugs in about 20 hours.
>
> Thanks
> Liviu
>
> Jeremy Dowdall wrote:
>> Hi Liviu,
>>
>> Thanks for the excellent and thorough description of this problem. The
>> first actually sounds like an internal focus problem - do these issues
>> happen on XP or is it specific to Vista?
>> Please file a bug for each of these and I'll try to get to them shortly
>> - I just haven't had time to run Vista lately.
>>
>> Liviu wrote:
>>> Hello,
>>>
>>> I've checked out the CDateTime project from the eclipse CVS and got it
>>> working in my application on the 26 January.
>>>
>>> I did that becouse the old CDateTime I've used would't work correctly a
>>> Vista system (the menu bar would dissapear under a white bar after the
>>> drop down composite would show).
>>>
>>> The 26 January version I got from the eclipse CVS corrected this problem
>>> but I had other issues:
>>>
>>> - If I would open and close the drop down 4 times in a row by clicking
>>> on the botton (aka arrow button in a normal combo) then the CDateTime
>>> would start to preselect days (Ex it would auto-select the day 21 and if
>>> I pressed on 15 without going with the mouse over 21 a priori then it
>>> would still select the 21rst day of that date - it could trick the user
>>> that he selected the 15 but actually the CDateTime selected 21 or so;
>>> note that after the 4th drop of the combo the date that it
>>> 'auto-selected' kept changing circulary following a diagonal pattern
>>> parallel with the secondary diagonal of the square)
>>>
>>> - moreover if I tried to use the arrows on the keyboard to change the
>>> selection then the whole app would freeze
>>>
>>> I did a compare with the date 26 january to check weather there have
>>> been changes that could correct this but I would like to check with you
>>> if these issues are already corrected or can otherwise be workedaround.
>>>
>>> For now I rolled back to the old CDateTime and miss the chance to run my
>>> app on a Vista box.
>>>
>>> Please advice.
>>>
>>> Thanks,
>>> Liviu
Re: CDateTime issues since 26 January? [message #62900 is a reply to message #62897] Mon, 02 March 2009 20:08 Go to previous message
Jeremy Dowdall is currently offline Jeremy Dowdall
Messages: 181
Registered: July 2009
Senior Member
> I forgot to tell you my hours tend to be quite long sometimes.

no problem, that happens :)

thanks for filing the bugs, I'll follow up there...
Re: CDateTime issues since 26 January? [message #593734 is a reply to message #62844] Thu, 19 February 2009 08:23 Go to previous message
Jeremy Dowdall is currently offline Jeremy Dowdall
Messages: 181
Registered: July 2009
Senior Member
Hi Liviu,

Thanks for the excellent and thorough description of this problem. The
first actually sounds like an internal focus problem - do these issues
happen on XP or is it specific to Vista?
Please file a bug for each of these and I'll try to get to them shortly
- I just haven't had time to run Vista lately.

Liviu wrote:
> Hello,
>
> I've checked out the CDateTime project from the eclipse CVS and got it
> working in my application on the 26 January.
>
> I did that becouse the old CDateTime I've used would't work correctly a
> Vista system (the menu bar would dissapear under a white bar after the
> drop down composite would show).
>
> The 26 January version I got from the eclipse CVS corrected this problem
> but I had other issues:
>
> - If I would open and close the drop down 4 times in a row by clicking
> on the botton (aka arrow button in a normal combo) then the CDateTime
> would start to preselect days (Ex it would auto-select the day 21 and if
> I pressed on 15 without going with the mouse over 21 a priori then it
> would still select the 21rst day of that date - it could trick the user
> that he selected the 15 but actually the CDateTime selected 21 or so;
> note that after the 4th drop of the combo the date that it
> 'auto-selected' kept changing circulary following a diagonal pattern
> parallel with the secondary diagonal of the square)
>
> - moreover if I tried to use the arrows on the keyboard to change the
> selection then the whole app would freeze
>
> I did a compare with the date 26 january to check weather there have
> been changes that could correct this but I would like to check with you
> if these issues are already corrected or can otherwise be workedaround.
>
> For now I rolled back to the old CDateTime and miss the chance to run my
> app on a Vista box.
>
> Please advice.
>
> Thanks,
> Liviu
Re: CDateTime issues since 26 January? [message #593746 is a reply to message #62870] Thu, 19 February 2009 13:17 Go to previous message
Liviu-Marian Negrila is currently offline Liviu-Marian Negrila
Messages: 53
Registered: July 2009
Member
Hi Jeremy,

They happen on XP.

I only tested on Vista that it would not kill the menu bar and it didn't
but on XP I had that focus problem you identified.

I did not test on vista for those bugs. I may do so next week
(Monday-Tuesday?).

I will file the bugs in about 20 hours.

Thanks
Liviu

Jeremy Dowdall wrote:
> Hi Liviu,
>
> Thanks for the excellent and thorough description of this problem. The
> first actually sounds like an internal focus problem - do these issues
> happen on XP or is it specific to Vista?
> Please file a bug for each of these and I'll try to get to them shortly
> - I just haven't had time to run Vista lately.
>
> Liviu wrote:
>> Hello,
>>
>> I've checked out the CDateTime project from the eclipse CVS and got it
>> working in my application on the 26 January.
>>
>> I did that becouse the old CDateTime I've used would't work correctly a
>> Vista system (the menu bar would dissapear under a white bar after the
>> drop down composite would show).
>>
>> The 26 January version I got from the eclipse CVS corrected this problem
>> but I had other issues:
>>
>> - If I would open and close the drop down 4 times in a row by clicking
>> on the botton (aka arrow button in a normal combo) then the CDateTime
>> would start to preselect days (Ex it would auto-select the day 21 and if
>> I pressed on 15 without going with the mouse over 21 a priori then it
>> would still select the 21rst day of that date - it could trick the user
>> that he selected the 15 but actually the CDateTime selected 21 or so;
>> note that after the 4th drop of the combo the date that it
>> 'auto-selected' kept changing circulary following a diagonal pattern
>> parallel with the secondary diagonal of the square)
>>
>> - moreover if I tried to use the arrows on the keyboard to change the
>> selection then the whole app would freeze
>>
>> I did a compare with the date 26 january to check weather there have
>> been changes that could correct this but I would like to check with you
>> if these issues are already corrected or can otherwise be workedaround.
>>
>> For now I rolled back to the old CDateTime and miss the chance to run my
>> app on a Vista box.
>>
>> Please advice.
>>
>> Thanks,
>> Liviu
Re: CDateTime issues since 26 January? [message #593826 is a reply to message #62876] Mon, 02 March 2009 10:54 Go to previous message
Liviu-Marian Negrila is currently offline Liviu-Marian Negrila
Messages: 53
Registered: July 2009
Member
Hi Jeremy,

I forgot to tell you my hours tend to be quite long sometimes.

Here are the bugs:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=266694
https://bugs.eclipse.org/bugs/show_bug.cgi?id=266698

I'd offer my time to correct this but I don't really know where to
start; on the other hand my client has already moved some systems on
Vista and, you guessed it, I'm rather desperate.
Please advice.

Thanks
Liviu

Liviu wrote:
> Hi Jeremy,
>
> They happen on XP.
>
> I only tested on Vista that it would not kill the menu bar and it didn't
> but on XP I had that focus problem you identified.
>
> I did not test on vista for those bugs. I may do so next week
> (Monday-Tuesday?).
>
> I will file the bugs in about 20 hours.
>
> Thanks
> Liviu
>
> Jeremy Dowdall wrote:
>> Hi Liviu,
>>
>> Thanks for the excellent and thorough description of this problem. The
>> first actually sounds like an internal focus problem - do these issues
>> happen on XP or is it specific to Vista?
>> Please file a bug for each of these and I'll try to get to them shortly
>> - I just haven't had time to run Vista lately.
>>
>> Liviu wrote:
>>> Hello,
>>>
>>> I've checked out the CDateTime project from the eclipse CVS and got it
>>> working in my application on the 26 January.
>>>
>>> I did that becouse the old CDateTime I've used would't work correctly a
>>> Vista system (the menu bar would dissapear under a white bar after the
>>> drop down composite would show).
>>>
>>> The 26 January version I got from the eclipse CVS corrected this problem
>>> but I had other issues:
>>>
>>> - If I would open and close the drop down 4 times in a row by clicking
>>> on the botton (aka arrow button in a normal combo) then the CDateTime
>>> would start to preselect days (Ex it would auto-select the day 21 and if
>>> I pressed on 15 without going with the mouse over 21 a priori then it
>>> would still select the 21rst day of that date - it could trick the user
>>> that he selected the 15 but actually the CDateTime selected 21 or so;
>>> note that after the 4th drop of the combo the date that it
>>> 'auto-selected' kept changing circulary following a diagonal pattern
>>> parallel with the secondary diagonal of the square)
>>>
>>> - moreover if I tried to use the arrows on the keyboard to change the
>>> selection then the whole app would freeze
>>>
>>> I did a compare with the date 26 january to check weather there have
>>> been changes that could correct this but I would like to check with you
>>> if these issues are already corrected or can otherwise be workedaround.
>>>
>>> For now I rolled back to the old CDateTime and miss the chance to run my
>>> app on a Vista box.
>>>
>>> Please advice.
>>>
>>> Thanks,
>>> Liviu
Re: CDateTime issues since 26 January? [message #593834 is a reply to message #62897] Mon, 02 March 2009 20:08 Go to previous message
Jeremy Dowdall is currently offline Jeremy Dowdall
Messages: 181
Registered: July 2009
Senior Member
> I forgot to tell you my hours tend to be quite long sometimes.

no problem, that happens :)

thanks for filing the bugs, I'll follow up there...
Previous Topic:GridTableViewer and sorting
Next Topic:GridViewer - Getting notifed when a record gets invisible through vertical scrolling
Goto Forum:
  


Current Time: Fri Apr 18 04:04:49 EDT 2014

Powered by FUDForum. Page generated in 0.04935 seconds