Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » Getting custom Yahoo provider to work
Getting custom Yahoo provider to work [message #624016] Thu, 07 August 2008 18:39 Go to next message
Jake is currently offline Jake
Messages: 3
Registered: July 2009
Junior Member
Hello,

I am new to ECF and am trying to write a custom provider to connect into
ECF for a custom chat program. To get familiar with how things work, I am
trying to get the custom Yahoo provider that was written here
( http://www-128.ibm.com/developerworks/opensource/library/os- ecl-commfwk/)
working, and I'm not having any success. I downloaded the source code and
tried putting the org.eclipse.ecf.provider.yahoo directory in the
eclipse/plugins directory and it didn't work (i.e. I didn't see Yahoo as
an entry when trying to connect to a provider. If anyone has any
suggestions, or something simple that I am forgetting, I would greatly
appreciate it.

Thanks
Re: Getting custom Yahoo provider to work [message #624017 is a reply to message #624016] Thu, 07 August 2008 18:59 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
Hi Jake,

I think the Yahoo provider that was done as part of the article is now
out of date. We do have a up-to-date version of the Yahoo provider
available here, however: http://ecf1.osuosl.org

The source code for that is also available...there are instructions for
CVS access at the bottom of the page.

Even the up-to-date version of the Yahoo provider can/could be
improved...and we have not been able to do a lot with it recently. If
you are able to update it and make improvements, please consider
contributing them back to the project.

Thanks!

Scott



Jake wrote:
> Hello,
>
> I am new to ECF and am trying to write a custom provider to connect into
> ECF for a custom chat program. To get familiar with how things work, I
> am trying to get the custom Yahoo provider that was written here
> ( http://www-128.ibm.com/developerworks/opensource/library/os- ecl-commfwk/)
> working, and I'm not having any success. I downloaded the source code
> and tried putting the org.eclipse.ecf.provider.yahoo directory in the
> eclipse/plugins directory and it didn't work (i.e. I didn't see Yahoo as
> an entry when trying to connect to a provider. If anyone has any
> suggestions, or something simple that I am forgetting, I would greatly
> appreciate it.
>
> Thanks
>
>
Re: Getting custom Yahoo provider to work [message #624019 is a reply to message #624017] Thu, 07 August 2008 19:22 Go to previous message
Jake is currently offline Jake
Messages: 3
Registered: July 2009
Junior Member
Great, thanks! I'll take a look at this.
Previous Topic:Notes from ECF conference call 8/7/2008
Next Topic:REMINDER: ECF conference call TODAY at 11am pacific/1800 UTC
Goto Forum:
  


Current Time: Wed Sep 17 19:37:41 GMT 2014

Powered by FUDForum. Page generated in 0.05076 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software