Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Calling help from a different RCP app
Calling help from a different RCP app [message #623974] Thu, 25 March 2010 15:41 Go to next message
cbhunni is currently offline cbhunni
Messages: 9
Registered: March 2010
Junior Member
Hello,
I have created a help contents plugin. I can bring up the help system from a view toolbar button successfully if I am running my own RCP stand-alone application using the following code:
...
PlatformUI.getWorkbench().getHelpSystem().displayHelpResourc e( "/gov.usgs.jem.model.spoonbill.help/html/toc.html");
...

But I have also exported my view plugins to be run from someone else's RCP application. Everything works fine except the help is NOT opening or doing anything when calling the line above.

The following line also returns true if that helps (which gives me a little hope): PlatformUI.getWorkbench().getHelpSystem().hasHelpUI()

Would anyone have any suggestions???
Thanks for any help! :)
Re: Calling help from a different RCP app [message #623994 is a reply to message #623974] Mon, 29 March 2010 19:13 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris Goldthorpe
Messages: 815
Registered: July 2009
Senior Member
Most likely the RCP app does not include all of the plug-ins required by help. Did you take a look at this Eclipse corner article on adding help to an RCP application?

http://www.eclipse.org/articles/article.php?file=Article-Add ingHelpToRCP/index.html
Re: Calling help from a different RCP app [message #624083 is a reply to message #623994] Wed, 31 March 2010 14:08 Go to previous message
cbhunni is currently offline cbhunni
Messages: 9
Registered: March 2010
Junior Member
Thanks so much Chris! :) Definitely made me look closer at the plugins being packaged with my non-rcp export.

Just in case anyone else has this issue, seems I was missing the following plugins that the help needs...

org.apache.jasper_5.5.17.v200806031609.jar
org.eclipse.equinox.http.jetty_1.1.0.v20080425.jar
org.eclipse.equinox.http.registry_1.0.100.v20080427-0830.jar
org.eclipse.equinox.http.servlet_1.0.100.v20080427-0830.jar
org.eclipse.equinox.jsp.jasper.registry_1.0.0.v20080427-0830 .jar
org.eclipse.equinox.jsp.jasper_1.0.100.v20080427-0830.jar
org.eclipse.help.webapp_3.3.101.M20080805_34x.jar
org.eclipse.osgi.services_3.1.200.v20071203.jar
org.mortbay.jetty_5.1.14.v200806031611.jar
org.apache.commons.el_1.0.0.v200806031608.jar
org.apache.commons.logging_1.0.4.v20080605-1930.jar

I added them to my feature (which my product was based on) using the Plug-ins tab. Maybe there's another way I should have added them. Not sure. Anyway, just thrilled that it's now working. Woohoo!
Previous Topic:Calling help from a different RCP app
Next Topic:Turn filtering on/off in the Infocenter
Goto Forum:
  


Current Time: Mon Oct 20 23:06:48 GMT 2014

Powered by FUDForum. Page generated in 0.01857 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software