Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » XMPPS does not work in intranet
XMPPS does not work in intranet [message #623685] Mon, 09 June 2008 08:08 Go to next message
Harish is currently offline Harish
Messages: 6
Registered: July 2009
Junior Member
Hello
If I use XMPPS service from intranet connection to talk.google.com is not
established. Same works if the system is connected directly to internet.
Is this an issue of not using proxy?

Regards
Harish
Re: XMPPS does not work in intranet [message #623686 is a reply to message #623685] Mon, 09 June 2008 13:37 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
Harish,

Harish wrote:
> Hello
> If I use XMPPS service from intranet connection to talk.google.com is
> not established. Same works if the system is connected directly to
> internet. Is this an issue of not using proxy?

Yes, probably...or a particuarly nasty firewall. Have you tried
configuring the JRE to use the proxy?

Scott
Re: XMPPS does not work in intranet [message #623688 is a reply to message #623686] Tue, 10 June 2008 01:19 Go to previous messageGo to next message
Harish is currently offline Harish
Messages: 6
Registered: July 2009
Junior Member
I tried setting this in JRE. The problem still exists. I think this should
use proxy settings from Network Connections preference page.
Harish
Re: XMPPS does not work in intranet [message #623692 is a reply to message #623688] Tue, 10 June 2008 12:22 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
Hi Harish,

Harish wrote:
> I tried setting this in JRE. The problem still exists. I think this
> should use proxy settings from Network Connections preference page.

Yes, it should. But the current version of Smack 2.2.1 does not support
proxies very effectively so this requires an update of the Smack library.

I've created bug (and dependent)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=236455

Scott
Re: XMPPS does not work in intranet [message #623693 is a reply to message #623688] Tue, 10 June 2008 12:28 Go to previous message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
Hi Harish,

Harish wrote:
> I tried setting this in JRE. The problem still exists. I think this
> should use proxy settings from Network Connections preference page.

Yes, it should. But the current version of Smack 2.2.1 does not support
proxies very effectively so this requires an update of the Smack library.

I've created bug (and dependent for smack 3.0.0 support)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=236455

Scott
Previous Topic:ECF 2.1+ Equinox XMPP server
Next Topic:An exception is occured when it is starting Eclipse
Goto Forum:
  


Current Time: Fri Aug 22 01:57:41 EDT 2014

Powered by FUDForum. Page generated in 0.01712 seconds