Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » Question with jslp library included in ECF jslp provider
Question with jslp library included in ECF jslp provider [message #623471] Wed, 30 April 2008 18:40 Go to next message
Phuong Hoang is currently offline Phuong Hoang
Messages: 10
Registered: July 2009
Junior Member
Hi all,
It's great to see the bug with ServiceProperties get fixed so fast. Thank
you very much for your hard work.

Anyway, I have another question regarding the jslp library included in the
download of ECF at http://www.eclipse.org/ecf/downloads.php
The library of jslp downloaded is
"ch.ethz.iks.slp_1.0.0.RC2_v200803061811.jar" which is not a OSGI version
but a standalone version of jSLP instead.
=> This leaves the org.eclipse.ecf.provider.jslp un-operational because it
cannot find Locator or Advertiser registered as OSGI services.

When replaced with OSGI version of jslp downloaded from sourceforge, the
jslp ECF provider works fine.

So I'm wondering if that jslp library (RC2_v200803031811) is the correct
one?

Phuong Hoang
Re: Question with jslp library included in ECF jslp provider [message #623474 is a reply to message #623471] Fri, 02 May 2008 08:28 Go to previous messageGo to next message
Markus Kuppe is currently offline Markus Kuppe
Messages: 177
Registered: July 2009
Senior Member
Phuong Hoang wrote:
> Anyway, I have another question regarding the jslp library included in the
> download of ECF at http://www.eclipse.org/ecf/downloads.php
> The library of jslp downloaded is
> "ch.ethz.iks.slp_1.0.0.RC2_v200803061811.jar" which is not a OSGI version
> but a standalone version of jSLP instead.
> => This leaves the org.eclipse.ecf.provider.jslp un-operational because it
> cannot find Locator or Advertiser registered as OSGI services.
>
> When replaced with OSGI version of jslp downloaded from sourceforge, the
> jslp ECF provider works fine.
>
> So I'm wondering if that jslp library (RC2_v200803031811) is the correct
> one?

Hi,

it is an OSGi bundle, but it lacks the Bundle-Activator OSGi header as
well as the activator class ch.ethz.iks.slp.impl.Activator. Orbit must
have accidentally used the non-OSGi sf.net jSLP jar. I've filed
https://bugs.eclipse.org/bugs/show_bug.cgi?id=229922

Cheers,
Markus

P.S.: If you feel comfortable with it, I'd suggest using trunk of
http://jslp.sf.net anyway. It contains a few bug fixes too. Updates in
Orbit usually take a while because of the IP process.
Re: Question with jslp library included in ECF jslp provider [message #623498 is a reply to message #623474] Fri, 02 May 2008 20:44 Go to previous messageGo to next message
Phuong Hoang is currently offline Phuong Hoang
Messages: 10
Registered: July 2009
Junior Member
Hi Markus,
Thanks very much for clarification,

Phuong Hoang

"Markus Alexander Kuppe" <news.eclipse.org.08@lemmster.de> wrote in message
news:fvejaq$bt2$1@build.eclipse.org...
> Phuong Hoang wrote:
>> Anyway, I have another question regarding the jslp library included in
>> the download of ECF at http://www.eclipse.org/ecf/downloads.php
>> The library of jslp downloaded is
>> "ch.ethz.iks.slp_1.0.0.RC2_v200803061811.jar" which is not a OSGI version
>> but a standalone version of jSLP instead.
>> => This leaves the org.eclipse.ecf.provider.jslp un-operational because
>> it cannot find Locator or Advertiser registered as OSGI services.
>>
>> When replaced with OSGI version of jslp downloaded from sourceforge, the
>> jslp ECF provider works fine.
>>
>> So I'm wondering if that jslp library (RC2_v200803031811) is the correct
>> one?
>
> Hi,
>
> it is an OSGi bundle, but it lacks the Bundle-Activator OSGi header as
> well as the activator class ch.ethz.iks.slp.impl.Activator. Orbit must
> have accidentally used the non-OSGi sf.net jSLP jar. I've filed
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=229922
>
> Cheers,
> Markus
>
> P.S.: If you feel comfortable with it, I'd suggest using trunk of
> http://jslp.sf.net anyway. It contains a few bug fixes too. Updates in
> Orbit usually take a while because of the IP process.
Re: Question with jslp library included in ECF jslp provider [message #623499 is a reply to message #623498] Tue, 06 May 2008 05:47 Go to previous messageGo to next message
Markus Kuppe is currently offline Markus Kuppe
Messages: 177
Registered: July 2009
Senior Member
Phuong Hoang wrote:
> Hi Markus,
> Thanks very much for clarification,
>
> Phuong Hoang
>
> "Markus Alexander Kuppe" <news.eclipse.org.08@lemmster.de> wrote in message
> news:fvejaq$bt2$1@build.eclipse.org...
>> Phuong Hoang wrote:
>>> Anyway, I have another question regarding the jslp library included in
>>> the download of ECF at http://www.eclipse.org/ecf/downloads.php
>>> The library of jslp downloaded is
>>> "ch.ethz.iks.slp_1.0.0.RC2_v200803061811.jar" which is not a OSGI version
>>> but a standalone version of jSLP instead.
>>> => This leaves the org.eclipse.ecf.provider.jslp un-operational because
>>> it cannot find Locator or Advertiser registered as OSGI services.
>>>
>>> When replaced with OSGI version of jslp downloaded from sourceforge, the
>>> jslp ECF provider works fine.
>>>
>>> So I'm wondering if that jslp library (RC2_v200803031811) is the correct
>>> one?
>> Hi,
>>
>> it is an OSGi bundle, but it lacks the Bundle-Activator OSGi header as
>> well as the activator class ch.ethz.iks.slp.impl.Activator. Orbit must
>> have accidentally used the non-OSGi sf.net jSLP jar. I've filed
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=229922
>>
>> Cheers,
>> Markus
>>
>> P.S.: If you feel comfortable with it, I'd suggest using trunk of
>> http://jslp.sf.net anyway. It contains a few bug fixes too. Updates in
>> Orbit usually take a while because of the IP process.

Hi Phuong,

the problem has been solved. Please verify with builds > 20080505.

Thanks
Markus
Re: Question with jslp library included in ECF jslp provider [message #623500 is a reply to message #623499] Tue, 06 May 2008 06:03 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
One thing to point out...the jslp provider is built by the Orbit project

http://www.eclipse.org/orbit

and they only do builds occasionally, so it may be a few days until ECF
can consume a new Orbit build.

I will make a request for another Orbit build to pick up these changes
and we will get them in place as soon as possible.

Scott


Markus Alexander Kuppe wrote:
> Phuong Hoang wrote:
>> Hi Markus,
>> Thanks very much for clarification,
>>
>> Phuong Hoang
>>
>> "Markus Alexander Kuppe" <news.eclipse.org.08@lemmster.de> wrote in
>> message news:fvejaq$bt2$1@build.eclipse.org...
>>> Phuong Hoang wrote:
>>>> Anyway, I have another question regarding the jslp library included
>>>> in the download of ECF at http://www.eclipse.org/ecf/downloads.php
>>>> The library of jslp downloaded is
>>>> "ch.ethz.iks.slp_1.0.0.RC2_v200803061811.jar" which is not a OSGI
>>>> version but a standalone version of jSLP instead.
>>>> => This leaves the org.eclipse.ecf.provider.jslp un-operational
>>>> because it cannot find Locator or Advertiser registered as OSGI
>>>> services.
>>>>
>>>> When replaced with OSGI version of jslp downloaded from sourceforge,
>>>> the jslp ECF provider works fine.
>>>>
>>>> So I'm wondering if that jslp library (RC2_v200803031811) is the
>>>> correct one?
>>> Hi,
>>>
>>> it is an OSGi bundle, but it lacks the Bundle-Activator OSGi header
>>> as well as the activator class ch.ethz.iks.slp.impl.Activator. Orbit
>>> must have accidentally used the non-OSGi sf.net jSLP jar. I've filed
>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=229922
>>>
>>> Cheers,
>>> Markus
>>>
>>> P.S.: If you feel comfortable with it, I'd suggest using trunk of
>>> http://jslp.sf.net anyway. It contains a few bug fixes too. Updates
>>> in Orbit usually take a while because of the IP process.
>
> Hi Phuong,
>
> the problem has been solved. Please verify with builds > 20080505.
>
> Thanks
> Markus
ECF 2.0.0 M7a was: Re: Question with jslp library included in ECF jslp provider [message #623507 is a reply to message #623500] Wed, 07 May 2008 22:25 Go to previous message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
Hi Folks,

This morning, the Orbit build promoted the fix to this jSLP bundle to
the Orbit I-build (I20080505235349) to address this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=229922

In order to pick up the jSLP fix, I've done an M7a build for ECF, and
deployed it to the normal locations (see below). This build should fix
this issue...and I decided to build and deploy an M7a today so that
Phuong and others could test and verify it. This is the only change
from M7 done last night.

I've just completed the deploy to the download and update site. The
Eclipse replication may take a little while, but it should be ready
soon. Note that the version qualifier for this build is v20080507-1345.

ECF Download: http://www.eclipse.org/ecf/downloads.php
N&N: http://www.eclipse.org/ecf/NewAndNoteworthy.html
ECF Extras: http://ecf1.osuosl.org
CVS tag: v20080507-1345

Thanks...sorry about any trouble.

Scott


Scott Lewis wrote:
> One thing to point out...the jslp provider is built by the Orbit project
>
> http://www.eclipse.org/orbit
>
> and they only do builds occasionally, so it may be a few days until ECF
> can consume a new Orbit build.
>
> I will make a request for another Orbit build to pick up these changes
> and we will get them in place as soon as possible.
>
> Scott
>
>
> Markus Alexander Kuppe wrote:
>> Phuong Hoang wrote:
>>> Hi Markus,
>>> Thanks very much for clarification,
>>>
>>> Phuong Hoang
>>>
>>> "Markus Alexander Kuppe" <news.eclipse.org.08@lemmster.de> wrote in
>>> message news:fvejaq$bt2$1@build.eclipse.org...
>>>> Phuong Hoang wrote:
>>>>> Anyway, I have another question regarding the jslp library included
>>>>> in the download of ECF at http://www.eclipse.org/ecf/downloads.php
>>>>> The library of jslp downloaded is
>>>>> "ch.ethz.iks.slp_1.0.0.RC2_v200803061811.jar" which is not a OSGI
>>>>> version but a standalone version of jSLP instead.
>>>>> => This leaves the org.eclipse.ecf.provider.jslp un-operational
>>>>> because it cannot find Locator or Advertiser registered as OSGI
>>>>> services.
>>>>>
>>>>> When replaced with OSGI version of jslp downloaded from
>>>>> sourceforge, the jslp ECF provider works fine.
>>>>>
>>>>> So I'm wondering if that jslp library (RC2_v200803031811) is the
>>>>> correct one?
>>>> Hi,
>>>>
>>>> it is an OSGi bundle, but it lacks the Bundle-Activator OSGi header
>>>> as well as the activator class ch.ethz.iks.slp.impl.Activator. Orbit
>>>> must have accidentally used the non-OSGi sf.net jSLP jar. I've filed
>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=229922
>>>>
>>>> Cheers,
>>>> Markus
>>>>
>>>> P.S.: If you feel comfortable with it, I'd suggest using trunk of
>>>> http://jslp.sf.net anyway. It contains a few bug fixes too. Updates
>>>> in Orbit usually take a while because of the IP process.
>>
>> Hi Phuong,
>>
>> the problem has been solved. Please verify with builds > 20080505.
>>
>> Thanks
>> Markus
Previous Topic:ECF 2.0.0 M7
Next Topic:ECF 2.0M7 update broken?
Goto Forum:
  


Current Time: Wed Sep 17 21:49:46 GMT 2014

Powered by FUDForum. Page generated in 0.04139 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software