Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Eclipse Help System WAR file does not pick up plugin_customization
Eclipse Help System WAR file does not pick up plugin_customization [message #623415] Thu, 18 June 2009 20:38
robert ly is currently offline robert lyFriend
Messages: 16
Registered: July 2009
Junior Member
I am migrating some plugins that were previously hosted in the IEHS
standalone Eclipse help system to a Eclipse 3.4 Help system WAR
deployment. I set the eclipse.product property in config.ini to the plugin
that contains my plugin_customization.ini
(eclipse.product=com.emc.ic.help), but the customizations are not picked
up. They worked fine in the IEHS deployment. Here is the
plugin_customization file:

org.eclipse.help.base/banner=/com.emc.ic.help/banner.htm
org.eclipse.help.base/banner_height=110
org.eclipse.help.base/windowTitlePrefix=false
org.eclipse.help.base/linksView=false
org.eclipse.help.base/help_home=/com.emc.ic.help/using_syste m/about_the_system.html
org.eclipse.help/baseTOCS=/com.emc.ic.help/toc.xml

So, I went ahead and modified preferences.ini in org.eclipse.help.base to
get the banner to show up. That worked fine, but I assume this isn't
ideal. So I went to go do the same thing in the org.eclipse.help plugin to
get my plugins to be ordered, and even when modifying the preferences.ini
inside that plugin, I can't get my books to be ordered correctly.

Also, I clear my Tomcat cache every time I make a change. Any ideas? The
documentation on the WAR deployment is very sparse.
Previous Topic:cannot find intro page of exported product; image in intro.xml
Next Topic:Eclipse Help System WAR file does not pick up plugin_customization
Goto Forum:
  


Current Time: Fri Nov 28 13:46:12 GMT 2014

Powered by FUDForum. Page generated in 0.01498 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software