Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » Get expiration notice when sending message to Yahoo Messenger
Get expiration notice when sending message to Yahoo Messenger [message #622633] Tue, 18 March 2008 14:23 Go to next message
Eclipse User
Originally posted by: dickyjohan.gmail.com

Hi,
I tried creating a sample chat client using the latest ECF build. But
when I send the message, I got another message from Yahoo:
[?Warning: This version of Messenger will expire on April 2, 2008.
Please upgrade to the latest supported version:
http://messenger.yahoo.com Learn more: http://messenger.yahoo.com/eol]

I understand we are using the open source yjmsg. Does anyone know if
there are plans to upgrade or replace the library so that it works with
the new Yahoo Messenger?

Thanks,
Dicky Johan
hip10.com
Re: Get expiration notice when sending message to Yahoo Messenger [message #622635 is a reply to message #622633] Tue, 18 March 2008 18:56 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 970
Registered: July 2009
Senior Member
Hi Dicky,

Dicky Johan wrote:
> Hi,
> I tried creating a sample chat client using the latest ECF build. But
> when I send the message, I got another message from Yahoo:
> [?Warning: This version of Messenger will expire on April 2, 2008.
> Please upgrade to the latest supported version:
> http://messenger.yahoo.com Learn more: http://messenger.yahoo.com/eol]
>
> I understand we are using the open source yjmsg. Does anyone know if
> there are plans to upgrade or replace the library so that it works with
> the new Yahoo Messenger?

Well, I have good news on this.

I went to the jYmsg sourceforge page at: http://jymsg9.sourceforge.net/

and I see that there is a patch for jymsg to move to version 063. ECF's
yahoo provider is currently running on 061 (the code is available via
anonymous CVS, for those interested:

http://ecf1.osuosl.org

in plugins/org.eclipse.ecf.provider.yahoo

And after changing the plugin to use the 063 jymsg jar, it seems that
the message Dicky quotes above does not appear...that is, 063 seems to
fix the problem! (yeah). I've made the update to the ECF yahoo
provider (replaced the 061 jar with 063 jar), and tried some smoke
tests...it seems to work with 063.

This change to 063 been checked in to ecf1.osuosl.org as of 3:52 pacific
time on Tuesday, March 18. I'm not sure if this change will make it
into the daily build today (Tuesday) as our OSU osl daily build happens
right around this time (and may be underway/already done), but it will
be in tomorrow's daily build (Wed), and in subsequent integration (every
Monday), milestone (M6 next week) and release builds.

And if you would like to get it right away, you can get the plugin and
build it in your own workspace.

Thanks for the report. Hopefully this will work out for you and others.
Please let us know if not...and what else we can do.

Scott
Re: Get expiration notice when sending message to Yahoo Messenger [message #622636 is a reply to message #622635] Tue, 18 March 2008 19:25 Go to previous message
Eclipse User
Originally posted by: dickyjohan.gmail.com

Scott Lewis wrote:
> Hi Dicky,
>
> Dicky Johan wrote:
>> Hi,
>> I tried creating a sample chat client using the latest ECF build. But
>> when I send the message, I got another message from Yahoo:
>> [?Warning: This version of Messenger will expire on April 2, 2008.
>> Please upgrade to the latest supported version:
>> http://messenger.yahoo.com Learn more: http://messenger.yahoo.com/eol]
>>
>> I understand we are using the open source yjmsg. Does anyone know if
>> there are plans to upgrade or replace the library so that it works
>> with the new Yahoo Messenger?
>
> Well, I have good news on this.
>
> I went to the jYmsg sourceforge page at: http://jymsg9.sourceforge.net/
>
> and I see that there is a patch for jymsg to move to version 063. ECF's
> yahoo provider is currently running on 061 (the code is available via
> anonymous CVS, for those interested:
>
> http://ecf1.osuosl.org
>
> in plugins/org.eclipse.ecf.provider.yahoo
>
> And after changing the plugin to use the 063 jymsg jar, it seems that
> the message Dicky quotes above does not appear...that is, 063 seems to
> fix the problem! (yeah). I've made the update to the ECF yahoo
> provider (replaced the 061 jar with 063 jar), and tried some smoke
> tests...it seems to work with 063.
>
> This change to 063 been checked in to ecf1.osuosl.org as of 3:52 pacific
> time on Tuesday, March 18. I'm not sure if this change will make it
> into the daily build today (Tuesday) as our OSU osl daily build happens
> right around this time (and may be underway/already done), but it will
> be in tomorrow's daily build (Wed), and in subsequent integration (every
> Monday), milestone (M6 next week) and release builds.
>
> And if you would like to get it right away, you can get the plugin and
> build it in your own workspace.
>
> Thanks for the report. Hopefully this will work out for you and others.
> Please let us know if not...and what else we can do.
>
> Scott
Super! Way to go! I have tested it as well, and the warning has been
removed!

Dicky
Previous Topic:ECF 2.0.0M5d and integration builds
Next Topic:Skype connection wizard hangs
Goto Forum:
  


Current Time: Mon Sep 01 09:51:59 EDT 2014

Powered by FUDForum. Page generated in 0.01708 seconds