Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » M5 Update Problem with Eclipse 3.3.2
M5 Update Problem with Eclipse 3.3.2 [message #621818] Mon, 10 March 2008 12:13 Go to next message
Rhodan76  is currently offline Rhodan76 Friend
Messages: 70
Registered: July 2009
Member
Scott Lewis wrote:

> ECF 2.0.0 milestone 5 is now available.

> Note: this build works with both Eclipse 3.3 and 3.4 streams of the
> Eclipse Platform.

I'm using Eclipse 3.3.2 and trying to install ecf 2.0.0M5. But the
Update-Site list's for me not fulfilled dependecy to org.eclipse.ui
(3.4.0). Any hint to solve this problem ?

Greetings

Sebastian
Re: M5 Update Problem with Eclipse 3.3.2 [message #621819 is a reply to message #621818] Mon, 10 March 2008 12:32 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26237
Registered: July 2009
Senior Member
Sebastian,

This tells me that ECF 2.0.0 is targeting Eclipse 3.4 so you'll either
need to switch to using Eclipse 3.4 or you need to find an older version
of ECF that's based on Eclipse 3.3.x.


S.Schnabl wrote:
> Scott Lewis wrote:
>
>> ECF 2.0.0 milestone 5 is now available.
>
>> Note: this build works with both Eclipse 3.3 and 3.4 streams of the
>> Eclipse Platform.
>
> I'm using Eclipse 3.3.2 and trying to install ecf 2.0.0M5. But the
> Update-Site list's for me not fulfilled dependecy to org.eclipse.ui
> (3.4.0). Any hint to solve this problem ?
>
> Greetings
>
> Sebastian
>
>
Re: M5 Update Problem with Eclipse 3.3.2 [message #621820 is a reply to message #621819] Mon, 10 March 2008 14:08 Go to previous messageGo to next message
Rhodan76  is currently offline Rhodan76 Friend
Messages: 70
Registered: July 2009
Member
Ed Merks wrote:

> This tells me that ECF 2.0.0 is targeting Eclipse 3.4

That can be the trick. But please don't announce 2.0.0M5 to be compatible
with eclipse 3.3 on your download page anymore in this case.

Thx Sebastian
Re: M5 Update Problem with Eclipse 3.3.2 [message #621821 is a reply to message #621820] Mon, 10 March 2008 14:40 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26237
Registered: July 2009
Senior Member
Sebastian,

That's a very good point1 Hopefully the misinformation on the download
page will be corrected soon.


S.Schnabl wrote:
> Ed Merks wrote:
>
>> This tells me that ECF 2.0.0 is targeting Eclipse 3.4
>
> That can be the trick. But please don't announce 2.0.0M5 to be
> compatible with eclipse 3.3 on your download page anymore in this case.
>
> Thx Sebastian
>
Re: M5 Update Problem with Eclipse 3.3.2 [message #621822 is a reply to message #621820] Mon, 10 March 2008 19:03 Go to previous messageGo to next message
Scott Lewis is currently offline Scott LewisFriend
Messages: 974
Registered: July 2009
Senior Member
Hi Sebastian,

Yes, there were some erroneous 3.4 minimum dependencies present in
2.0.0M5b. In truth, 3.3 should work OK.

So these 3.4 dependencies are/will be removed, and a new integration
build (2.0.0M5c) will be done today (3/1/2008). Sorry about the trouble.

Scott



S.Schnabl wrote:
> Ed Merks wrote:
>
>> This tells me that ECF 2.0.0 is targeting Eclipse 3.4
>
> That can be the trick. But please don't announce 2.0.0M5 to be
> compatible with eclipse 3.3 on your download page anymore in this case.
>
> Thx Sebastian
>
Re: M5 Update Problem with Eclipse 3.3.2 [message #621823 is a reply to message #621822] Mon, 10 March 2008 19:09 Go to previous messageGo to next message
Scott Lewis is currently offline Scott LewisFriend
Messages: 974
Registered: July 2009
Senior Member
Created bug to track

https://bugs.eclipse.org/bugs/show_bug.cgi?id=222102

Scott Lewis wrote:
> Hi Sebastian,
>
> Yes, there were some erroneous 3.4 minimum dependencies present in
> 2.0.0M5b. In truth, 3.3 should work OK.
>
> So these 3.4 dependencies are/will be removed, and a new integration
> build (2.0.0M5c) will be done today (3/1/2008). Sorry about the trouble.
>
> Scott
>
>
>
> S.Schnabl wrote:
>> Ed Merks wrote:
>>
>>> This tells me that ECF 2.0.0 is targeting Eclipse 3.4
>>
>> That can be the trick. But please don't announce 2.0.0M5 to be
>> compatible with eclipse 3.3 on your download page anymore in this case.
>>
>> Thx Sebastian
>>
Re: M5 Update Problem with Eclipse 3.3.2 [message #621824 is a reply to message #621823] Mon, 10 March 2008 19:36 Go to previous messageGo to next message
Rhodan76  is currently offline Rhodan76 Friend
Messages: 70
Registered: July 2009
Member
Scott Lewis wrote:

>> build (2.0.0M5c) will be done today (3/1/2008).

It seems besides ecf you are working on a time-traveling machine ;-) Don't
worry, it confused me only a second.

Thank you for your great work with ecf !
Re: M5 Update Problem with Eclipse 3.3.2 [message #621825 is a reply to message #621824] Mon, 10 March 2008 19:42 Go to previous messageGo to next message
Scott Lewis is currently offline Scott LewisFriend
Messages: 974
Registered: July 2009
Senior Member
Hi Sebastian,

S.Schnabl wrote:
> Scott Lewis wrote:
>
>>> build (2.0.0M5c) will be done today (3/1/2008).
>
> It seems besides ecf you are working on a time-traveling machine ;-)

I wish :). Instead it's a stick '0' key :).

> Don't worry, it confused me only a second.
> Thank you for your great work with ecf !

Thanks.

Scott
Re: M5 Update Problem with Eclipse 3.3.2 [message #621828 is a reply to message #621822] Tue, 11 March 2008 11:32 Go to previous messageGo to next message
Rhodan76  is currently offline Rhodan76 Friend
Messages: 70
Registered: July 2009
Member
Thx, now i installed ecf 2.0.05c successful on eclipse 3.3.2.

But now i could not join a project-specific collaboration session anymore,
because the Communications Menu has completely disappeared from a
project's context-menu.
Re: M5 Update Problem with Eclipse 3.3.2 [message #621829 is a reply to message #621828] Tue, 11 March 2008 15:34 Go to previous messageGo to next message
Scott Lewis is currently offline Scott LewisFriend
Messages: 974
Registered: July 2009
Senior Member
Hi Sebastian,

For UI simplicity, I removed the project-specific context menu item.
Multiple workspace level collab connections are still supported,
however...and editor context menu has "Share Resource to Collaboration:
<username>" to share resource references.

Scott

S.Schnabl wrote:
> Thx, now i installed ecf 2.0.05c successful on eclipse 3.3.2.
> But now i could not join a project-specific collaboration session
> anymore, because the Communications Menu has completely disappeared from
> a project's context-menu.
>
Re: M5 Update Problem with Eclipse 3.3.2 [message #621830 is a reply to message #621829] Tue, 11 March 2008 16:04 Go to previous message
Rhodan76  is currently offline Rhodan76 Friend
Messages: 70
Registered: July 2009
Member
> Multiple workspace level collab connections are still supported,
> however...and editor context menu has "Share Resource to Collaboration:
> <username>" to share resource references.

Thx. Good to know.
Previous Topic:Re: Chat within Eclipse
Next Topic:RESCHEDULE: ECF conference call scheduled for 3/11/2008 moved to 3/13/2008
Goto Forum:
  


Current Time: Sat Nov 29 09:03:24 GMT 2014

Powered by FUDForum. Page generated in 0.04118 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software