Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » [UML] Problem running ATL standalone with UML files
[UML] Problem running ATL standalone with UML files [message #619678] Mon, 04 June 2007 11:37
Paul Gribben is currently offline Paul Gribben
Messages: 28
Registered: July 2009
Junior Member
Hi,

I wasn't sure whether to post this to the UML or ATL group, so I've posted
it to both.

I've been trying to put together a java launcher for ATL transformations
that use eclipse UML2 model files. I am currently getting a problem when
the transform attempts to resolve the 'hasStereotype' operation:

message: ERROR: could not find operation hasStereotype on Void having
supertypes: [OclAny]

I'm guessing that I need to register some extension or plugin element in
the standalone environment context, but can't figure out what to do. So
far I've registered the UML2 package doing this:

org.eclipse.uml2.uml.UMLPackage.eINSTANCE.getEFactoryInstanc e();

I also did the following (but am unsure if I needed to):

Map extensionToFactoryMap =
Resource.Factory.Registry.INSTANCE.getExtensionToFactoryMap( );
extensionToFactoryMap.put(UMLResource.FILE_EXTENSION,
UMLResource.Factory.INSTANCE);
extensionToFactoryMap.put(XMI2UMLResource.FILE_EXTENSION,
XMI2UMLResource.Factory.INSTANCE);

Any help would be greatly appreciated.

Thanks
Paul
Previous Topic:heavyweight extension in OMG specifications
Next Topic:[UML] Problem running ATL standalone with UML files
Goto Forum:
  


Current Time: Wed Apr 23 20:59:49 EDT 2014

Powered by FUDForum. Page generated in 0.01645 seconds