Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » VE 1.4 and Eclipse 3.6
VE 1.4 and Eclipse 3.6 [message #618403] Sat, 26 June 2010 20:23 Go to next message
Chris Missing name is currently offline Chris Missing name
Messages: 2
Registered: June 2010
Junior Member
Hi!

I have some problems installing VE 1.4 on a fresh Eclipse 3.6 IDE for Java EE Developers installation, because i get some dependency errors (see below). There are some infos in different threads and in this bugreport:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=301766

for VE 1.4 and Eclipse 3.5. I have tried to installed only the VE SDK but still get the dependency error. Are there any chances to install VE 1.4 on Eclipse 3.6 or do we need a new VE version?

Thanks in advance for a reply.
Chris

Dependency error:

Quote:
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Visual Editor SDK 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO (org.eclipse.ve.sdk.feature.group 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO)
> Software currently installed: Eclipse IDE for Java EE Developers 1.3.0.20100617-0521 (epp.package.jee 1.3.0.20100617-0521)
> Only one of the following can be installed at once:
> International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
> International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
> Cannot satisfy dependency:
> From: Eclipse IDE for Java EE Developers 1.3.0.20100617-0521 (epp.package.jee 1.3.0.20100617-0521)
> To: org.eclipse.epp.package.jee.feature.feature.group [1.3.0.20100617-0521]
> Cannot satisfy dependency:
> From: Java EE IDE Feature 1.3.0.20100617-0521 (org.eclipse.epp.package.jee.feature.feature.group 1.3.0.20100617-0521)
> To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
> Cannot satisfy dependency:
> From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
> To: org.eclipse.rcp.feature.group [3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS]
> Cannot satisfy dependency:
> From: Eclipse RCP 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS (org.eclipse.rcp.feature.group 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS)
> To: com.ibm.icu [4.2.1.v20100412]
> Cannot satisfy dependency:
> From: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
> To: org.eclipse.ve.java.core [1.3.0,2.0.0)
> Cannot satisfy dependency:
> From: Visual Editor Java Core 1.4.0.v20090826-1446 (org.eclipse.ve.java.core 1.4.0.v20090826-1446)
> To: bundle com.ibm.icu [3.4.4.1,4.1.0)
> Cannot satisfy dependency:
> From: Visual Editor SDK 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO (org.eclipse.ve.sdk.feature.group 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO)
> To: org.eclipse.ve.feature.group [1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk]
Re: VE 1.4 and Eclipse 3.6 [message #618404 is a reply to message #618403] Wed, 30 June 2010 06:03 Go to previous messageGo to next message
bigboban  is currently offline bigboban
Messages: 4
Registered: June 2010
Junior Member
I have same problem. On Eclipse 3.5 no problem, on 3.6 same error as Chris. :(


I use this online install site:

http://download.eclipse.org/tools/ve/updates/1.4/
Re: VE 1.4 and Eclipse 3.6 [message #618405 is a reply to message #618404] Wed, 30 June 2010 10:52 Go to previous messageGo to next message
Patrik Suzzi is currently offline Patrik Suzzi
Messages: 5
Registered: June 2010
Location: The Netherlands
Junior Member

Troubles installing VE 1.4 ( Visual Editor ) on Eclipse 3.6 Helios

I've used this update site:
http://download.eclipse.org/tools/ve/updates/1.4/

and I tried to install Visual Editor on different Eclipse distros:
- Eclipse RCP and RAP
- Eclipse Modeling (with incubating components)
- Eclipse Reporting.

In any case i get this error:
Cannot complete the install because one or more required items could not be found.
Software being installed: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd (org.eclipse.jem.feature.group 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
Missing requirement: Java EMF Model Utilities 2.0.200.R3_1_maintenance (org.eclipse.jem.util 2.0.200.R3_1_maintenance) requires 'bundle com.ibm.icu [3.8.1.1,4.1.0)' but it could not be found
Cannot satisfy dependency:
From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd (org.eclipse.jem.feature.group 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
To: org.eclipse.jem.util [2.0.200.R3_1_maintenance]

Anyone can help me ?
Re: VE 1.4 and Eclipse 3.6 [message #618407 is a reply to message #618403] Thu, 01 July 2010 11:46 Go to previous messageGo to next message
Pascal is currently offline Pascal
Messages: 2
Registered: July 2010
Junior Member
Hi, same problem here. Eclipse Helios for Java Dev.

Cannot complete the install because one or more required items could not be found.
Software being installed: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
Missing requirement: Visual Editor Common Data Editor 1.4.0.v20090826-1446 (org.eclipse.ve.cde 1.4.0.v20090826-1446) requires 'bundle com.ibm.icu [3.4.4.1,4.1.0)' but it could not be found
Cannot satisfy dependency:
From: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
To: org.eclipse.ve.cde [1.3.0,2.0.0)

My Plugins:
Mobile Tools
PDT
Pydev
Android Plugin for Eclipse.

A quick updaty by the plugin dev would be great.

Thanks!
Pascal
Re: VE 1.4 and Eclipse 3.6 [message #618408 is a reply to message #618403] Fri, 02 July 2010 01:41 Go to previous messageGo to next message
Nialsh is currently offline Nialsh
Messages: 2
Registered: July 2010
Junior Member
I'm having the same issue using Helios EE. Build id: 20100617-1415

Quote:
> Cannot complete the install because one or more required items could not be found.
> Software being installed: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
> Missing requirement: Visual Editor Java Core 1.4.0.v20090826-1446 (org.eclipse.ve.java.core 1.4.0.v20090826-1446) requires 'bundle com.ibm.icu [3.4.4.1,4.1.0)' but it could not be found
> Cannot satisfy dependency:
> From: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
> To: org.eclipse.ve.java.core [1.4.0.v20090826-1446]


I really don't want to write this GUI by hand. Please help!
Re: VE 1.4 and Eclipse 3.6 [message #618409 is a reply to message #618408] Mon, 05 July 2010 06:07 Go to previous messageGo to next message
Roland  is currently offline Roland
Messages: 6
Registered: November 2009
Junior Member
Same problem here. Trying to install VE 1.4 in Eclipse 3.6 Helios Build id: 20100617-1415 (a fresh install of Eclipse IDE for Java Developers, not EE version).

Like others, I have followed the steps outlined in the VE Wiki to the letter, but have the same problem.

I have had similar problems with 3.5 Galileo. I was advised at the time to just install VE SDK and none of the other options, but that never worked for me either.

As mentioned in other posts / forums, there seems to be a dependency around Java EMF. What conflict actually exists? Did
EMF break backwards compatibility? Why does it seem that a specific EMF version is required rather than a more generic >= N ?
Re: VE 1.4 and Eclipse 3.6 [message #618410 is a reply to message #618403] Mon, 05 July 2010 08:40 Go to previous messageGo to next message
Ben is currently offline Ben
Messages: 11
Registered: July 2009
Junior Member
Hi,

i just downloaded the ve plug-in. copied it to my plugins-folder and the modified the MANIFEST.MF of each single plug-in, removing the version information of the required bundles.

Works fine for me now :)

greetings,
Ben
Re: VE 1.4 and Eclipse 3.6 [message #618412 is a reply to message #618403] Tue, 06 July 2010 11:55 Go to previous messageGo to next message
Ben is currently offline Ben
Messages: 11
Registered: July 2009
Junior Member
Hi kit,

jar files are in fact just normal .zip files.
I am using Total Commander for example with a plug-in that handles .jar files as zip files. So i open it, edit the MANIFEST.MF in it and pack it back in.

It's that simple :)

greetz,
Ben
Re: VE 1.4 and Eclipse 3.6 [message #618413 is a reply to message #618403] Thu, 08 July 2010 04:13 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
The build for Helios is ongoing. It will be available soon.

Best regards
Yves YANG
"Chris" wrote in message
news:i05njj$ho2$1@build.eclipse.org...
> Hi!
>
> I have some problems installing VE 1.4 on a fresh Eclipse 3.6 IDE for Java
> EE Developers installation, because i get some dependency errors (see
> below). There are some infos in different threads and in this bugreport:
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=301766
>
> for VE 1.4 and Eclipse 3.5. I have tried to installed only the VE SDK but
> still get the dependency error. Are there any chances to install VE 1.4 on
> Eclipse 3.6 or do we need a new VE version?
>
> Thanks in advance for a reply.
> Chris
>
> Dependency error:
>
> Quote:
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Visual Editor SDK
>> 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO
>> (org.eclipse.ve.sdk.feature.group
>> 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO)
>> Software currently installed: Eclipse IDE for Java EE Developers
>> 1.3.0.20100617-0521 (epp.package.jee 1.3.0.20100617-0521)
>> Only one of the following can be installed at once: International
>> Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu
>> 4.2.1.v20100412)
>> International Components for Unicode for Java (ICU4J) 4.0.1.v20090822
>> (com.ibm.icu 4.0.1.v20090822)
>> Cannot satisfy dependency:
>> From: Eclipse IDE for Java EE Developers 1.3.0.20100617-0521
>> (epp.package.jee 1.3.0.20100617-0521)
>> To: org.eclipse.epp.package.jee.feature.feature.group
>> [1.3.0.20100617-0521]
>> Cannot satisfy dependency:
>> From: Java EE IDE Feature 1.3.0.20100617-0521
>> (org.eclipse.epp.package.jee.feature.feature.group 1.3.0.20100617-0521)
>> To: org.eclipse.platform.feature.group
>> [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
>> Cannot satisfy dependency:
>> From: Eclipse Platform
>> 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
>> (org.eclipse.platform.feature.group
>> 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
>> To: org.eclipse.rcp.feature.group
>> [3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS]
>> Cannot satisfy dependency:
>> From: Eclipse RCP 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS
>> (org.eclipse.rcp.feature.group 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS)
>> To: com.ibm.icu [4.2.1.v20100412]
>> Cannot satisfy dependency:
>> From: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk
>> (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
>> To: org.eclipse.ve.java.core [1.3.0,2.0.0)
>> Cannot satisfy dependency:
>> From: Visual Editor Java Core 1.4.0.v20090826-1446
>> (org.eclipse.ve.java.core 1.4.0.v20090826-1446)
>> To: bundle com.ibm.icu [3.4.4.1,4.1.0)
>> Cannot satisfy dependency:
>> From: Visual Editor SDK
>> 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO
>> (org.eclipse.ve.sdk.feature.group
>> 1.4.0.v20090826-1446-57F-9xKEUXK5__GAVDlmFRiymDdO)
>> To: org.eclipse.ve.feature.group
>> [1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk]
>

[Updated on: Mon, 19 November 2012 14:00] by Moderator

Report message to a moderator

Re: VE 1.4 and Eclipse 3.6 [message #618420 is a reply to message #618403] Mon, 09 August 2010 08:18 Go to previous messageGo to next message
bigboban  is currently offline bigboban
Messages: 4
Registered: June 2010
Junior Member
On this page

http://www.eclipse.org/projects/project-plan.php?projectid=t ools.ve

i see VE 1.5 was released on 06/28/2010.

Under "Release Deliverables" i see "..Project runtime binary features on eclipse.org update site (install via Eclipse update manager)..."

I think this is not true, because there is NO url with new VE 1.5.

So where can i download released VE 1.5??
Re: VE 1.4 and Eclipse 3.6 [message #618426 is a reply to message #618412] Thu, 19 August 2010 14:33 Go to previous messageGo to next message
hiro nakag is currently offline hiro nakag
Messages: 8
Registered: August 2010
Junior Member
Hi!

Thanks for Ben, I was able to install VE1.4 on Helios.
And it seems to be working fine for me too.

If there is a person who want to try the plugins that I modified, please look at http://sourceforge.jp/projects/tmdmaker/wiki/VisualEditor1.4 .0ForHelios

By the way,
".jar.pack.gz" can extract $JAVA_HOME/bin/unpack200 .

Thank you for your time.
Re: VE 1.4 and Eclipse 3.6 [message #618427 is a reply to message #618403] Tue, 24 August 2010 17:18 Go to previous messageGo to next message
Colargol is currently offline Colargol
Messages: 5
Registered: July 2009
Junior Member
Hiya nakag,

I downloaded, installed and (quickly) tried your setup... and it seems to work!!!

Thanks for the good work

- Colargol
Re: VE 1.4 and Eclipse 3.6 [message #618428 is a reply to message #618427] Wed, 25 August 2010 11:50 Go to previous messageGo to next message
hermann krauÃ? is currently offline hermann krauÃ?
Messages: 4
Registered: July 2009
Junior Member
thanks,
it seem to run on

Eclipse Java EE IDE for Web Developers.
Version: Helios Release
Build id: 20100617-1415

Herman
Re: VE 1.4 and Eclipse 3.6 [message #618429 is a reply to message #618428] Fri, 27 August 2010 09:51 Go to previous messageGo to next message
hermann krauÃ? is currently offline hermann krauÃ?
Messages: 4
Registered: July 2009
Junior Member
hi,

winxp is o.k.,

but there are problems on linux (sidux,debian 64 bit):
with openjdk, the controls are missplaced
with sun jdk, there is a runtime-error opening forms

but this problems are the same on eclipse 3.5.x since a few month ago

hermann
Re: VE 1.4 and Eclipse 3.6 [message #618430 is a reply to message #618429] Fri, 27 August 2010 23:48 Go to previous messageGo to next message
hiro nakag is currently offline hiro nakag
Messages: 8
Registered: August 2010
Junior Member
Hi,

The environment i modified VE1.4 is winxp.

For other platform, you might have to modified VE1.4 for yourself, following procedures. (written in japanese is http://d.hatena.ne.jp/nakaG/20100819#1282225964)

1. Install VE1.4 to eclipse galileo from updatesite.
2. Take VE1.4's features and plugins out of the installation features and plugins folder.
3. Extract plugin jar files.
4. Remove '; bundle-version = "[3.8.1.1, 4.1.0)"' from com.ibm.icu written in Require-Bundle of MANIFEST.MF.
5. Remove eclipse.inf, ECLIPSEF.RSA, ECLIPSEF.SF from META-INF folder.
6. Compress it again. (You can use jar command or zip archiver.)
7. Drop it on dropins folder.

You will have to modify the following files.

org.eclipse.jem.util_2.0.200.R3_1_maintenance.jar
org.eclipse.ve.cde_1.4.0.v20090826-1446.jar
org.eclipse.ve.java.core_1.4.0.v20090826-1446.jar
org.eclipse.ve.jfc_1.4.0.v20090826-1446.jar
org.eclipse.ve.propertysheet_1.4.0.v20090826-1446.jar
org.eclipse.ve.swt_1.4.0.v20090826-1446.jar

If you fail to install VE1.4 to galileo, i have no idea...

Thanks for reading my poor English.
Re: VE 1.4 and Eclipse 3.6 [message #630198 is a reply to message #618430] Fri, 01 October 2010 04:26 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 1
Registered: October 2010
Junior Member
On linux (Fedora 13) same problem here, can't get Visual Editor 1.4 to work with these versions of Eclipse :

eclipse-3.5.2-galileo-java
eclipse-3.6.1-helios-cpp
eclipse-3.6.1-helios-java_ee
eclipse-3.5.2-galileo-java_ee
eclipse-3.6.1-helios-java
eclipse-3.6-helios-classic_SDK
icon14.gif  Re: VE 1.4 and Eclipse 3.6 [message #631821 is a reply to message #618426] Fri, 08 October 2010 21:57 Go to previous messageGo to next message
MrCompiler Missing name is currently offline MrCompiler Missing name
Messages: 1
Registered: October 2010
Junior Member
I installed this following the instructions on your web page and it works perfectly. Thank you for taking the time to make this available.
Re: VE 1.4 and Eclipse 3.6 [message #631826 is a reply to message #630198] Fri, 08 October 2010 23:20 Go to previous message
hiro nakag is currently offline hiro nakag
Messages: 8
Registered: August 2010
Junior Member
Hello.

If VE1.4 installed onto galileo from updatesite didn't work,
it may not work well even if you modify VE1.4 by yourself only the same way that I did.

It seems that it is a problem of VE1.4.
Then, I think that you should try VE1.4 on this page,
if you have not done yet.
It might have to be modified by yourself the same way I did.

Thanks for reading my poor English.

[Updated on: Fri, 08 October 2010 23:38]

Report message to a moderator

Previous Topic:Installing VE
Next Topic:problem with an unavailable file
Goto Forum:
  


Current Time: Wed Sep 03 07:18:30 GMT 2014

Powered by FUDForum. Page generated in 0.03141 seconds