Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Verification Hook class problem in Linux
Verification Hook class problem in Linux [message #62393] Wed, 29 March 2006 19:27 Go to next message
Heidi Gumpert is currently offline Heidi Gumpert
Messages: 13
Registered: July 2009
Junior Member
Hi All,

I using TPTP version 4.2 February 28th (last stable build) on Red Hat
Enterprise 4. I am trying to use verifications hooks within my AGR
testcases. When I run my testsuite, I get an error saying it can't find
the verification hook class.

Did I miss a step in setting up the verification hook class? Has anybody
else tried this with success?

Thanks,
Heidi
Re: Verification Hook class problem in Linux [message #63178 is a reply to message #62393] Sat, 01 April 2006 06:06 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
Are you storing the verification hook class under a default package (i.e. no
package name)? This was a defect that I fixed in a later build. Take a
look at the location and the resource attributes of the verification hook
fragment. Make sure that the values are correct. The location attribute
should point to the folder where the class resides and the resource
attribute is the name of the class.

The problem with the default package name was caused because of a period
being added to the beginning of resource attribute's value. A workaround
would be to manually modify the resource attribute or to use a verification
hook class under a package name.

Alternatively, you can download a development build or wait until a stable
i2 build is released.
Let me know if you still experience the problem.

Example of a verification hook fragment:
<command type="verification"
contextId="view/org.eclipse.jdt.ui.PackageExplorer" location="/plugin/src"
resource="AutomatedTest" hook="verifyState:Qorg.eclipse.ui.IViewPart;"/>


"Heidi Gumpert" <hgumpert@qnx.com> wrote in message
news:dbd1b140d29752fed1c13d57ec789882$1@www.eclipse.org...
> Hi All,
>
> I using TPTP version 4.2 February 28th (last stable build) on Red Hat
> Enterprise 4. I am trying to use verifications hooks within my AGR
> testcases. When I run my testsuite, I get an error saying it can't find
> the verification hook class.
>
> Did I miss a step in setting up the verification hook class? Has anybody
> else tried this with success?
>
> Thanks,
> Heidi
>
Re: Verification Hook class problem in Linux [message #63583 is a reply to message #63178] Mon, 03 April 2006 19:41 Go to previous messageGo to next message
Heidi Gumpert is currently offline Heidi Gumpert
Messages: 13
Registered: July 2009
Junior Member
Hi,

I tried again with today's build (April 3rd) with no luck.

I am storing my verification hook class within a package name and the
resource attribute's value within my macro does not begin with a ".".

Please let me know if the error message in the execution result file
containing the stack trace is of use to you or if you would like to see my
macro.

Thanks for your help!

Heidi
Re: Verification Hook class problem in Linux [message #65645 is a reply to message #63583] Tue, 11 April 2006 17:55 Go to previous message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
Hi Heidi,

Yes, you're absolutely right. I tried this in Linux RedHat 9.0 and it
didn't work. I have opened the following defect
https://bugs.eclipse.org/bugs/show_bug.cgi?id=136157 to address the problem
in the third iteration of 4.2 (we're very close to finishing the second
iteration)


"Heidi Gumpert" <hgumpert@qnx.com> wrote in message
news:39253467ebc2380c26010ab0c44859c0$1@www.eclipse.org...
> Hi,
>
> I tried again with today's build (April 3rd) with no luck.
>
> I am storing my verification hook class within a package name and the
> resource attribute's value within my macro does not begin with a ".".
>
> Please let me know if the error message in the execution result file
> containing the stack trace is of use to you or if you would like to see my
> macro.
>
> Thanks for your help!
>
> Heidi
>
Previous Topic:eclipse automatically exit
Next Topic:Problem with runing AGR tests with Ant script without existing .metadata folder
Goto Forum:
  


Current Time: Wed Oct 22 09:47:57 GMT 2014

Powered by FUDForum. Page generated in 0.02646 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software