Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Modeling (top-level project) » cdo - unimplemented methods and missing repositories
cdo - unimplemented methods and missing repositories [message #617527] Mon, 27 July 2009 18:07
Eclipse UserFriend
Originally posted by: hamak.email.cz

Hi.
For the past couple of days I've been trying to learn cdo and to get it
to work with hibernate and mysql but unsuccessfully. I use Eclipse
Galileo on linux and I have followed these guides:
http://wiki.eclipse.org/CDO_Source_Installation and
http://wiki.eclipse.org/Getting_started_with_CDO_Galileo

The first problem I have is that there is an error in CDOIDHibernateImpl
because methods isExternal(), isNull() etc. are not implemented. These
methods are commented out in its primitive class AbstractCDOID. Is it right
to uncomment them or is there another way to solve it?

The second problem concerns repositories. When I run CDO server(it
starts without any errors) and try
to connect to it in the CDO Sessions view I get an error that says

Repository /repo1 not found
org.eclipse.emf.cdo.util.ServerException: Repository /repo1 not found
at
org.eclipse.emf.internal.cdo.net4j.protocol.OpenSessionReque st.confirming(OpenSessionRequest.java:79)
at
org.eclipse.emf.internal.cdo.net4j.protocol.OpenSessionReque st.confirming(OpenSessionRequest.java:1)
at
org.eclipse.emf.internal.cdo.net4j.protocol.CDOClientRequest .confirming(CDOClientRequest.java:77)
at
org.eclipse.net4j.signal.RequestWithConfirmation.doExtendedI nput(RequestWithConfirmation.java:123)
at org.eclipse.net4j.signal.Signal.doInput(Signal.java:312)
at
org.eclipse.net4j.signal.RequestWithConfirmation.doExecute(R equestWithConfirmation.java:103)
at org.eclipse.net4j.signal.SignalActor.execute(SignalActor.jav a:66)
at org.eclipse.net4j.signal.Signal.runSync(Signal.java:239)
at
org.eclipse.net4j.signal.SignalProtocol.startSignal(SignalPr otocol.java:423)
at
org.eclipse.net4j.signal.RequestWithConfirmation.doSend(Requ estWithConfirmation.java:87)
at
org.eclipse.net4j.signal.RequestWithConfirmation.send(Reques tWithConfirmation.java:73)
at
org.eclipse.emf.internal.cdo.net4j.protocol.CDOClientProtoco l.send(CDOClientProtocol.java:286)
at
org.eclipse.emf.internal.cdo.net4j.protocol.CDOClientProtoco l.openSession(CDOClientProtocol.java:78)
at
org.eclipse.emf.internal.cdo.session.CDOSessionImpl$Delegati ngSessionProtocol.openSession(CDOSessionImpl.java:1572)
at
org.eclipse.emf.internal.cdo.session.CDOSessionImpl.doActiva te(CDOSessionImpl.java:716)
at org.eclipse.net4j.util.lifecycle.Lifecycle.activate(Lifecycl e.java:65)
at
org.eclipse.net4j.util.lifecycle.LifecycleUtil.activate(Life cycleUtil.java:94)
at
org.eclipse.net4j.util.lifecycle.LifecycleUtil.activate(Life cycleUtil.java:84)
at
org.eclipse.net4j.util.container.ManagedContainer.getElement (ManagedContainer.java:285)
at
org.eclipse.net4j.util.container.ManagedContainer.getElement (ManagedContainer.java:265)
at
org.eclipse.emf.cdo.internal.ui.actions.OpenSessionAction.do Run(OpenSessionAction.java:67)
at
org.eclipse.net4j.util.ui.actions.LongRunningAction$1.run(Lo ngRunningAction.java:185)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)



and the console of the CDO sever says:

[ERROR] Factory not found: org.eclipse.emf.cdo.server.repositories[default]
org.eclipse.net4j.util.container.FactoryNotFoundException: Factory not
found: org.eclipse.emf.cdo.server.repositories[default]
at
org.eclipse.net4j.util.container.ManagedContainer.getFactory (ManagedContainer.java:193)
at
org.eclipse.net4j.util.container.ManagedContainer.createElem ent(ManagedContainer.java:490)
at
org.eclipse.net4j.util.container.ManagedContainer.getElement (ManagedContainer.java:281)
at
org.eclipse.net4j.util.container.ManagedContainer.getElement (ManagedContainer.java:265)
at
org.eclipse.emf.cdo.spi.server.RepositoryFactory.get(Reposit oryFactory.java:43)
at
org.eclipse.emf.cdo.spi.server.ContainerRepositoryProvider.g etRepository(ContainerRepositoryProvider.java:41)
at
org.eclipse.emf.cdo.server.internal.net4j.protocol.OpenSessi onIndication.responding(OpenSessionIndication.java:85)
at
org.eclipse.emf.cdo.server.internal.net4j.protocol.CDOServer Indication.responding(CDOServerIndication.java:112)
at
org.eclipse.net4j.signal.IndicationWithResponse.doExtendedOu tput(IndicationWithResponse.java:96)
at org.eclipse.net4j.signal.Signal.doOutput(Signal.java:282)
at
org.eclipse.net4j.signal.IndicationWithResponse.execute(Indi cationWithResponse.java:65)
at org.eclipse.net4j.signal.Signal.runSync(Signal.java:239)
at org.eclipse.net4j.signal.Signal.run(Signal.java:147)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Threa dPoolExecutor.java:886)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo lExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Thanks for your help
Ondrej Hamak
Previous Topic:EMF Migration - EDataType error
Next Topic:cdo - unimplemented methods and missing repositories
Goto Forum:
  


Current Time: Sat Nov 22 10:38:45 GMT 2014

Powered by FUDForum. Page generated in 0.02007 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software