Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » WikiText UI (and Mylyn Dependencies)
WikiText UI (and Mylyn Dependencies) [message #62200] Tue, 25 November 2008 16:53 Go to next message
Philip Quitslund is currently offline Philip Quitslund
Messages: 24
Registered: July 2009
Junior Member
I've been using Textile-J for a while (and loving it) and am getting to the
point where I want to start playing with implementing some extensions for the
editor (with an eye towards pushing them back to the community). In an effort
to keep up with the Joneses, I started to pull things out of CVS on eclipse.org
only to find that I need to pull in loads of Mylyn bits too. I'm curious why
there is this coupling? Shouldn't I be able to use (and contribute to) the
WikiText editor without the Mylyn tasks UI?

Thanks!


-phil
Re: WikiText UI (and Mylyn Dependencies) [message #62250 is a reply to message #62200] Tue, 25 November 2008 17:15 Go to previous messageGo to next message
David Green is currently offline David Green
Messages: 135
Registered: July 2009
Senior Member
Philip Quitslund wrote:
> ...I started to pull
> things out of CVS on eclipse.org only to find that I need to pull in
> loads of Mylyn bits too. I'm curious why there is this coupling?
> Shouldn't I be able to use (and contribute to) the WikiText editor
> without the Mylyn tasks UI?

Philip,

Glad to hear that you're enjoying WikiText (nee Textile-J)

You're right, these dependencies on Mylyn should be optional. To
contribute/code against the Textile-J UI you'll need to get the Mylyn
source or have the latest weekly Mylyn build installed, however to run
it you should not need to have Mylyn installed at all. I'm tracking
this issue here https://bugs.eclipse.org/bugs/show_bug.cgi?id=256510
since the Mylyn dependencies are not marked as optional in the bundle
manifest.

If you think that you should not need to have Mylyn in order to
contribute to the WikiText UI, then please post a bug

Regards,

David
Re: WikiText UI (and Mylyn Dependencies) [message #62274 is a reply to message #62250] Tue, 25 November 2008 17:59 Go to previous message
Philip Quitslund is currently offline Philip Quitslund
Messages: 24
Registered: July 2009
Junior Member
Hey David,

Thanks for following up.

> If you think that you should not need to have Mylyn in order to
> contribute to the WikiText UI, then please post a bug

I updated the bug you mentioned
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=256510) instead but will be happy
to open another if you'd prefer.

The more I think about it, the more I think this is an important thing to get
right now. WikiText has the potential to interest a broader community than
Mylyn and I wonder if having it as a subcomponent (esp. with deps.) might not
limit its audience? I'm not trying to sell Mylyn short (hey I was an early
adopter!) Nor am I diminishing the contribution to Mylyn WikiText can make. I
guess I'm just wondering if it appeal isn't potentially broader...

In any event, I do feel strongly that the WikiText editor should be a separable
component from the Mylyn task UI. If there's anything I can do to help in that
effort, please let me know.


Thanks!


-phil
Re: WikiText UI (and Mylyn Dependencies) [message #595016 is a reply to message #62200] Tue, 25 November 2008 17:15 Go to previous message
David Green is currently offline David Green
Messages: 96
Registered: July 2009
Member
Philip Quitslund wrote:
> ...I started to pull
> things out of CVS on eclipse.org only to find that I need to pull in
> loads of Mylyn bits too. I'm curious why there is this coupling?
> Shouldn't I be able to use (and contribute to) the WikiText editor
> without the Mylyn tasks UI?

Philip,

Glad to hear that you're enjoying WikiText (nee Textile-J)

You're right, these dependencies on Mylyn should be optional. To
contribute/code against the Textile-J UI you'll need to get the Mylyn
source or have the latest weekly Mylyn build installed, however to run
it you should not need to have Mylyn installed at all. I'm tracking
this issue here https://bugs.eclipse.org/bugs/show_bug.cgi?id=256510
since the Mylyn dependencies are not marked as optional in the bundle
manifest.

If you think that you should not need to have Mylyn in order to
contribute to the WikiText UI, then please post a bug

Regards,

David
Re: WikiText UI (and Mylyn Dependencies) [message #595024 is a reply to message #62250] Tue, 25 November 2008 17:59 Go to previous message
Philip Quitslund is currently offline Philip Quitslund
Messages: 24
Registered: July 2009
Junior Member
Hey David,

Thanks for following up.

> If you think that you should not need to have Mylyn in order to
> contribute to the WikiText UI, then please post a bug

I updated the bug you mentioned
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=256510) instead but will be happy
to open another if you'd prefer.

The more I think about it, the more I think this is an important thing to get
right now. WikiText has the potential to interest a broader community than
Mylyn and I wonder if having it as a subcomponent (esp. with deps.) might not
limit its audience? I'm not trying to sell Mylyn short (hey I was an early
adopter!) Nor am I diminishing the contribution to Mylyn WikiText can make. I
guess I'm just wondering if it appeal isn't potentially broader...

In any event, I do feel strongly that the WikiText editor should be a separable
component from the Mylyn task UI. If there's anything I can do to help in that
effort, please let me know.


Thanks!


-phil
Previous Topic:WikiText UI (and Mylyn Dependencies)
Next Topic:Mylyn WikiText Stand-Alone Package Available
Goto Forum:
  


Current Time: Sat Jul 26 09:19:31 EDT 2014

Powered by FUDForum. Page generated in 0.03282 seconds