Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » "This mapped class is not specified in persistence unit" and related issues
"This mapped class is not specified in persistence unit" and related issues [message #611853] Tue, 18 November 2008 01:06
Steve Kuo is currently offline Steve KuoFriend
Messages: 14
Registered: July 2009
Junior Member
I'm using the Dali/JPA Eclipse plugin as included in the download
wtp-R-3.0.3-20081113203138.zip

I'm getting the error "This mapped class is not specified in persistence
unit" on my @Entity annotation. I do have more than one persistent unit.
According to this message it's a limitation on Dali.
http://dev.eclipse.org/newslists/news.eclipse.technology.dal i/msg00521.html
So I have commented out all but one persistent unit in my persistence.xml
file. This does not work.

Furthermore when I try editing the JPA settings (Project-Properties-JPA) I
get the popup error dialog "The currently displayed page contains invalid
values". Is this Dali crashing?

Also, if I go to my persistence.xml file and select JPA Tools -
Synchronize Classes, I get an error popup saying "'Synchronize classes
has' encountered a problem". Clicking on Details reveals that it's a null
pointer exception.

I'm not sure what else to try short of getting an older version of the
plugin.
Thanks, Steve
Previous Topic:Shared persistence.xml
Next Topic:Problems running WTP 3.0.3 in Eclipse 3.4.1
Goto Forum:
  


Current Time: Sat Nov 29 07:47:16 GMT 2014

Powered by FUDForum. Page generated in 0.02038 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software